Jump to content

[Solved] Need help for video acceleration on NUC


Recommended Posts


I use a "simili Nuc" bought some years ago. I tried to install MacOS on it. I could do it, Ventura is booting and working partially, but not possible to activate video acceleration.

Here are some characteristics, name is Vorke V2 : 

- intel equiped with a i5-8250u, 16 Go ram, network running, video running but with Intel Graphics 620 7mb displayed.


OpenCore 0.9.8, kext and drivers removed.


Many thanks for help.






VorkeMAC.ioreg EFI.zip

Link to comment
Share on other sites

  • Administrators

Intel i5-8250U is Kaby Lake R with UHD 620 graphics (iGPU id 0x5917).


Looking at your posted IOReg + OC config, your injected graphics settings are incorrect:


  1. iGPU id 0x5917 is not natively supported. Please note that injecting hardware's own/native ids is useless and therefore totally unnecessary. Vendor id not to be specified in device id.
  2. No such thing as framebuffer layout 0x17590000 (or 0x59170000 which is presumably what you intended to use).
  3. Make sure to specify ids in the correct format and byte order; it needs to be from least significant to most significant. 0x80865917 must be entered as 17598680 and 0x59170000 must be entered as 00001759.


You need to refer to the KBL/ABL section of the WEG user manual for guidance. You must fake a supported KBL/ABL iGPU id (ideally 0x5916) and call on a valid KBL/ABL framebuffer layout (ideally supported desktop id 0x59120000). In a nutshell, you need to modify your graphics injected as follows:

AAPL,ig-platform-id        00001259        DATA
device-id                  16590000        DATA

You may experiment with other desktop values of course; please note that if you do not specify one, the default framebuffer layout id is 0x59160000 and it's a mobile layout (i.e. for laptops).


If you're game, you may experiment with laptop values too but this will require you to patch the framebuffer layout (no LVDS/eDP connector on a desktop) and you'll probably have to change your SMBIOS to that of a MacBook too. But I see no reason why desktop settings would not work.


KBL framebuffer 0x59120000 defines 3 x DP ports (i.e. connectors). Adjust as required if you have other types of video outputs (eg: DVI, HDMI)

ID: 59120000, STOLEN: 38 MB, FBMEM: 0 bytes, VRAM: 1536 MB, Flags: 0x0000110B
TOTAL STOLEN: 39 MB, TOTAL CURSOR: 1 MB (1572864 bytes), MAX STOLEN: 115 MB, MAX OVERALL: 116 MB (122171392 bytes)
Model name: Intel HD Graphics KBL CRB
Camellia: CamelliaDisabled (0), Freq: 1388 Hz, FreqMax: 1388 Hz
Mobile: 0, PipeCount: 3, PortCount: 3, FBMemoryCount: 3
[1] busId: 0x05, pipe: 9, type: 0x00000400, flags: 0x00000187 - ConnectorDP
[2] busId: 0x04, pipe: 10, type: 0x00000400, flags: 0x00000187 - ConnectorDP
[3] busId: 0x06, pipe: 10, type: 0x00000400, flags: 0x00000187 - ConnectorDP
01050900 00040000 87010000
02040A00 00040000 87010000
03060A00 00040000 87010000


Once you've fixed the injected iGPU properties of your OC config, cleared NVRAM at OC picker and rebooted, your IOReg will show you something that will look a bit like this, where your injected values should be reflected (laptop's settings below):


Link to comment
Share on other sites

Thanks for answer Hervé.

I tried with AAPL,ig-platform-id        00001259  and      device-id 16590000, black screen and reboot again and again.


If i remove device-id line and let only the first one, i can access the desktop. In fact, on the first line, i can put anything, it can boot, only the second line give me a black screen and reboot

Link to comment
Share on other sites

  • Administrators

If you boot without proper graphics settings, you're in what is called VESA mode, i.e. basic graphics without any form of acceleration but system more or less unusable because running slow and lots of graphics defects/glitches. Black screen means that you are getting there but there is another issue along the way. What kind of video output port do you use? VGA, DVI, HDMI?

Link to comment
Share on other sites

  • Administrators

Try the following additional properties in your iGPU settings:

framebuffer-con0-pipe 12000000 DATA
framebuffer-con0-type 00080000 DATA
framebuffer-con1-pipe 12000000 DATA
framebuffer-con1-type 00080000 DATA

I verified the old bootpack of the (Kaby Lake R / UHD 620) Latitude 7490 I had a few years ago and I had patched HDMI connector con1 that way. Then monitor your framebuffer connectors live in IOReg as you plug and unplug your HDMI cable.

Link to comment
Share on other sites

Same result, black screen and reboot. I have only HDMI output on this Nuc so no possible to see change in IOReg. Do you think I can modify acpi tables in the bios like in the beginning to increase Vram ?

Link to comment
Share on other sites

Hi Hervé,


Some news with some progress.

The system boot and I have now graphics acceleration but with some issues.

At the boot end, the display goes black, come back with the login display ,and then goes black again and stay black. I must disconnect hdmi connector and reconnect it to get the display again and after it is running correctly with acceleration.

Here joins are the new files

Have you an idea ?


Many thanks for help

EFI.zip Vorke.ioreg

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...