Jump to content

Latitude 5310 KP on sleep (Sleep Wake Failure in EFI)

Go to solution Solved by hidematu5310,

Recommended Posts

I did pmset restoredefaults again, and added your SSDT-S3 from the above post ("deepsleep_off").

I also disabled Low Power S0 Idle Capability in BIOS as you recommended:

>setup_var.efi 0x14 0x0 -n Setup


Using hibernatemode 25 the machine now hibernates with no battery discharge, and I can wake from the power button.


Thank you again for your work solving sleep for this model!

Link to comment
Share on other sites

  • Replies 22
  • Created
  • Last Reply

Top Posters In This Topic

On 6/15/2024 at 9:43 PM, hidematu5310 said:

Update 3:

hibernatemode 3 battery drain test for 1 hour.

Set standbydelay to about 5 minutes(300).

100% -> 98%


Update 4:

Fixed a potential problem where trackpad would stop working after rebooting from Windows or after Wake.


Update 5:

probably fixed instant wake on AC

recommended to add darkwake=0


SSDT-S3_upd5.zip 819 B · 1 download


I tried the "update 5" SSDT, but would get a wake on AC that triggered the Dell Diagnostic menu to run a test on the hard drive, causing the fan to spin at full speed.

"Update 2" SSDT still works for hibernatemode 25 (direct to hibernate), but for hibernatemode 3, I get video glitches after S3 sleep.


Would it be possible for you to re-post update 3?  Thanks!

Link to comment
Share on other sites

Try removing darkwake=x and changing it to hbfx-ahbm=129 and adding igfxfw=2.


If it does not work, remove this part of ssdt and test.

Name (SLTP, Zero)
Method (_TTS, 1, NotSerialized) // _TTS: Transition To State
    SLTP = Arg0
    If ((PWRS == Zero)){}


If it still does not work, try enable S3 as shown in the second image below.



ACPI Sleep State S3 (Suspend to RAM):

setup_var_cv Setup 0x6A5 0x1 0x2


S3 Video Repost:

setup_var_cv Setup 0x6A8 0x1 0x1


Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...