Jump to content

D620, 10.6.8 no sound


snoopers
 Share

Recommended Posts

I have tried to find something in the search but nothing helped so far...

 

I have installed Snow Leopard on my D620 (1.83GHz, C2D, Intel Graphics and Intel WiFi) (10.6.0 retail DVD). I used the installation guide provided by this site and everything went well until I installed the EDP framework which comes with the DMG-file from this website.

After letting the EDP framework do its work in the Terminal, the computer ends up with a kernel panic on every boot.

 

What I did then:

Installing the System again, but did not install the EDP framework after OS X installation.

I used KextHelper to install AppleACPIBatteryManager.kext which I got from a D620 kext.package somewhere in the net. This worked and I know have the battery symbol in the task bar.

Then I have installed all the kext-files provided by the D620 bootpack from this website (not sure if this made any sense as these are already part of the MyHack-Install-Disk).

 

Then I installed the 10.6.8 combo update. Everything is fine so far. But what do I have to do to get the Sound working?

Thanks for your help.

Link to comment
Share on other sites

  • Administrators

When you run EDP kext installation, make sure to select the correct model (LoRes vs HiRes) as DSDT table differs and will be overwritten.

 

Then I would suggest that, instead of predefined values,  you opt for your own settings and select:

. VoodooPS2Controller

. NullCPUPowerManagement

. SleepEnabler

. Emulated SpeedStep

. VoodooTSCsync

. patched AppleHDA STAC9200 for D620

. Voodoo Battery

 

Also, make sure your BIOS is set according to the recommended parameters.

 

I've just updated my EDP (it was at v4 r71, now at v4 r110) and I've just re-run kext installation as per above list on my D620 GMA950 LoRes running SL 10.6.8 -> All Ok, except sound which I've lost.

 

We're looking at the Sound problem, meantime it works with 'VoodooHDA (more stable)'.

Link to comment
Share on other sites

Thank you very much for the quick response!

 

I have applied the settings you suggested and everything works fine now. The only thing I had to choose different is the ApplePS2Controller as the Trackpad did not work with the VoodooPS2Controller.

 

Thanks for your help :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...