Jump to content

No Wake After Sleep on Notebook with Intel GMA 950 video on 10.6.8 AND 10.7.5


bisk
 Share

Recommended Posts

Aloha all,

I'm hoping someone can shed some light on a frustrating issue that I have encountered.  I have 2 very nice, nearly 100% functional HackBooks that both exhibit the exact same deficiency.  They will NOT wake from sleep.  I'm fairly sure that they KP on wake.  Usually they just stay black screen but every once in a while, I'll get a stack trace screen.  Only once was there actually a kext in the stack trace and that was IOSurface.kext.  

Both notebooks are ICH7 models with the Intel GMA 950 video chip.  One is a Toshiba Satellite A105, Core Duo T2500, 1GB RAM, etc. and the other is a Dell Inspiron E1505, Core 2 Duo T5600, 2GB RAM, etc.  Again, both have the Intel GMA 950.  

I have Snow Leo 10.6.8 w/ Chameleon 2-RC5-r752 on the Toshiba and Lion 10.7.5 w/ Chameleon 2.1-r1650 on the Dell.

Both systems are entirely vanilla except for the usual AppleACPIPS2Nub/ApplePS2Contoller/FakeSMC in /E/E and an AppleACPIPlatform rollback to Snow Leo + VoodooTSCSync for the Dell running Lion.  There are also the usual "legacy" mods to IOPlatformPluginFamily on both to  get native SpeedStep as well but other than a few added kexts for audio and LAN, that's about it.

Everything else works: QE, ResMan, LAN, WiFi, Audio ins and outs, SpeedStep, Sleep from the menu button and power button menu pop up and clamshell/lid but NO WAKE !

There is one other VERY KEY kext that must be changed, AppleIntelIntegratedFrameBuffer.

I have found that only a couple of "patched" versions will get me a display and both seem to be all the way back from Tiger based on the version number -> 1.4.20 !

I have also found one other from Dr. Hurt versioned 1.6.6 that seems more modern but all three still end with the same result, no wake from sleep.

 

Most of this was learned right here on this forum from the Dell Inspiron 6400 thread started by kannan.

 

https://osxlatitude.com/index.php?/topic/2039-dell-inspiron-6400/

If I try the proper Intel FrameBuffer for the exact release of OS X that I'm running, I get a black screen with cursor. I have tried most, if not all, the FrameBuffers from 10.5.8 all the way through 10.7.5.

I have tried a couple prescribed DSDT fixes, injecting GMA 950 values from the GFX0 device and removing CRT/DVI/TV devices but this makes no difference.

At this point, I'm guessing that this problem is caused by the old FrameBuffer.

So these are the details of my testing.

Has anyone else out there gotten wake from sleep working on their notebook with GMA 950 under either 10.6.8 or 10.7.5 ?

If so, please share.

Link to comment
Share on other sites

  • Administrators

Well, GMA950-based D620 and D430 do wake from sleep. But they require a BIOS system password (+ password bypass on wake) to be set or they will KP on wake! You could try that. I'd say it's likely to work on the Dell 1505.

  • Like 1
Link to comment
Share on other sites

OMG ! 

 

That's it !!!

 

I would have never in a billion years have ever thought to set a system password and then bypass it to make this fly.

 

Verified to do the trick on the E1505 for 10.7.5 for the most part.

 

I don't always get the trackpad back after waking if I sleep right at the login screen but from the desktop, it seems fine.

 

I did KP once.  Stack trace started in IONetworkingFamily->IO80211Fammily but I need to simplify my DSDT to remove a bunch of test code so that might improve things.

 

Merci mon ami !

Link to comment
Share on other sites

 Share

×
×
  • Create New...