Jump to content

Snow Leopard on D620 no sound


unbewusstsein
 Share

Recommended Posts

After the first boot in Snow Leopard i had no sound at all even, Sound prefs pane said there is no input nor no output devices.

 

But i had Ethernet working then, I've installed EDP.app and ran it.

 

First reboot after that, no more Ethernet.

 

Then i decided torun myHack.app reinstalling the original /Extra i had on my USB stick, here Ethernet connection reappered.

 

The USB stick was done using myHack + retail SL DVD, afterwards i used again myHack.app to install /Extra from Dell_Latitude_D620-intel-sl.zip.

 

(the one for D620 1280x800 video)

 

the Install EDP.dmg this the one found at http://argo.osxlatitude.com/edp/download/.

 

I think i'm doing something wrong but what ?

 

to be clear here is what I have actually in my /Extra folder :

 

d620:~ yt$ ls -al /Extra
total 88
drwxr-xr-x  10 root  wheel    340 18 jul  2011 .
drwxr-xr-x  33 root  admin   1190  4 fév 14:58 ..
-rwxr-xr-x   1 root  wheel   6148 23 mar  2012 .DS_Store
-rwxrwxrwx   1 root  wheel  21045 28 jan 12:23 DSDT.aml
drwxrwxrwx  11 root  wheel    374 18 jul  2011 Extensions
drwxrwxrwx   4 root  wheel    136  4 fév 09:10 RemovedExtensions
drwxrwxrwx   3 root  wheel    102 28 jan 12:23 Themes
-rwxrwxrwx   1 root  wheel    792  4 fév 14:23 org.chameleon.Boot.plist
-rwxrwxrwx   1 root  wheel     65  4 fév 14:23 org.chameleon.Boot.plist.plist
-rwxrwxrwx   1 root  wheel    843 28 jan 12:23 smbios.plist
 
what is in the backup folder :
d620:~ yt$ ls -al /Extra.backup.13-02-04/
total 80
drwxr-xr-x  17 root  wheel    578  4 fév 14:34 .
drwxr-xr-x  33 root  admin   1190  4 fév 14:58 ..
drwxr-xr-x   8 root  wheel    272  4 fév 14:33 .svn
drwxrwxrwx  12 root  wheel    408  4 fév 14:34 Extensions
drwxrwxrwx   4 root  wheel    136  4 fév 14:33 Themes
drwxrwxrwx  42 root  wheel   1428  4 fév 14:33 bin
drwxrwxrwx   4 root  wheel    136  4 fév 14:33 custom
-rwxrwxrwx   1 root  wheel  21045  4 fév 14:34 dsdt.aml
-rwxrwxrwx   1 root  wheel     83  4 fév 14:33 edptool.command
-rwxrwxrwx   1 root  wheel     97  4 fév 14:33 edpweb.command
drwxrwxrwx   4 root  wheel    136  4 fév 14:32 include
drwxrwxrwx   4 root  wheel    136  4 fév 14:34 model-data
drwxrwxrwx   8 root  wheel    272  4 fév 14:33 modules
drwxrwxrwx   4 root  wheel    136  4 fév 14:33 myHack.kext
-rwxrwxrwx   1 root  wheel    793  4 fév 14:34 org.chameleon.Boot.plist
-rwxrwxrwx   1 root  wheel    843  4 fév 14:34 smbios.plist
drwxrwxrwx  11 root  wheel    374  4 fév 14:33 storage
 
notice "Extra.backup.13-02-04" is my oxn backup of the Extra folder after running EDP and not having back Ethernet after reboot.

 

Link to comment
Share on other sites

Look for AppleHDA and Stac9200 kexts or VoodooHDA in your /Extra/Extensions folder. If they're missing, you'll have no sound.

 

Fine, thanks, Ive used "VoodooHDA-2.7.2.pkg" tne the kext is installed in /System/Extensions.

I think it doen't mater if its in /Extra or /System/Extensions

 

And hat about the fact using EDP brakes Ethernet, i should say the message given, from EDP.app, at terminal says some files/folders weren't found :

 

Copying sl kexts to /Extra/Extensions.. 

cp: /Extra/storage/standard/sl/Extensions/*: No such file or directory
                                                                                                                                                                                                                                                                Copying common kexts to /Extra/Extensions.. 

cp: /Extra/model-data/Dell_Latitude_D620-intel/common/Extensions/*: No such file or directory
                                                                                                                                                                                                                                                                Copying sl kexts to /Extra/Extensions.. 

cp: /Extra/model-data/Dell_Latitude_D620-intel/sl/Extensions/*: No such file or directory
                                                                                                                                                                                                                                                                Checking if we need ACPIfix 
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                          Checking if we need GMA950 Brightness fix 
  Applying custom plists, kexts etc. (you can ignore copy errors here, it just means the folder is empty)
cp: /Extra/include/Extensions/*: No such file or directory
                                                                                                                                                                                                                                                              cp: /Extra/include/*.aml: No such file or directory
                                                                                                                                                                                                                                                              cp: /Extra/include/*.plist: No such file or directory
                                                                                                                                                                                                                                                                Removing version control of kexts in /Extra/Extensions 

find: path: No such file or directory

 

 

The Model selected was :

Model selected: Dell_Latitude_D620-intel (Dell Latitude D620, Intel GMA950 graphics (1280x800))
 PS2 driver: 4
 Audio driver: 2
 GMA950 Brightness fix: 
 Battery driver: 1
 Install NullCPUPowerManagement: no
 Install SleepEnabler: no
 Install VoodooTSCsync: yes
 Update Chameleon to latest version: Yes 
 Use custom kernel: no
 Use custom chameleon: no
 Emulated speedstep: yes

Is this correct ? (y/n) 

y
Link to comment
Share on other sites

  • Administrators

Re: Ethernet, there should be a BCM57xxx kext in /E/E. I can't explain why that'd be missing all of a sudden. We need to look at EDP to check if that has gone missing for some reason.

 

I'll check things up on my D620 GMA950 tonight and let you know.

Link to comment
Share on other sites

Re: Ethernet, there should be a BCM57xxx kext in /E/E. I can't explain why that'd be missing all of a sudden. We need to look at EDP to check if that has gone missing for some reason.

 

I'll check things up on my D620 GMA950 tonight and let you know.

 

Fine thanks a lot, no at all BCM57xxx in my /E/E...

I can say even that i never had one neither using EDP bootpacks (ie. Dell_Latitude_D620-intel-sl.zip) nor after running EDP.app.

Link to comment
Share on other sites

 Share

×
×
  • Create New...