Jump to content

Dell D820, SSD support


dutchcow
 Share

Recommended Posts

  • Replies 31
  • Created
  • Last Reply

Top Posters In This Topic

Trim enabler doesn't detect it though. The system info tool should show "media types" but I'm missing that line completely. I wasn't sure where to post, some googling led me to believe it had to do with dtst. Is TRIM not support on non-ahci sata interfaces under OSX? It should work. Maybe I bought an incompatible one... TRIM works fine under Lion/ML on my D630. Guess I'm out of luck on the D820 when it comes to TRIM. The build-in garbage collection should be enough but I'm not too sure about it.

 

At least we know the Kingston V300 & V200+ SSD are compatible with the D630, sure you won't get the 400MB/s R/W but it sure is quieter and much much faster than the noisy and warm 7K2 drive and it was on offer  ;)

Link to comment
Share on other sites

I'm still at a loss on howto get TRIM to work under OSX. It is possible, I read some people put SSDs in their old non-ahci macbooks and it worked for them. Here's a screenshot of a clean win7 install on the D820: http://i.imgur.com/10fm0pu.png Everything works as it should. If anyone knows howto get TRIM to work under OSX on this machine let me know  :)

 

Edit 1: These guys use dsdt to force the ICH7 controller into AHCI mode, apparently it does support it. I've tried their DSDT method but it didn't work. Devices still don't have a media type in system info. My knowledge at this is very limited. How Windows can use TRIM/NCQ without AHCI is a riddle to me. Windows switches the ICH7-M in AHCI mode in the boot process.

 

Edit 2: After some fighting with phoenixtool refusing to add a new dsdt I finally managed to flash my bios with the fix and it didn't do anything. It is loaded though (verified with acpidump) and the machine works fine with the additions. But still no TRIM joy.

 

Edit 3: The final stretch. The controller does support AHCI mode under Linux, the trick above probably doesn work on the D820 dsdt without modification but I really have no idea how to do that. Here is some Linux stuff:

 

[email protected]:~# lspci -s 00:1f.2 -nnvvxxx | grep -i sata
00:1f.2 IDE interface [0101]: Intel Corporation 82801GBM/GHM (ICH7-M Family) SATA Controller [IDE mode] [8086:27c4] (rev 01) (prog-if 01 [PriO])
[email protected]:~# setpci -s 00:1f.2 90.b=40
[email protected]:~# setpci -s 00:1f.2 90.b
40
[email protected]:~# modprobe fakephp
[email protected]:~# echo 0 > /sys/bus/pci/slots/0000\:00\:1f.2/power
[email protected]:~# echo 1 > /sys/bus/pci/slots/0000\:00\:00.0/power
[email protected]:~# lspci -s 00:1f.2 -nnvvxxx | grep -i sata
00:1f.2 SATA controller [0106]: Intel Corporation 82801GBM/GHM (ICH7-M Family) SATA Controller [AHCI mode] [8086:27c5] (rev 01) (prog-if 01 [AHCI 1.0])
Link to comment
Share on other sites

Did some more research on those setpci commands, I can execute setpci commands via grub but there is no way to reinitialize the device as there no rescan option for the bus and no fakephp grub module. Another option was used a long time ago but the software that bootdisk is part of costs $25 today, and the free version has been wiped out from the internet. So still no joy. So close, yet so far. I have TRIM in every OS except the one I run.

Link to comment
Share on other sites

That only works once AHCI is working, it does the same as Trim Enabler. It shows enabled as the patch has been applied. But as long as the controller is running in ide (compatible) mode instead of native sata it will be hard. 

 

The speed benefit for normal drives could be noticed too. Right now the ICH7-M is speed limited, stuck in IDE compat mode. This is potentially very interesting for anyone with a ICH7-M chipset and no ability to turn AHCI on in the bios like me. Because it is supported and can be enabled either via setpci commands via an external boot disk or a properly patched DTST. This is why I originally replied in that thread but it was moved to a new topic here.

 

All we need is the DSDT fix fixed for the Dx20s with the ICH7-M chip to enable AHCI/force sata mode, the Linux kernel already does this. Windows has its own magic for gaining access to TRIM and NCQ. This should be possible under OSX too.

Link to comment
Share on other sites

  • Administrators

Did you try adding the SATA Chameleon module to /Extra/Module? I don't know if that adds AHCI support like Linux does though, but worth investigating...

 

Not owning a D820, I did not know AHCI mode was not available in the BIOS, so yes, you're right, the other alternative is a DSDT patch. Let's see what we can do here...

 

Copy attached patched DSDT table to /Extra then reboot with boot option: DSDT=DSDT_D820Intel_AHCI2.aml (don't replace your existing DSDT table in case the new table screws things up). Let us know if it works or not.

DSDT_D820Intel_AHCI2.zip

 

This patch should:

1) force device IDE0 at address 001F0002 (from 001F0001)

2) force ICH7-M device id to 0x27c5, i.e. the AHCI-capable version (from default 0x27c4)

 

Should this trick work, OS X would hopefully load AppleAHCIport + IOAHCIFamily kexts.

Link to comment
Share on other sites

It seems to hang on IO something, boot device stuff. It's expected if the patch works, I will put it on an install stick and try there. When I tried switching the interface via grub on the same disk the disk just dies/and or the OS can't find the drives. I think it has to be done from external boot disk, or from the memory. The bootdisk thats now behind a paywall can be loaded as an img file into the ram and then do setpci stuff and chainload any OS. Will report back on how it goes on an installer. I made a pic of the screen, it's kinda hard to read, but not impossible. Sorry about that.

http://i.imgur.com/ZvXyqKr.jpg (seems to miss the root device uuid in the string section?)

 

I will also try loading the DSDT from grub which chainloads into chameleon at the moment for testing those setpci commands. But it can also load DSDT tables. Grub is pretty neat, though still a bit limited as I cant reinitialize/rescan the bus with echo commands or anything else.

 

The installer loads fine in verbose mode, then loads the grey screen and then goes to black using this DSDT. Will try it on my USB Live Lion stick and see if it loads the ahci kexts. I think as long as the root device isn't using the controller it should be possible to switch it into sata mode and see the drives form the installer right?

Link to comment
Share on other sites

 Share


×
×
  • Create New...