Jump to content

Dimension e520 tower AKA: DM061


AWD_Guy
 Share

Recommended Posts

Hopping you Dell focused folks can help me out. Other sites assuming way more knowledge than I have to try and follow some of the plisting, KEXTing, injecting, etc...

Haven't messed with OSX86 much since Tiger on an old P4 a good while back, so be gentle. :)
 

Current project is a:

Dimension e520 tower AKA: DM061
     Intel E6300, 1.86Ghz, Intel® Coreâ„¢ 2 Duo-Conroe[Contemplating upgrading to Q6x00 if I get it working]
     Intel G965 Chipset
     Intel ICH8 Southbridge ATA/RAID (Dreadful thing)
     4 GB of DDR2
     Intel 825xx Gigabit Platform LAN
     Sigmatel 9227 Audio
     Intel® GMA X3000 On-board (Disabled)
     ATI Radeon x1300 PCI-E

 

More than willing to back up and start over with EDP, but here is where I am.


iboot (chameleon, stolen and rebranded)(GraphicsEnabler=No) + SL 10.6.3 retail install (From USB image thanks to my G4 Mini and DD) onto USB HD due to stupid ICH8 Controller.

System stable overnight. Audio works, Ethernet works Have to iboot (chameleon, stolen and rebranded) with GraphicsEnabler=No on. Sleep fails and just locks up screen saver rather than sleeping. Recovers though from key press.

 

After 10.6.8 Combo and Multi-beast in EasyBeast mode, no audio, had to check AppleIntelE1000e to get Ethernet back working. Added GraphicsEnabler=No to org.chameleon.Boot.plist to not have to type it every time.

System appears to work fine at first but if I leave the system alone for a few minutes, it goes into "I don't want to do anything mode". Mouse moves, but menus don't work, Pinwheels... Safari launches but then won't exit. Preferences won't open, just bounces for a while.

As I said, due to the terrible ICH8 controller, EVERYTHING drive related is USB right now. Enabling even my Windows HD on the controller causes boot failure. This also means no optical drive once booted. iboot (chameleon, stolen and rebranded) runs from CD fine.

I would prefer to leave it in RAID mode instead of ATA/RAID detect for Windows performance, but could swap it.

I will attack the ATI x1300 once Audio and hopefully SATA is working and it is stable on 10.6.8. It is on a cheap 15"LCD right now, so not a priority.

What/how do I log the boot processes or use to figure out what is going on. I'm guessing the Don't want to do anything mode is sleep or power saving related, but don't know.

I also built an iFail  S3v2 10.6.3 USB drive that is rock solid, no updates/tweaks at all. I would even say QE/CI is working. I don't get widget ripple, but screen saver test and chess work. Afraid to update it really since I haven't made an image of it yet. On the list for today.

Any help would be appreciated.

Link to comment
Share on other sites

  • Administrators

Hi, we should be able to get this particular model fully operational. You have the desktop version of the Intel G965 with ICH8 and that works pretty well in our well-known D630 (mobile version of the chipset of course). Nothing wrong with ICH8 as far as I'm concerned, well at least on laptops...

 

There's a good chance you can only install OS X with AHCI mode enabled for your HDD. That may not be an available option in the BIOS, in which case, you could be forced to stick with RAID mode settings (which does not mean you have to operate a RAID array).

 

The ATI X1300 should be able to operate fully in SL (and in SL only). Could you try and get the device id (may be through the Windows device driver properties if you're unfamiliar with that)? You're highly likely to require a patch for that (well, I did to get mine to work on my Vostro 200).

 

Audio and Ethernet already work, which is good. Audio should be supported by latest VoodooHDA kexts.

 

What I'd recommend you to do is the following:

1) create a myHack SL installer with default/Generic /Extra

2) if it's not already installed by default, add IOATAFamily kext to /Extra/Extensions. This kext should allow you to detect your HDD through the ICH8 SATA controller

3) re-run myHack->myFix (full) afterwards on your USB installer

4) edit your boot plist to disable GraphicsEnabler

 

See if that installer boots (with boot option GraphicsEnabler=No initially) and allows you to perform a basic SL 10.6.3 installation. If it does, you'll hopefully be able to reboot to complete your basic SL installation. We can then add the various kexts you require for LAN, audio (if it does not work OOB), video/graphics, etc.

 

For LAN, you can indeed use the IntelE1000e kext but we recommend the Intel82566MM kext.

For Video, have a look at my Vostro 200 guide in the EDP -> Supported Models section. Basically, you're probably gonna need an injecter + patched kexts.

 

Boot with -v flag to see what happens on screen.

 

You say the system seems to become unresponsive if you leave it idle and that sleep does not work -> it's probably because it requires a proper DSDT table to be provided. Have a look at the DSDT section to find out how to extract it and get it patched by Dinesh. But that can be looked into once you have all hardware working.

 

To me, this particular desktop should be able to run SL, Lion and ML without problems and in 32/64bit kernel mode. It will require a different graphics card for ML though, possibly for Lion too...

IOATAFamily.kext.zip

Intel82566MM.kext.zip

  • Like 1
Link to comment
Share on other sites

Up and running MyHack 10.6.3 version on USB HD.

 

Intel82566MM Ethernet working
 

No Audio


IOATAFamily is not seeing CD/DVD in RAID mode. checking other modes and enabling HD drives to see what happens.
 

Is there a way to write the -v boot data to a log file?

 

Can I use the ATI KEXTs out of the Vostro pack since they have the same Dev ID?

Do KEXTs in /extra superseed those in /system/library/extensions or do those need to be removed?

Do I still need the Chameleon GraphicsEnabler branch from Azimutz and make the associated changes. If so, where can I find it? There appear to be a few Azimutz branches at forge.voodooprojects.org.

 

Thanks again.
 

Link to comment
Share on other sites

Audio working using VoodooHDA 2.8.2 installer.
http://www.osx86.net/view/2746-voodoohda_2.8.2_pkg_installer.html

Still can't get anything on the ICH8. Any ideas?

 

Working on x1300 now.

 

Picked up an 8800GT from a friend since the 9800 is a 2 slot card and the chassis doesn't have a second slot above the PCI-E Slot. I aparently has native and NVidia downloadable drivers for SL,L,ML, so that is my backup. x1300 is now kind of a challenge like the ICH8.

Link to comment
Share on other sites

I lied and worked on the ICH8 some more. Drives now visible with

modified-ahciportinjector.kext

http://www.insanelymac.com/forum/topic/186653-modified-ahciportinjectorkext-no-more-orange-hds/
info.plist edited per:
http://legacy.tonycrapx86.com/viewtopic.php?f=79&t=21704

Is that enough to put a drive on it and boot, or do I have to do something with Chameleon?

Link to comment
Share on other sites

  • Administrators
Can I use the ATI KEXTs out of the Vostro pack since they have the same Dev ID?

Since you appear to have same X1300 card as in my Vostro 200, yes, just copy the 3 related kexts from the Vostro200 SL bootpack to /E/E (EVOenabler + ATIRadeonX1000 + ATI1300Controller).

 

Do I still need the Chameleon GraphicsEnabler branch from Azimutz and make the associated changes. If so, where can I find it? There appear to be a few Azimutz branches at forge.voodooprojects.org.

As I said at the bottom of the Vostro 200 guide, you no longer need the Azimutz Chameleon branch because newer versions of Chameleon (r2181 for instance) support the card. Install Chameleon Wizard and you'll be able to set Chameleon boot file to particular version within a recent range.

 

Do KEXTs in /extra superseed those in /system/library/extensions or do those need to be removed

With the use of myHack, yes, kexts in /E/E supersede their equivalent/counterpart in /S/L/E. As such, no need to do anything to kexts in /S/L/E; they can be left as is, i.e. that folder stays totally original/vanilla.

 

Is there a way to write the -v boot data to a log file?

What you see on screen with verbose boot flag actually goes by default to the system log. Open up Console tool and you'll see (in Applications -> Utilities).

 

IOATAFamily is not seeing CD/DVD in RAID mode. checking other modes and enabling HD drives to see what happens.
IOATAFamily still not seeing the ICH8 regardless of BIOS settings.

 

I put it in /Extra/Extensions which is working for LAN.

 

Dev:2822 Ven:8086

Still can't get anything on the ICH8. Any ideas?
I lied and worked on the ICH8 some more. Drives now visible with

modified-ahciportinjector.kext

http://www.insanelymac.com/forum/topic/186653-modified-ahciportinjectorkext-no-more-orange-hds/

info.plist edited per:

http://legacy.tonycrapx86.com/viewtopic.php?f=79&t=21704

 

Is that enough to put a drive on it and boot, or do I have to do something with Chameleon?

It sounds like a "simple" matter of device id needing to be covered by the IOATA kext. Indeed, the AppleIntelPIIXATA plugin of the IOATAFamily kext I attached above does not refer to device id 2822. If you edit the Info.plist file of the plugin and add your particular device id to the ICH sections, you'll probably get your controller detected and working... For instance, copy the 1st ICH8 SATA section, paste it, rename it ICH8R (or ICH9R or ICH10R depending on revision, although it does not really matter what you call it) and replace 0x28208086 by 0x28228086.

http://www.pcidataba...vice_search.y=0

http://www.pcidataba...ils.php?id=1302

 

Remember to re-run myFix (full) everytime you work on kexts in /E/E.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...