Jump to content

D630 Chameleon Boot Questions


cNone
 Share

Recommended Posts

Hello;

I have 10.6.8 EDP'ed SL installation on my D630. I have some questions about the boot.

1. I used chameleon bootloader screen at low resolution till yesterday. I didn't remember what did I do but somehow my resolution gone up 1440x900 at boot menu. I was trying to figure out the boot issue I have.

2. Boot issue for me is every time chameleon boots in -v -f flags. I've checked the boot.pilist but there isn't a boot flag. But when I hit a button at boot menu I can see there is boot flags that's already written.

 

My system: D630 with [email protected]

Everything works as expected.

 

Thanks in advance fellas :)

Link to comment
Share on other sites

It could be a bug in Chameleon + the nvram module.

 

The solution? Delete the commands before boot. Press a space and then press enter.

If you just delete it, it won't save your empty 'line'. When you press a space, it is fixed.

Link to comment
Share on other sites

  • Administrators

The bootup resolution is managed by optional parameter "Graphics Mode"="----x----x32".

 

Best way to check and set or adjust this is with Chameleon Wizard once you're booted up: install Cham Wizard on your system (for instance, in Applications) and just double click on the Chameleon boot plist in /Extra. You'll see this optional parameter to the right side with a scroll-down menu from which you can choose various resolutions. Select 1440x900 if that's the one you want.

 

For the persistent -f -v boot flags, as Mick said, press a key when you see the Chameleon delay bar at startup. You should then see the persistent boot flags and options at the botton of your screen. Delete everything, press Space then press Enter. That should take care of things.

Link to comment
Share on other sites

I tried it and that ddn't worked.Then I deleted the nvram.plist file that worked about the persistent flags.But for the graphic mode I always add the graphicmode flag but never worked before and not working at desired resolution right now too

Link to comment
Share on other sites

  • Administrators

Are you doing it the manual way (i.e. you enter the option by interrupting the initial boot sequence) or via the Cham Wizard? If doing it the manual way, make sure you use the correct syntax with double quotes as specified above. You can always just enter ? at the prompt to get the list of flags and options with full syntax details.

 

Having used it several times and for a long time, I can tell you that this option does work on a D6x0 1440x900, regardless of the graphics chip, OS X version and Chameleon version.

Link to comment
Share on other sites

I add the graphicsmode to boot.plist in extra.I will do some more tries with the latest chameleon and with cham wizard.I am doing the modifications with the champlist and manual text edit so far.Another question about chameleon;does the latest build works at1440x900 because whenever i switched larger release number than 2.0 i always lost thehigh res.I will try and come with the results later.

 

By the way I am not talking about system resolution,boot menu resolution is my question.After booting process i have the 1440x900 resolution in system.

 

Thank you for your great support :)

  • Like 1
Link to comment
Share on other sites

  • Administrators

This is still supported with by latest Chameleon versions, yes. And yes, understood you're talking about the startup resolution (so that you get a nicer gray Apple screen).

 

Use Cham Wizard, it's so much easier! It allows you to update Cham versions too.

Link to comment
Share on other sites

SOLVED:

I removed the data (2D66202D 7600) from the line boot-args under NVRAM in nvram.44454c4c-0000-1000-8000-80c04f000000.plist file, that removed -f -v but  added ''?B'' to boot arguments. Then I removed all the line boot-args completely and that done the trick. Now I have full high res start-up and nicer gray apple boot screen :D

 

I used PlistEdit Pro BTW, and now I'm exploring ChamWizard.

Thanks guys, you are doing great work. ;)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...