Jump to content

D820/NVidia can't even boot USB


arghargh
 Share

Recommended Posts

Trying just to get a bootable USB.  I used myHack to create a Snow Leopard bootable USB.  D820 just ends up at a blank screen with a flashing cursor when I try to boot.

 

A couple of things bother me.

 

1. We creating the install from myHack I get an error about having to run myFix.

2. I run myFix and that seems to work.

3. I install Extras from from EDP SnowLeopard for D820/NVidia

 

Try to boot...epic fail.

 

Is there something obvious I am missing here?

 

Thanks.

Link to comment
Share on other sites

Step 3 I am referring to is below.... I created the USB installer with myHack, and before I try and boot it looks like I have install EDP, right?

 

"Now that you have created your USB installer with myHack, we need to put the EDP bootpack on it.

 

  1. Download the EDP bootpack, customized for your system! Our bootpacks contain almost every kext (driver) you need, except the battery and audio driver. Our target is to make the install as easy as possible, so we excluded high risk factors during installation.
    Choose the bootpack for the same OS X version as you made your myHack USB.
  2. Open myHack again and choose: “Install Extraâ€.
  3. Choose as target volume the USB installation pen.
  4. Choose “Use My Own†and select the Extra folder, from the downloaded bootpack.
  5. Quit myHack and eject your USB pen, you are ready to go!

"

Link to comment
Share on other sites

Ok, I am getting a bit further along.  The problem seems to be that when creating the installer from myHack it copies OSX there just fine, but errors looking for myHack.kext.  At that point I assume the other steps (like Chameleon) never get run.  I tried run each option by hand (including the EDP) and now I can boot the US, but I get:

 

BOOTMGR is missing.  

 

Clearly this has something to do with myHack.app not preparing my USB correctly.

Link to comment
Share on other sites

Took another direction.  I managed to track down my Lion install.  myHack still gets an error, but seems to get much further.  I installed myFix, and EDP on USB drive, but now when I boot I get:

 

boot0: GTP
boot0: test
boot0: test
boot0: error

 

Whoa no, cancel that. I installed Chameleon again and it boots...let's see how far I get now!

Link to comment
Share on other sites

During install issues now...

 

1. If the screen goes to sleep it won't wake up even though the install is still running.

2. If baby sit the install and keep the screen active the install finishes, but when I try and boot off the disk I just get a blank screen and a flashing cursor.

3. If I boot off the USB and then try to run the hard drive OSX (as opposed to the install) I can see all kinds of debug but eventually hangs.

 

Can someone verify the myHack steps.  Do I create the installer first?  If I see errors do I just run the other steps manually (and in what order).

Link to comment
Share on other sites

  • Administrators

The display sleep issue is a known one; it also affects the D620. It's to do with the nVidia chip; it's probably something to do with DSDT. Basically, if the display goes to sleep, it'll only wake to a grey screen. In that case, the best you can do is put the entire computer to sleep and wake it.

 

For the rest, it still sounds like you're still without bootloader. You're probably not following the procedure 100%.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...