Jump to content
derikke

E5520 Bootpack problems with Intel HD 3000 HD @ 1920X1080

Recommended Posts

Hello Team,
 
i can´t install ML with your given Bootpack.
I´ve had extract my own DSDT an pachted it with DUALLINK, now the gfx part works.
Could someone please include my E5520 Model and fix sleep etc in DSDT?
Clean DSDT is attached.

 

My Latitude E5520 Specs:

 

 

1PROCESSOR : ONE INTEL CORE I5-2430M (2.4
1DISPLAY : 15.6IN ULTRASHARP FULL HIGH DE
1PALMREST : DUAL POINT TOUCHPAD AND TRACK
1CAMERA : CAMERA WITH MICROPHONE
1MEMORY : 4GB(2X2GB)1333MHZ DDR3 DUAL CHA
1WIRELESS : DELL 375 BLUETOOTH CARD
1KEYBOARD : DUAL POINTING INTERNAL KEYBOA
intel HD 3000 @ 1920x1080

 

dsdt-e5220-clean.zip

Share this post


Link to post
Share on other sites

This dsdt is not patched it is my clean.

 

Dsdt patch for duallink is available in the Internet.

But i need a fully patched one for power management / sleep.

I could provide my clean dsdt with duallink, but that will not contribute to the e5520 edp, it's only patched to get the right resolution nothing more.

So who can help to get the package complete?

Share this post


Link to post
Share on other sites

Ok, if you need patching, follow the process detailed in R&D->Other research-> DSDT section. You can't miss it.

 

PS: no EDP bug here, so moving post to support section.

Share this post


Link to post
Share on other sites

Ok my E5520 Model is now fully functional with ML 10.8.3 with all updates

 

i´ve added a Atheros AR5B91 for native wifi.

 

sleep, battery etc is working fine, got some trouble with full brightness after sleep...

i will finetune this and repost.

But i've no clue to get my cardreader to work, extra package for boot and run is attached.

 

 

Extra5520_i5_2430m.zip

  • Like 2

Share this post


Link to post
Share on other sites

Extra5520_i5_2430m.zip

Thank you! I installed your bootpack to myHack installation drive and now it boots installation. The bootpack on EDP page didn't work.

Share this post


Link to post
Share on other sites

@derikke Do you have HDMI both Video and Audio working? ... I have HDMI video working but HDMI Audio just won't work 

Can you go to the BIOS and check what you have for Audio?

Is it 92HD90...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...