Jump to content

D520 Lion install woes


Recommended Posts

g'day folks..

trying to breath life into my 520.. using your myhack method, select 10.7 add extra folder, (tried running my fix, tried not adding extra folder)

boot off USB
right after selecting language the mouse becomes unresponsive..except for fleeting moments when it springs back to life every 10 sec for a 1 second bursts..extrenal USB mouse does same.

I can navigate with keyboard to get around this,
always start fresh and erase drive (journaled ofcourse)
all goes well when myhack asks me which extra folder to use at which point.. it hangs, once MyHack has asked me if i want to delete problematic kexts.. which is normal, but goes no further.

I am running

core 2 duo    (D520 previously had core Duo)

4 gig ram      (also tried with 2 gig)
removed wifi
removed bluetooth
have tried with SSD and normal HDD

tried intsalling with 2 different USB sticks and off hard disk partition.

I have an iFail lion disk and strangley the mouse issue is same.
I have tried with out adding the extra folder and it still hangs same spot.
I am going to try and use a different source as I am using a DMG image of lion

have set up the BIOS same as thread here



I am very familiar with other install methods, but cant walk away from your install method when all the hard work has been done...extra folders worked out...sheeeesh!!

any help at all, would be extremely appreciated :D

Link to comment
Share on other sites

  • Administrators

With Lion, you could try to boot with option "USBBusFix=No" to fix your mouse/trackpad issue. I did notice that using that option on D6x0 avoided OS X prompting for a BT mouse/keyboard and therefore avoided to plug in USB devices...


Note that the installation can take a few more long minutes after the myHack request to remove problematic kexts, so you may have to be quite patient there.


Out of interest, which Core2Duo CPU did you fit in your D520?

Link to comment
Share on other sites

got a C2D 1.66GHz T5500 667MHz  Socket M, slipped straight in no problem.

I have no idea why, but rectified my problem by running MyHack > create OS installer - after that finished I manually copied across everything from the D520 "extra" folder I downloaded from here, then running MyHack > MyFix (all) 

Then everything ran smooth as an androids bum, mouse fine, sound no1#, wireless (i had a Broadcom43xx) all good, battery, EDP worked fine, am posting from a Lion 10.7.5 updated .

just wondering the


USBBusFix=No , is it (=No) by default ??
is there any point running EDP before the combo update..

anyways , extremely extremely pleased..
donated two long bottles of beer, EDP and MyHack luv ya work 

thanks very much herve, with out your help I'd still be staring at my CORE DUO wondering whats wrong

Link to comment
Share on other sites

  • Administrators

Some Chameleon boot plists of our booptacks have USBBusFix set to Yes. I have often found that, unless that option is set to No, Lion prompts for a BT keyboard during or after installation (can't remember which), which then requires a USB keyboard to be plugged in. When you manually specify the parameter at Chameleon startup, it overrides the plist settings.


If you're proceeding with combo update straight after initial installation, no, there is no real point installing EDP and doing a system build before the Combo update. The critical point is to do an EDP system build before any reboot after the combo update is installed.


Great that you got there and can now enjoy your Lion Hackintosh!

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...