Jump to content

Mountain Lion 10.8.4 on Dell D630 - GMA X3100 with full QE/CI


karpais
 Share

Recommended Posts

Hi!

 

I have follow OS X Latitude guides and MLPostFactor V3, i manage to instal with sucess Mountain Lion 10.8.4 on my Dell D630, thanks to you guys. Everything's working but the sound, i have run EDP, but AppleHDA don't seams to work.

 

Can someone help me please?

 

Thank You.

Link to comment
Share on other sites

I can't seem to wake from sleep. Every time I turn the computer back on it halts and turns off, and when I turn it back on the BIOS settings are reset. I'm using the D630 with X3100 1440x900 on 10.8.4. I've run EDP and myHack (in that order). The computer also can shut down on its own but cannot restart without hanging at a white screen, therefore I have to force it off.

 

Thanks in advance!

Link to comment
Share on other sites

  • Administrators

Try the following things:

  • ensure you have BIOS A17 or A18
  • check your BIOS parameters and make sure they're set as per recommended settings in the pinned thread

You say you've run EDP (I presume you meant doing a System Build) followed by myHack. What was the rationale behind that?
 
Can you list the kexts you have in /Extra/Extensions?
 
When you run EDP to do the System Build, you can actually modify the default settings as follows:

  • in Kext/Drivers tab, set everything to OFF (that will get rid of nullCPUPowerManagement, SleepEnabler and Emulated SpeedStep)
  • in Fixes tab, turn patched IOATAFamily to OFF (not necessary on D630)

Then follow the instructions to enable native SpeedStep detailed here. Alternatively, use the files attached below, placing FakeSMC in /Extra/Extensions, SMBIOS.plist in /Extra and HWMonitor in Applications folder and re-run myFix to properly install the kext.
FakeSMC_5.2.678_32-64bit.zip smbios.plist.zip HWMonitor_5.2.678.zip
 
With MLPF, the kext cache generation can be problematic, so check what you have in /System/Library/Caches/com.apple.kext.caches/Startup. If you see no kextcache file, use the following Terminal command to try and generate it: sudo kextcache -system-prelinked-kernel.
 
Regarding sleep, use Terminal command sudo pmset -g to check hibernation. If hibernate mode is set to 3 (or any non-zero value), use sudo pmset hibernatemode=0 to turn it off. That usually fixes sleep.

 

Only reboot once you've done all this, then verify those troublesome items.

  • Like 1
Link to comment
Share on other sites

You are a god!

 

Ok extensions are

AppleACPIPlatform

AppleSCPIPS2Nub

ApplePS2Controller

FakeSMC (yours)

IntelCPUController

Ispcidrv

Patched_10.7_AppleRTC

 

Not sure exactly what fixed my sleep, but it works now. I was already running BIOS A17 with the recommended settings.

 

I could never get the kextcache to generate, it seemed to have issues with IntelCPUMonitor.kext - no dependency found for org.netkas.FakeSMC. 

 

Thanks again!

Link to comment
Share on other sites

  • Administrators

Glad to see it's all working.

 

IntelCPUMonitor kext works with earlier release of FakeSMC such as v4.0. It's not required with newer versions published by Kozlek and in fact, clashes with them.

 

I don't know what your IntelCPUController kext does. I don't have that on any of my D series laptops.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...