Jump to content

How I got ML installed on my 830


KingPrawn
 Share

Recommended Posts

This is how I got ML installed on my D830.

My D830 specs are:

2.4 ghz, 4gb Ram, NVS 140, 1920x1200, dual wireless dell 1390 and Broadcom Xtreme N, bluetooth, etc.

 

This is what I turned off in the A15 BIOS:

Modem, Parallel, Serial, ASF, Ambient Light Sensor, all the password stuff and TPM, All power management.

 

I was using iFail before and I could never get anything to install. Just hung at PCI config every time. I finally abandoned that and went with MyHack instead since I couldn't figure out how to install the new kexts in iFail. I used the MyHack method for setting up the USB flash drive and got the bootpack from here. I pretty much used every option that MyHack allowed me to use. New extras (downloaded from here), MyFix (all). When I installed it this time at least did something but I kept getting stumped at the PCI config, so I got the IOPCIFamily.ketx from netkas.org. plugged my flash drive back into my HP DC7900 USFF with Lion (iFail worked great on that) and used MyHack again and manually dropped in the IOPCIFamily.kext.

 

I got a little farther that time before it black screened on me. After reading through the MyHack troubleshooting again one recommendation was to boot with PCIRoot=1. That did the trick at first only to be greeted with another black screen. I restarted the system again and this time it loaded up and it installed pretty well for about 2/3s of the install until I got another black screen. I could still see my flash drive activity LED blinking and HDD activity was pretty solid but still a black screen. Funny, I guess, but the reason for the last black screen was that the monitor had apparently shut off and I just had to click the mouse button and was welcomed with some MyHack options. I could tell instantly that

 

At the end of the install I had the unfortunate message of "install failed". I just rebooted and it loaded right into the ML initial setup. Everything worked. wifi, bluetooth, video... pretty much everything I could check at a glance. The only problem is that it wouldn't shut down, but there was still a lot of HDD activity so i just let it sit there while it mocked me and all my efforts. But, thankfully, after what seemed like an eternity it rebooted and it loaded back into ML. Of course there was no keyboard or trackpad support since they are PS2. I then ran the EDP, chose my model, and waited some more. After the install I had a much faster shutdown and reboot and everything worked. Sleep works fine as well. I haven't had any issues with it. I can sleep it and wake it up with no problem and everything works.

Magic? Maybe.

 

There was a weird issue with the trackpad that made it seem to lag for no reason then speed up. After a minute I realized that it was acting like it was pressure sensitive. The harder I pushed the worse it reacted. A super light touch and all was fine. I just went into the trackpad properties in System Preferences and turned off two finger scrolling and now everything works like it should. I have the Synaptics touchpad with the biometric scanner. I haven't managed to find any kexts that allow my to use scrolling with the Synaptics pad unfortunately.

 

What doesn't work:

Biometrics don't show up/work

No Scrolling with Synaptics touchpad but the action of the pad is great.

 

I think that I've covered my procedure as best I can. I've never used a Mac until 3 days ago when I put Lion on a HP DC7900 USFF so I'm not an expert. Thanks to everyone in the community because without your knowledge I would have never gotten this installed. Hope this helps someone. Questions or comments are welcome. Thanks again.

 

P.S. if anyone has a solution to the Synaptics touchpad scrolling problem I'd love to get it working. I can't seem to find one.

 

 

Link to comment
Share on other sites

  • Administrators

As far as I know, D830s have ALPS trackpad, not Synaptics. Scrolling works Ok with severak PS2 kextpacks. By default, EDP installs the ANV-SLice which does provide heavy-finger scrolling (you need to very light finger for regular mouse moves...).

 

Our D Series are one of the best mastered family of laptops as far as Hackintoshing is concerned; so, yes, our OSXL install procedure + EDP is well adapted to these systems (and has been for quite some time). There is also a dedicated thread in the D830 section re: BIOS settings.

 

If you want to play around with native SpeedStep and improvement GPU management, read-up the article about fine-tuning with FakeSMC in the Articles section of the web site.

Link to comment
Share on other sites

As far as I know, D830s have ALPS trackpad, not Synaptics. Scrolling works Ok with severak PS2 kextpacks. By default, EDP installs the ANV-SLice which does provide heavy-finger scrolling (you need to very light finger for regular mouse moves...)

Ya know... you're right. I could have sworn that the touchpad with the biometrics was a Synaptics and the ALPS was w/o bio. But, I took it apart and checked and it sure is an ALPS. I don't know what made me believe that. That clears a few things up for me. Thanks. I'll be sure to check out the articles and see what tweaks I can make. I appreciate the info.

 

I just got this system off ebay a couple of weeks ago for $139 which I think is a steal! I've never had a Dell before. I always buy MSI, ASUS or Clevo laptops. I didn't know anything about MacOS either. Needless to say I'm super happy with it. Even just with Win 7 on it. I ordered a media bay HDD carrier so I'll have a choice to boot Win or ML on separate drives so that should be pretty nice. Sadly, I have a rather expensive MSI machine that doesn't get much use now that I have this :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...