Jump to content

ASUS VivoBook S550CM


Recommended Posts

Hi all,


I'm trying to set up ML 10.8.3 with myHack an I've been able to install it in a second partiton and boot it with the external myHack USB and -x flag only (yet).


From what I've seen, the model is quite similar in specs to another Asus already described here (K55VM) but I'm not sure if  I should use the same kexts.



Windows® 8 64 bits

Intel® Core™ i5-3317U

4 GB DDR3 1600 MHz (1 x 4 GB)

500 GB sATA 5400 rpm + 24 GB MSSD

NVIDIA® GeForce® GT 635M with 2GB

15.6" 16:9 HD (1366x768) LED Backlight Glare panel (multitouch)


1 x USB 3.0 + 2 x USB 2.0


Audio: ALC270

Wifi: Atheros AR9485WB-EG

SD, SDHC: RT55289

PCI-E Ethernet: RTL8168/8111

Bluetooth: Atheros chipset but not able to find reference with AIDA 64



I've already set up other three different Desktops with ML (Acer, Dell and Gigabyte mb) but this is my first laptop so I'm kind of newbie in this area so any help will be appreciated.


Up to now, I'm able to boot it with Chameleon in an external USB but not sound or video acceleration yet.


While I keep tweaking the system to make it usable I would like to understand the following:


- With an EFI BIOS (Aptio AMI), do I still need a DSDT? (i've attached the extracted DSDT from AIDA 64)

- HDD is already formated in GUID with an initial EFI partition. What is the best option for dual boot taking into account I already have windows 8 up and running?

- I assume the 24GB SSD (GUID) is set up in Windows 8 as a cache disk. Is that something I can us also with ML?





Link to comment
Share on other sites

dude- the new windows 8 laptops have EUFI secure boot. Ask the admins on how to overwrite it, but I don't think it's an easy thing to do without bricking the computer

Link to comment
Share on other sites

That is my major fear and this is why I still I boot with an externak usb stick with chameleon.


I have the system almost full operative with the great work from EMlyDinEsh and his DSDT/SSDT patch but I don't want to install the boot loader until I have it clear that it can be done without braking the current set up with Windows 8 (and have to reinstall it).

Link to comment
Share on other sites

If you can boot from USB, you can also boot from HD. I don't think that SecureBoot will cause issues, and otherwise it should be possible to turn it off?


However, if you have a dualboot on one harddrive, it is a bit hard. Just try installing Chameleon, and getting the OS X partition active. You can always repair the Windows 8 bootsection, with the DVD or something.

Link to comment
Share on other sites

I've got an Asus S300CA with almost identical hardware as you (different eth card, I have no Nvidia).  I'm running 10.9 at the moment still booting from usb with clover UEFI. Using clover autopatched DSDT with HD4000 device properties in config.plist gives me full acceleration. Not sure about Nvidia. Audio is working with Voodoohda.  The bluetooth is an Atheros AR3012 BT 4.0 + HS bundled with the Ar9485. I haven't got it working though.


SMBIOS is Macbook Air 5.2. Initially I used 5.1 but 5.2 seems to work better for this machine.


SecureBoot can be disabled in BIOS.


Try this guide. That's what I used to get this machine going. Guide also works for 10.9. There's info in the guide on how to dual boot with a pre-existing Windows install (I haven't tried it yet). I had a lot of HW issues with ML but Mavericks is working surprisingly well. (Everything except wifi/bluetooth & the touchscreen that I don't care about)


The big hurdle for me now is patching my DSDT properly.


NOTE: If you use a different clover version than the guide remember to make a /BOOT folder under /EFI & copy CLOVERX64.efi from /EFI/CLOVER/ to /EFI/BOOT. Rename /EFI/BOOT/CLOVERX64.efi to /EFI/BOOT/BOOTX64.efi. So it should look like this:




Otherwise clover won't load.


My current clover config for reference (try the string under properties to enable HD4000):






Link to comment
Share on other sites



Thanks for your input.


I've also migrated to Maverick and it's working quite well. I'm using an ad hoc DSDT generated by EMlyDinEsH


Audio: I've patched AppleHDA as per  EMlyDinEsH guide and it is working quite well. The only issue is waking up EADP output(speakesrs) but with the flag in Elan kext there is no problem to solve it. I've attached it would you like to test it.


BT/WIFI: Same issue

Bluethooth: It is detected but there is no way to make it working (checking it in several forums)

Wifi: Will never work. Using a TP-link mini USB dongle.


Dual boot is working quite well from HDD using CLOVER configuration I've found from HP Elitebook:https://www.dropbox....198h/3GDjlCCzZj I've tried your's but it doesn´t work.


Also, if you want to use ACPIBatteryManager.kext, you can easily patch your DSDT to make it working with the following file:https://github.com/RehabMan/Laptop-DSDT-Patch/blob/master/battery/battery_ASUS-N55SL.txt




Link to comment
Share on other sites

Here you have it.


Have you made the USB 3.0 working? I'm having problems with sleep using the latest GenericUSBXHCI kext


Thanks. How is audio working for you? My max volume was too low & mic wasn't working.


Boot with "-gux_defer_usb2" flag


That fixed usb sleep! Thanks! Is there a DSDT edit to remove the boot arg?

Link to comment
Share on other sites

  • Create New...