Jump to content

D530 some strange bugs


Recommended Posts

Hello everybody !


I come to you because I have some strange issues installing OS X on my Dell D530.



First of all, here is it's config: Intel Core 2 Duo T7700 2.4GHz, 4Gb Ram, latest BIOS version.



Okay, let me now tell you what happens.


When I tried the first time to install OS X Snow Leopard using MyHack with EDP Bootpacks, I just got a screen that told me to turn off the computer.


Then I used the -v boot arg to see what happens: I had a faulty kext called IOATAFamily. It said secondary IDE channel was disabled, and just after that the KP came.

I searched the web, and found a patched kext that worked fine, but had to replace it manually on the S/L/E of USB stick.


Next time I tried to install, I got another kernel panic, this time from AppleEFIRuntime, another kext name I saw was AppleEFINVRAM.


I simply deleted it from S/L/E on USB stick to see what it would do, and installer launched perfectly, until the moment he tries to start the newly installed OS.

As both kexts are included in a .pkg, it was fixed on the USB stick, but not on the installed system.


Then I pulled out the HD, connect it to another mac (Dell Mini, running SL 10.6.2) using a SATA-to-USB adapter, replaced the IOATAFamily.kext with the patched one, and again removed AppleEFIRuntime.kext.


This time the system loads perfectly, installed and ran EDP, everything works except sound and LAN.



Now, as it was a 10.6 retail DVD I used to create the usb stick, I wanted to install the combo update.

While it was installing the update, everything froze and I could never get the system back again, even by replacing/deleting the mentioned kexts.

It just blocked while loading, without any information.



For now, I reinstalled 10.6 just like I did before I tried to update, but it's not really satisfying for me.


Maybe could someone help me determine what the problem is with these kexts ?



Thanks in advance for your replies.









PS: I tried to install Lion too, but like in another thread, installer freezes while it launches, sometimes while copiying the files, sometimes while partitioning, sometimes it even can't load installer and blocks at command-line type screen...

Link to comment
Share on other sites

Okay thank you.


Where can I get the latest version and can I add it to myHack in order to make a fresh and clean install ?

If a add the patched kext to the bootpack E/E folder, will it override the stock kext from the install DVD ?



Is there a way to upgrade to 10.6.8 with these things fixed? Just by letting OS X doing it's combo update?




Again, thanks for your help !

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...