Jump to content

D830 Lion 10.7.4 install. Need help please!


TheOriginalThee
 Share

Recommended Posts

Hi everyone.


I'll give you some background on me first.
I am an Infrastructure Engineer who about 2 years ago, built myself an OSX SL Dell Mini 9 (10.6.7) which I still use today.
 
I have now started to build a Dell Latitude D830 (Intel graphics) with Lion 10.7.4 and initially had somewhat of a success the first attempt.
 
My problem lay in that I didn't read the instructions clearly as I'd been flicking between websites to get instructions.
Saying that, I formatted an 8GB usb stick and install the generic MyHack onto it.
Using this i was able to get Lion running on my D830. Although the problem was there was only 1024x768 display and no network card showing up so i couldn't run the EDP post installation tool as it fails - no network connection!
 
I also realised there was a bootpac for the D830 which you should replace with the generic "extra" folder on the MyHack usb stick (i think that is correct).
I tried the options in MyHack to get this working but still no network card so i wiped the HDD and really carefully followed the instructions to the letter. This is where it all went a bit frustrating for me.
 
No amount of try's have allowed me to get it to install. I get a black screen just after i get to where you can select the OSX tools or install the OS.
 
So, now i am back to using the generic MyHack prepared USB stick and it is slow but seems to be working again.
Im already on the installing part of the procedure with 19 minutes remaining.
 
My question to the group is, how do i get the nic driver onto the D830 after the OS install is complete so i can do the post install EDP?
 
I still haven't fully got my head around the drivers component of the whole hackintosh so any advice on what to do to tie off the loose ends would be greatly appreciated.
 
 
Cheers! 

 

Link to comment
Share on other sites

First, which card is in your D830? You may have an unsupported card, or one that requires a kext (driver). Obviously, an unsupported one will need to be replaced, with a supported one, a kext can be added after the install if needed. If you know which kext you need, it can be added to the USB. Use the appropriate bootpack (there are two for your model) by adding it to you USB stick. With about two minutes left in the install, you will get a pop-up asking whether to use a Generic Extra or you own, choose your own, and OK. A pop-up will appear with a directory of your USB stick - find the Extra folder and choose it. Continue with the install, choosing to delete the three kexts that pop-up. I often use a USB on which I have created two partitions on, one for the installer and a separate partition for various kexts I may need. Just be sure to name the partitions clearly to avoid confusion when using them. You can then move the kext(s) from the USB and install on your OSx partition using the MyFix feature in MyHack, after putting the needed kext into the Extra/Extensions folder (when you use MyHack to install, a copy of it is installed into your applications folder - open it and choose MyFix (Full) from the dropdown menu, making sure to choose / (your drive) as the destination. where It will install the kext, repair permissions and rebuild kext caches. I suggest running MyFix after any changes (adding kexts, updating, etc.)

Link to comment
Share on other sites

  • Administrators

When you say you have no NIC, I assume you're talking about the on-board 10/100Mb Ethernet port. You should use our bootpack as it contains the kext for the on-board LAN: check your /Extra/Extensions folder and it should contain something like BCM5722D.kext

 

If it does not, that would explain your issue.

Link to comment
Share on other sites

Thanks guys.

I appreciate the help.

There is no recognised onboard nic so I cant run the edp yet.

I'll try the bootpack. Is it possible to run that after the installation or does it have to be done at the end of the install?

Reason I ask is because it is already installed again with no nic.

Can I just add the extra folder from the bootpack to the USB stick and point it to the MyHack on the OS drive to add it?

Link to comment
Share on other sites

  • Administrators

If you already have myHack installed on your machine, yes, you can simply add the missing kexts or replace your /Extra folder by the boot pack for your specific model. Then run myHack-myFix (full) to repair permissions and rebuild kext cache.

 

On reboot, you should be Ok and good to install EDP and do a System Build.

 

If you do not have myHack, what you can do is:

  1. copy the LAN kext to /System/Library/Extensions
  2. open up Terminal from Utilities folder and type:
  • sudo chown -R 0:0
  • sudo chmod -R 755
  • touch /System/Library/Extensions

 

Reboot and you should have LAN working.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...