Jump to content

Swapped/non-working keyboard keys


Charles Albert
 Share

Recommended Posts

Hi everyone. I've already posted it some time ago, but it was archived, and maybe it was so due to lack of information, so here goes more details: I've had MacOSX 10.6 on my Dell D630, every keyboard key worked just fine. Then, i've updated to 10.6.6, and after that some keys were swapped(i.e.: \| for '"), but the most strange is the /? key that is located at the left side of the right shift that turned up to some sort of [enter]. Now updated to 10.6.7 and the situation stood the same. Tried different keyboard/mouse kexts (from the latest EDP) without any different results. Tried different keyboard layouts/languages, but no dice either. Also tried that keyboard layout editor called Ukelele, but I didn't knew where to start.

 

Then now comes the surprise: if I use any external keyboard, all the keys work perfectly.

 

What strikes me odd the most of this situation is that, although my Latitude is an Brazilian model (ABNT2 keyboard layout), the /? key was working even with the default language, although with some other characters. And even with the language setting that fixed the right key positions (keys also working in 10.6), from 10.6.6 until now the keyboard does not work properly.

 

Why it is happening is absolutely beyond me. Anyone ever heard about something like this or has any ideas from these clues I've posted above?

Link to comment
Share on other sites

 Share

×
×
  • Create New...