Jump to content

The D830 OSX86 (SL) Experiance


lcars
 Share

Recommended Posts

Hallo,

 

Since their does not seem to be alot of experiance with the D830, I thought i write a short summary about my experiance and how i got it installed. Maybe it might help someone.

 

My Hardware: D830; A14 Bios; intel GMX3100; Original: Intel WLAN 39??; Changed module to: Brodcom 4311; C2D 1.8GHZ; 2GB Ram :(

 

Installation:


  •  
  • - Bios Setting: Use default Settings + Sata Mode AHCI
  • - The SL420 image (The torrent link on the wiki page) does not work! No Graphic during install. A custom build usb-stick (http://www.osxlatitude.com/groups/d4xosx/wiki/94855/Howto_install_OSX_on_your_Dell_Latitude.html)with EDP1.8 (D630-intel option) might work!! Not tested.
  • => I installed using the nawcom modcd (http://blog.nawcom.com/). The new modusb will likely work...But i used the older iso... so can only say for sure that the iso works and an OSX 10.6.3 Reteil DVD
    In the OSX installer I used the Diskutility to make a new Jornaled MAC Os Partition in a GPT Partition Schema. I choose Custom install where i deselected almost all of the additional language packs and printer support (didnt need it; if you do let it in).
    The Installation (copiing of files) itself was very slow but worked.
  • - After installation was finished i installed the combined Update to 10.6.7 from the apple.com homepage and EDP1.8 (http://www.osxlatitude.com/groups/d4xosx/wiki/a92b0/EDP_History_and_Changelog.html) (slow Snow Leopard is normal at this point until you get the edp installed and reboot)
  • - EDP Options: The kext for D830-intel have some problems - see: https://osxlatitude.com/index.php?/topic/395-d830-intel-needs-a-doctors-appointment-plz-help/ => Use the kext for D630-intel!!! I used the options AppelCPUPowermanagment, AppelPS2, AppelBattery, no pcmcia (didnt need it); (re)Installed Camelon Version from the EDP; Fixes etc. Use what seems right... (dont know)

 

 

What works:

(Note: If a Feature is not listed here it doesnt mean it will not work! It just means i have not tested it yet!)


  •  
  • - Speedstep: works and the CPU didnt get to hot. Though i havent done anything that is really CPU intensive e.g. video converting; gameing etc. so i suggest you still monitor it.
  • - Graphic: works
  • - Touchpad: works with basic functions; no gestures. But you may try the VoodooPS2 driver(not tested). Slice does not work at all.
  • - LAN: works
  • - WLAN with BCM4311: works (even with no rebrending; might do it anyway) WLAN with original Intel Card: not working Attention: If you use the described method with the original Intel WLAN Card make sure you disable Wireless in BIOS (after EDP installation) otherwise you will get a Kernel Panic!!
  • - Bluetooth: works
  • - Sleep: works with choosing sleep from the the menu AND when shutting the lid of the Laptop!
  • - BatteryIndecator: does not work neigther with Appel nor with Voodoo driver.
  • - usb and (ps2 on dockingstation): works
  • - Docking Station (Port Replicator): Saddly the DVI out of the Dockingstation does not work. If you boot the laptop with closed LID it goes to sleep mode as soon as the OS is loaded. If you leave the lid open it auto switches to the internal display once the OS is loaded. Function key- Output select does not help eigther. Though that might be normal ... i read somewhere that LION has a new feature that allows you to use usr MAC-book Pro as Desktop... supposedly in SL even MAC Books behave in the discribed manner. (Going to sleep with closed lid) But supposedly you should be able to wake Mac Books with an USB Event (usb keyboard) and then they activate the external monitor... havent tested.
    In anycase: Being able to use the DVI of the Docking Station is the MAIN Point i am missing ATM. So if anyone knows a way to make that work (preferably with disabled internal display or in mirror mode with the external monitor being the primary screen) PLEASE Do tell

  • Like 1
Link to comment
Share on other sites

ok so d830 intel version is working with d630 build? not with edp d830-intel option?

That is correct... Apart from the battary indecator, which actually worked with the d830 Intel edp..

Link to comment
Share on other sites

Have you attempted to extract the battery indicator kext or utility from the D830 EDP?

 

If so, were you able to swap it with the one installed from the D630 EDP, and if so, did it work?

 

If so, could you please spell out the steps and commands required to accomplish this switch?

 

Thanks,

 

nesnfsn in Sunny South Florida

Link to comment
Share on other sites

Ok I have a question. I started with the MODCD and it booted up great and installed my Retail Snow Leopard DVD. Everything was working great. I then applied the update from apple and rebooted. Blammo my system will not boot now.

 

Is this because I did not install EDP?

 

Thanks so much

 

Mike

Link to comment
Share on other sites

Too funny, I think this is the 5th time reloading OSX. I just tried without the updates and tried EDP 1.9.1 for snow leopard. I went with the 630 kexts from what this user has done. I want to keep learning, its just wierd how it works AWESOME up until the reboot. I thought maybe it was Chameleon so I did an update of that through the EDP.

 

I mean after installing with the MODCD I think everything is working.

Link to comment
Share on other sites

Hmm the latest one on nawcom because i couldnt get my 830 to boot into the install dvd. Id be happy with a vanilla kernel. I wasnt aware that EDP was for a vanilla kernel and nawcom probably was using a custom kernel. Wish i knew why my system installs off his boot and not the chameleon here. Now i seem. To have a working system after EDP 1.9.1. My wifi worked before EDP and now its not hmm i am really liking OSX too :)

Link to comment
Share on other sites

 Share

×
×
  • Create New...