Jump to content

D630: sound or DVD but not both


tbyers31
 Share

Recommended Posts

I've been working on trying to get my DVD to work with the sound card. If I choose audio drivers in edptool.command, I get internal sound to work fine but the DVD won't work. If I rerun edptool without audio, DVD works.

 

There are several IOATAFamily.kext's out there that I've tried. Starting to get tied up in knots with this. Any ideas?

 

D630 - A17 Bios - Intel Graphics - 10.6.7

 

I'm using /Extra from Thund3rbolt due to issues with D630. Tried two different IOATAFamily.kext's

 

Thanks!

Link to comment
Share on other sites

Funny how often it happens that as soon as I post a question I stumble on the answer...

 

I did try VLC but the problem is the system didn't recognize the internal CD/DVD drive at all.

 

Retracing my steps I searched for the IOATAFamily.kext and remembered I had deleted it to get around an earlier kernel panic.

 

I put it back and here's the thing learned (I think):

 

You can't just move files around in the /Extensions directory without fixing the permissions, right? (various forums mention this but I'm not exactly clear on what this is).

 

I reran edptool.command and used the "fix" option. Does that do this?

 

Anyway, DVDs are good now with either the native player or VLC. And sound it working too, although pretty quiet I must say even at full volume.

 

Thanks for the suggestions.

Link to comment
Share on other sites

 Share

×
×
  • Create New...