Jump to content

Dell Latitude D810


PauloBral
 Share

Recommended Posts

Dell Latitude D810

 

Processor:

Intel Pentium M 2.13GHz (MMX,SSE,SSE2)

 

Memory:

2GB DDR2/533MHz (1GB original infineon + 1GB kingston)

 

Video:

ATI Mobility Radeon X600 (PCIE) (1002:3150)

 

Network:

Broadcom NetXtreme BCM5751 (14E4:1677)

 

Wi-Fi:

Intel 2200/2915 (a,b,g) (8086:4223)

 

Sound:

SigmaTel C-Major Audio (8086:266E)

 

Chipset:

Intel i915/ICH6 (4x USB Ports)

 

PCMCIA:

Texas Instruments (104C:8036)

 

SmartCard Reader:

Texas Instruments (104C:8038)

 

Infrared:

SMC Fast Infrared (*SMCF010)

 

Bluetooth:

No bluetooth (has expansion for Dell BT350)

 

Hard Disk:

TravelMate 60GB 7200RPM ATA

 

Optical:

Philips DVD/CD-RW Combo

 

-----------------------------

 

I managed to install OS X Tiger 10.4.8 (JaS) but nothing works (no lan, no wi-fi, no video, etc)

I also managed to install OS X Leopard 10.5.7 (iFailv7) but it hangs, takes ages to show login screen, also nothing works.

 

I need help!

I want to do with this laptop the same as I did with my desktop computer...

 

On my desktop computer I applied the DSDT patches directly on the BIOS chip, and I don't need to put DSDT.aml on the root anymore, the system works like a charm.

 

I want to do the same with this laptop, but I can't find a way to modify the BIOS.

I tried with Phoenix SLIC tool 1.85 that has option to modify the DSDT but the changes aren't really applied for some unknown reason to me.

 

Has anyone sucessfully installed any OS X with everything working on this model?

  • Like 1
Link to comment
Share on other sites

does the dsdt work or not? maybe some of our dsdt pros may have a look...

 

if u can wait i can communicate...

 

At first here is the bios with modified dsdt from simeonoff (all credits to him :lol: ) in it...

 

BTW. try to recover first - if it works give a short feedback

 

if it wont work - have a look here - do the things - post your linux dump and wait for a better fitting dsdt ;)

 

cheers

 

CRC

 

btw. WIFI and ATI wont work probably

D810_OSX.zip

Link to comment
Share on other sites

Hey Paolo,

 

I worked on your DSDT for D810 today. Your dsdt was a mess. Fixed it, should boot SL now.

A few remarks:

 

1. X600 won't work in Snow Leopard

2. Wifi too will not work.

3. Audio with VoodooHDA.kext

4. Ethernet with BCM5751.kext

 

Your best bet will be to follow this guide to create a USB bootable install flash. I attached a custom "Extra" folder for your installation flash. Copy the Extra I attached to your SL install flash. Install chameleon and you're done. Time to test if it boots. I also attach a separate DSDT.aml for your model just in case you wanna do some edits, or give it to someone else to do edits for you.

 

Good Luck!

Install_Extra_With_PrebootD810.zip

dsdt.aml.zip

Link to comment
Share on other sites

@crc-error404

Man I don't know how can I thank you!!!! I don't really knew how to use the "recover.hdr" file, so I just installed D810-OSX.EXE (using DOS-boot PenDrive) and then rebooted to Windows and now I have HPET (and other ACPI000 unknow device) and this is a sign that is worked!!! :D:D:D

 

Thank you very very much!

 

 

@simeonoff

I will buy a new pendrive (16gb) tomorrow to try the guide you suggested.

During the meantime, I will play with other OSx86 DVDs I have here to see what happens!

 

Thank you very much!

 

 

Ah, I will be back to post what happened! TYVM again guys

 

 

Edit:

Hi, I'm back!!!

 

I'm still unable to run SL (till now tried with iFail S3)

 

I noticed that things are a bit faster now, but still not perfect yet. (is the HPET that makes things faster?)

 

I'm managed to install iFail v7 (10.5.7) but I'm having some trouble with kernel panic at random times.

 

I also noticed that the SpeedStep implementation on my processor is very inconsistent

It varies from 800MHz to 2.13GHz and, sometimes it boots at fullspeed (and then osx boots normally) but other times it boots at 800mhz (and then I get KP)

I tried to disable SpeedStep on the bios, but if I do this, this ****ing system locks the processor at 800MHz

 

Is there anyway to change bios to make it always run in 2.13GHz when I disable Speed Step?

 

TYVM in advance.

Link to comment
Share on other sites

Paulo,

I would strongly suggest you stay with Chameleon and EDP.

If you throw other bootloaders into the mix, the team here would most probably be unable to help you.

EDP solution we use is built around Chameleon 2 RC5. All other bootloaders might defer in their needs and we cannot cover them all.

That does not mean we don't want to help, but it would be very challenging task for our small team to stay on top of all and every bootloader out there.

 

Hope you understand.

 

Thanks!

Link to comment
Share on other sites

@Zeppo

 

My laptop does not boot Chameleon 2 (gives boot0 error) so I am stuck with the previous Chameleon version.

I managed to install a nice double-boot Win7+OS X 10.5.7 (using 10.5.5 kernel - I am also stuck with this, since from kernel 10.5.6 and above there is a check for "processor family" value in order that only core2 processor will boot - I mean, I am saying this based on readings through the net) - and my processor is a weak Pentium M (single core, SS2-only), and I am happy to run 10.5.7 on such old laptop)

 

So, now the OS X is working, I only need to get sound+network+video(even tho I think ATI X600 wont work)

And I also need to make the processor run at 2.13GHz at boot otherwise I get kernel panic (it says something like this: reported fsb: 133mhz, actual fsb: 49.xx Mhz, cpu0 panic in rtc .....)

 

A temporary fix I did and it works sometimes, is to add -f switch to make the boot read all the kexts, so this makes the processor work, and it goes to full speed and the system boots.

 

All I need (as in "the most important right now") is to find a way to turn off speed step and make the processor always run in 2.13ghz instead of 800mhz minimum speed.

Link to comment
Share on other sites

All I need (as in "the most important right now") is to find a way to turn off speed step and make the processor always run in 2.13ghz instead of 800mhz minimum speed.

Have you tried to disable speedstep from the HW side, in BIOS?

Link to comment
Share on other sites

 Share

×
×
  • Create New...