Jump to content

Recommended Posts

Guys I need your help, I only have a problem to solve, everything else works fine in my asus zenbook ux32vd with i5-3317u processor and 1366x768 resolution screen.

 

The laptop use HD4000 graphics card, it have the nvidia GT620, but it is disabled with DSDT (PINI).

 

When im going to see graphics properties I have black screen (I have uploaded two videos to explain better), and when im going to help section, or when im going to install AutoCad, when the program need evaluate the graphics the screen blinks and goes black.

The problem only happened with @LVDS, if i used @HDMI i don't have the problem, the screen never goes black, i can see in HDMI but the laptop screen stay in black.

 

The partners with the same laptop but different hardware (i7 and fullHD resolution) don't have the screen problem only have the problem the laptops with 1366x768 resolution.

 

http://www.youtube.com/watch?v=rG25DUVIvVM&feature=youtu.be

 

Below what I tried:

  1. Various flags in config.plist of Chameleon: InjectIntel, GraphicsEnabler.InjectEDID, IgPlatformId (all). (I try with clover too, and have the same results)
  2. Ram allocated in the Bios (64,128,256,512 Mb)
  3. Changing AppleIntelFrameBufferCapri.kext
  4. Efi string.
  5. Several DSDT.

All without lasting results, sometimes the screen blinks only a few seconds, but no stay in black.

This problem occurs only with internal monitor, connecting an external monitor always works.

None of you had the same problem? I hope someone can help me.

Thank you all.

 

MacBookAir5,2.zip

Link to post
Share on other sites
  • Replies 20
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

are you sure you even have LVDS connector not an eDP connector? also try using another smbios profile like maybe macmini5,1 or 6,1

http://www.insanelymac.com/forum/topic/286092-guide-1st-generation-intel-hd-graphics-qeci/page-16

I've patched your dsdt with different platform id's in order to detect HD4000, so try them and let me know.   btw What's your screen resolution? DSDT_Test.zip

Hello friend @Bronxteck sorry for the wait, i had a lot of exams and i couldn't do anything about this.

 

I run ubuntu and check the connector, ubuntu said this:

 

PCH_LVDS: 0x00000000 (disabled, pipe A, 18 bit, 1 channel)

 

I have eDP connector, you can help me? thank you very much four your comments

Link to post
Share on other sites

×
×
  • Create New...