Jump to content

M4300 Mavericks post install issues: BT, HWsensors, shutdown, kernel caches


Recommended Posts



I think this is my first post here, but not my first hack :-) many thanks to this great community.


This one is a M4300 T8300 machine and I have tuned it according to the SMBIOS tuning guide to MBpro 5.1 1.42f4

Installed FakeSMC Kext version 5.4.944 and the corresponding HWMonitor.

My WLAN card shows as third party, but works perfectly fine.

The machine came without BT card, so I moved one over from an older D820.


Here are the issues that I still have and I hope that you can help me fix them:


1) no Bluetooth: BT is not shown in System-prefs and does not show in About this Mac either

2) no HW Sensors: the only HW sensors that I can get working are HDD temperature and internal battery charge percentage

3) the machine does not shutdown. it shows the grey screen, there is lots of hdd activity and it just sits there for ages. Have to shutdown with power button.

4) no kernel caches. I tried to build kernel cache using terminal commands, but keep getting error messages: Failed to generate prelinked kernel.



Thank you for your inputs


Link to comment
Share on other sites

  • Administrators

The SMC keys to use for the BacBookPro5,1 model/profile is 1.33f8, not 1.42f4. I don't know where you got that from




I've verified these settings as fully functional with Kozlek's FakeSMC v5.2.678 and more recent version such as 6.0.1011 for instance. This being said, if HWMonitor shows no sensors, it probably means your FakeSMC is invalid or incorrectly installed.


Are you using a myHack installation?


If so, success could depend on the manner in which you installed your version of FakeSMC. If you simply execute Kozlek's package, the kext will go to /S/L/E by default and HWMonitor app in Applications folder. What you really ought to do is:

1) modify the Info.plist of FakeSMC kext to reflect SMC compatible to "smc-mcp" and all 3 keys to 1.33f8

2) copy all 4 (or 5) FakeSMC plugins (ACPISensor, CPUSensor, GPUSensor, etc.) to the PlugIns folder inside FakeSMC kext

3) place modified FakeSMC kext in /E/E and re-run myFix (quick)

4) modify your SMBIOS plist to MBP5,1

5) remove all instance of NullCPUPowerManagement + CPUMonitor + VoodooPState + VoodooTSCSync kexts from /E/E

6) enable P+C States in Chameleon boot plist (keep other settings underneath unticked)


Regarding Bluetooth, do you know the model of the module you got out of that D820? I would expect it to be a DW350 or DW360. You would normally see it under the USB section of a System Report (via Apple Menu). Have a look at the Bluetooth thread in R&D->Hardware->Wifi/Bluetooth section; you may find that the BT radio was disabled when D820 ran Windows and that will render the module unusable under Mac OS X. You would need to re-enable radio from within Windows or you can try to patch the CSR plugin of IOBluetoothFamily kext and there's a good chance your module could be reactivated from within Mac OS X.


The shutdown issue is most likely due to cache not being built and this extra long time you're experiencing will be the system's attempt to rebuild the cache. Are you using the patched AppleACPIPlatform kext at all?


In fact, I'm beginning to wonder if you did an EDP System Build on this laptop?

Link to comment
Share on other sites

Hi Hervé


Thanks for your explanations. Meanwhile I have successfully installed FakeSMC 6.0.987 - downloaded from Github.

As the download is a PKG and I dont know how to edit it, I ran the PKG (gave me an error message on install) and copied the result from SLE back to EE.

Then edited the 3 keys in info.plist and ran myFix.

Now my HW Monitor is running fine with Cstates and Pstates working. 

I am getting warnings though: system is telling me that some kexts (sensors) are not by a verified developer - how do I add those to the exceptions list?


Now on to the BT issue...


best regards


Link to comment
Share on other sites

Part 2: BT and caches


Checked BT module hardware as per your instructions and per the tread given. Found that mine was a DW350; found a DW360 in another machine that I have sitting around and swapped it  -  now with the DW360 in the M4300 BT was working right after the next reboot.


It seems that this has also somehow (automagically?) taken care of the cache building issue, too.

I tried building the caches using terminal commands and all worked fine.

Even though some kexts are not included in the cache (Sierra wireless for my WWAN card and some others) the cache is now used on boot.

After one boot with a KP, the second boot was successful and now the machine is running quite nicely with CPU speeds between 796 and 2400 MHz.


Seems that I was not that far off target. I am quite happy now :-)

Thank you - this is great support.


best regards


Link to comment
Share on other sites


  • Create New...