Jump to content

HD4400 stuck on second boot


nnware
 Share

Recommended Posts

I installed Marvericks by myHack 3.3.1 with patched kernel for Haswell to Lenovo Thinkpad T440s laptop.

Thinkpad T440s laptop has HD4400 and GT 730M GPU.

 

On first boot after install (with option 'IntelAzulFB=12"),

HD4400 Graphics works fine with QE/CI.

 

But, After restart, It stuck on boot(or looping WindowServer clash).

 

It can boot with '-x' option or 'GraphicEnabler=No' option.

It also can boot after remove HD5000 kexts, But It kills QE/CI.

 

I want to know why first boot was fine but second boot was fail.

 

Any Suggestion?

 

 

 

Link to comment
Share on other sites

I already tried "SkipNvidiaGfx=Yes" option.

 

And I tried Re-Install serval time. 

Results are same.

First boot is fine,QE/CE are work. But Second time, WindowServer Clashed on boot.

I think Something changed while Setup Assistant or shutdown process on first time. 

So I think I have to reset something like PRAM.

Link to comment
Share on other sites

What SMBIOS definition are you using? You should be using a haswell macbook air/pro.

 

Does your laptop have a resolution above 1366x768? That requires DualLink injection.

 

In any case, try injecting ig-platform-id: 0x0600260a via DSDT and boot with GE=No

 

If you don't know how to, please upload your DSDT and ioreg and I'll patch it for you.

Link to comment
Share on other sites

Oh..I forgot to try with '-f' option because I already tried to rebuild boot caches.

I added '-f' and 'IntelAzulFB=12' options on boot.plist then HD4400 works fine now.

Thank you for remember me back to basics :)

 

I also changed SMBIOS definition to iMac14.2 (27inch late 2013)

 

Thank you for every one!

  • Like 1
Link to comment
Share on other sites

 Share

×
×
  • Create New...