Jump to content

D630 Mavericks Installer


Recommended Posts

I've created a Mavericks Installer Application for my D630. (I have a D630 Nvidia)

Maybe it works for other D630 owners.

It could work possibly for other models, if you replace the Extra folder in the D630 folder with your own.

(Feedback are welcome, whether it works or not.)




Unzip it and move or copy the whole folder 'D630Installer' to Applications.

You can replace the dsdt in the D630/Extra Folder with your own.

Do not change the rest of the folder.


You need a 8GB Usb-Stick and the Mavericks Install App from the AppStore.

Start the D630Installer.app in the 'D630Installer' folder and follow the instructions on the screen.


After making the Stick 

- copy the folder D630 from /Applications/D630Installer to the Stick.

- Download the Post Installer and copy the unzipped App to the  Stick


(after the completion of the stick you can find on the desktop a file named D630Installer.log,

you can read or delete the file.)

- - - - -  - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

When the Installation ask for a Bluetooth Keyboard, just press the spacebar.

- - - - -  - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

edit: important

After Installation is finished, boot from stick, in Chameleon choose your new Installation

and type -v -f


Run the D630InstallerPost.app from the Stick. Reboot.



here is the Installer script, if you wanna change it.

on run
		-- icon
		set myicon to "Applications:D630Installer:applet.icns"
		-- Frage Formatierung
		display dialog ("Welcome to the D630 Installer" & return & return & "USB Stick will be formatted, Continue?") buttons ["No", "Yes"] with icon file myicon
		if result = {button returned:"Yes"} then
			-- USB Stick wählen
			tell application "System Events"
				set theText to name of current user
			end tell
			set adminpass to the text returned of (display dialog ("type Password for user " & theText) default answer "" with title theText with hidden answer)
			set PW to result
			do shell script "echo " & PW & " | sudo -S /usr/bin/true" --sudo su
			with timeout of 3600 seconds
				-- Formatieren
				tell application "Finder" to set allDrives to the name of every disk whose local volume is true and startup is false
				set driveName to {choose from list allDrives with prompt "Choose USB Stick:"} as text
				set getDriveIdentifier to "diskutil info " & quoted form of driveName & " | grep Ident | awk '{print $3}'"
				set driveIdentifier to do shell script getDriveIdentifier
				set driveIdentifier to text 1 thru 5 of (get driveIdentifier)
				do shell script "echo '$PW' | sudo diskutil unmountDisk force /Volumes/" & driveName
				do shell script "echo '$PW' | sudo diskutil partitionDisk " & driveIdentifier & " GPT HFS+ InstallDisk 100%"
				-- Installations Programm wählen
				display dialog "Choose 'Install OS X Mavericks.app'" with icon file myicon
				set app_folder to quoted form of POSIX path of (choose file)
				do shell script "hdiutil attach -noverify " & app_folder & "/Contents/SharedSupport/InstallESD.dmg" -- DMG1 mounten
				set BasePfad to "OS X Install ESD:BaseSystem.dmg" -- DMG2 mounten -- OS X Install ESD
				set BasePfad to quoted form of POSIX path of BasePfad
				do shell script "hdiutil attach -noverify " & BasePfad
				do shell script "echo '$PW' | sudo asr -restore -noverify -source " & BasePfad & " -target Volumes/InstallDisk -erase -noprompt  -format HFS+" -- DMG restore
				-- USB Stick umbenennen
				do shell script "diskutil rename '/Volumes/OS X Base System 1' InstallDisk"
				-- Spotlight stoppen
				do shell script "mdutil -i off /Volumes/InstallDisk"
				-- FakeSMC kopieren
				do shell script "echo '$PW' | sudo cp -r /Applications/D630Installer/D630/FakeSMC.kext /Volumes/InstallDisk/System/Library/Extensions"
				-- NullCPU kopieren
				do shell script "echo '$PW' | sudo cp -r /Applications/D630Installer/D630/NullCPUPowerManagement.kext /Volumes/InstallDisk/System/Library/Extensions"
				-- mach_kernel kopieren
				do shell script "cp -r /Applications/D630Installer/D630/mach_kernel /Volumes/InstallDisk"
				-- symlink löschen
				do shell script "echo '$PW' | sudo rm /Volumes/InstallDisk/System/Installation/Packages"
				-- Ordner erstellen
				do shell script "echo '$PW' | sudo mkdir /Volumes/InstallDisk/System/Installation/Packages"
				-- Extra Ordner kopieren
				set extra_pfad to POSIX path of "/Applications/D630Installer/D630/Extra"
				do shell script "echo '$PW' | sudo cp -r " & extra_pfad & " /Volumes/InstallDisk/Extra"
				-- Chameleon installieren
				set champath to "/Applications/D630Installer/D630"
				do shell script "echo '$PW' | sudo installer -pkg " & champath & "/*.pkg -target /Volumes/InstallDisk"
				-- myhack kext kopieren
				set myhack to POSIX path of "/Applications/D630Installer/D630/myHack.kext"
				do shell script "echo '$PW' | sudo cp -r " & myhack & " /Volumes/InstallDisk/System/Library/Extensions"
				-- voodoohda kopieren
				set vodoohda to POSIX path of "/Applications/D630Installer/D630/VoodooHDA.kext"
				do shell script "echo '$PW' | sudo cp -r " & vodoohda & " /Volumes/InstallDisk/System/Library/Extensions"
				-- repairPermissions myhack kext
				do shell script "echo '$PW' | sudo chmod -R 755 /Volumes/InstallDisk/System/Library/Extensions/myHack.kext"
				do shell script "echo '$PW' | sudo chown -R root:wheel /Volumes/InstallDisk/System/Library/Extensions/myHack.kext"
				-- repairPermissions voodoohda kext
				do shell script "echo '$PW' | sudo chmod -R 755 /Volumes/InstallDisk/System/Library/Extensions/VoodooHDA.kext"
				do shell script "echo '$PW' | sudo chown -R root:wheel /Volumes/InstallDisk/System/Library/Extensions/VoodooHDA.kext"
				-- boot file kopieren
				do shell script "echo '$PW' | sudo cp /Applications/D630Installer/D630/boot /Volumes/InstallDisk" --with administrator privileges
				-- Packages kopieren
				do shell script "echo '$PW' | sudo cp -r /Volumes/OS\\ X\\ Install\\ ESD/Packages/* /Volumes/InstallDisk/System/Installation/Packages"
				-- Stick umbenennen
				do shell script "diskutil rename InstallDisk D630Installer" -- rename USB Stick
				-- Spotlight stoppen
				do shell script "mdutil -i off /Volumes/D630Installer"
				-- DMG1 auswerfen
				set disk1Name to "OS X Base System"
				tell application "Finder"
					if disk disk1Name exists then
						eject disk disk1Name
					end if
					-- DMG2 auswerfen
					set disk2Name to "OS X Install ESD"
					tell application "Finder"
						if disk disk2Name exists then
							eject disk disk2Name
						end if
					end tell
					display dialog "USB Stick finished!" & return & return & "You can now boot from the Stick" & return & "to install Mavericks"
				end tell
			end timeout
		end if
	on error errMsg number errNo
		display dialog errMsg & return & errNo
	end try
end run
Link to comment
Share on other sites

2014-02-15 06:53:17: Started partitioning on disk1

Unmounting disk

Creating the partition map

Waiting for the disks to reappear

Formatting disk1s2 as Mac OS Extended with name InstallDisk

Initialized /dev/rdisk1s2 as a 7 GB case-insensitive HFS Plus volume

Mounting disk

Finished partitioning on disk1


   #:                       TYPE NAME                    SIZE       IDENTIFIER

   0:      GUID_partition_scheme                        *7.9 GB     disk1

   1:                        EFI EFI                     209.7 MB   disk1s1

   2:                  Apple_HFS InstallDisk             7.5 GB     disk1s2

2014-02-15 06:53:39: /dev/disk2           Apple_partition_scheme        

/dev/disk2s1         Apple_partition_map            

/dev/disk2s2         Apple_HFS                       /Volumes/OS X Install ESD

2014-02-15 06:53:40: /dev/disk3           Apple_partition_scheme        

/dev/disk3s1         Apple_partition_map            

/dev/disk3s2         Apple_HFS                       /Volumes/OS X Base System

2014-02-15 06:59:58: Validating target...done

Validating source...done

Retrieving scan information...done

Validating sizes...done

Restoring  ....10....20....30....40....50....60....70....80....90....100

Remounting target volume...done

2014-02-15 07:00:00: Volume on disk1s2 renamed to InstallDisk

2014-02-15 07:00:00: /Volumes/InstallDisk:

Error: Index is already changing state.  Please try again in a moment.


Cant seem  to get the installer correctly on the disk.

Link to comment
Share on other sites

15/02/14 08:11:17,000 kernel[0]: hfs: mounted OS X Base System on device disk1s2

15/02/14 08:11:17,162 mds[57]: (Normal) Volume: volume:0x7feac38f7000 ********** Bootstrapped Creating a default store:3 SpotLoc:/Volumes/OS X Base System 1/.Spotlight-V100 SpotVerLoc:/Volumes/OS X Base System 1/.Spotlight-V100/Store-V1 occlude:0 /Volumes/OS X Base System 1

15/02/14 08:11:17,412 WindowServer[852]: _CGXGLDisplayContextForDisplayDevice: No matching context for device (0x7f940a51ea60) - disabling OpenGL

15/02/14 08:11:20,315 com.apple.kextd[12]: Warning: /Volumes/OS X Base System 1/System/Library/Extensions: No such file or directory

15/02/14 08:11:20,315 com.apple.kextd[12]: Warning: /Volumes/OS X Base System 1/Library/Extensions: No such file or directory

15/02/14 08:11:20,315 com.apple.kextd[12]: Note: /Volumes/OS X Base System 1/mach_kernel: No such file or directory

15/02/14 08:11:20,340 fseventsd[36]: failed to make the directory /Volumes/OS X Base System 1/.fseventsd (2/No such file or directory)

15/02/14 08:11:20,524 com.apple.kextd[12]: Note: /Volumes/InstallDisk/mach_kernel: No such file or directory

15/02/14 08:11:20,576 sudo[1301]:    admin : no tty present and no askpass program specified ; TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/bin/cp -r /Applications/D630Installer/D630/FakeSMC.kext /Volumes/InstallDisk/System/Library/Extensions

15/02/14 08:11:20,989 mds[57]: (Error) Server: Failed to register path "/Volumes/InstallDisk" to store <MDSStoreToken: 0x7feac26e5df0>{storeID:0x6b000140 registered:YES private:NO age:2ms uuid:11A9A194-14FA-4BE2-BC99-44EE884A8962}
Link to comment
Share on other sites

This worked well for my D630 with the exception that WiFi is not supported.  Everything else is awesome, even the trackpad works better than other solutions I've seen for similar laptops.  Any idea whether it's possible to get WiFi going on these machines?

Link to comment
Share on other sites



Not sure if anyone can help, I originally tried to install on an e6410 but gave up on that and instead decided on trying on my older d630 since it has the nvidia graphics card and the e6410 didn't. Anyway followed the instructions above but cant get even to the install screen the last line on the screen on verbose shows this


"using 64-bit bootcache playlist

BootCacheControl:unable to open /var/db/BootCache.playlist: 2 "


any suggestions please?

Link to comment
Share on other sites

did you replace the Extra folder in the D630 folder (on the USB-Stick) before Installation with your own Extra folder?


the myhack.kext in /System/Library/Extensions is for a D630, maybe you should delete it? (on the USB-Stick before Installation,

or on your installation disk - if you have it already installed)

Link to comment
Share on other sites

I was not able to get this to work successfully, but after some effort I have managed to install Mavericks on several D630s with nvidia graphics.  Everything works, including wake from sleep, Bluetooth, SpeedStep, and WI-FI (with WEP security only, or none).  I've tested this on D630s with either T7500 or T8300 processors, running either BIOS A17 or A19.  My only known remaining issues are: WIFI won't work with WPA/WPA2 security, and the microphone tends to stop working after waking from sleep.  (Suggestions welcome).  The process could probably be simplified, but here is what I do.


You'll need to have an external keyboard and mouse attached during the installation, but afterward open Bluetooth Preferences, Choose Advanced..., and de-select opening Bluetooth Setup Assistant when keyboard or mouse are not detected.



1. Carefully insure the BIOS is set as noted in BIOS Settings - D630 - D6xx - OSXLatitude Forum.  

Mostly, it is essential to set  SATA Operation = AHCI.

2. Follow complete detailed instructions at Pre Installation | OSXLatitude.com (three pages).

The instructions say myHack prompts for your Extra folder (downloaded from Bootpacks).  It doesn’t.  Just run myHack a 2nd time, and choose install Extra.


Post Installation - EDP  (download EDP updates first) - Config Options:

  • Dell - Dell Latitude - Dell Latitude D630, nvidia graphics card (Laptop)
  • Kext/Drivers
  1. FakeSMC: FakeSMC 6.0.1082 (Patched with MacBookAir5,1 firmware for IvyBridge)
  2. PS2 kext: ALPS touchpad --> important: leave alone
  3. Audio: VooDooHDA v2.8.4 (Latest) - Latest version should work with almost any machine.
  4. Wifi kext: Kext - Dell DW1395, DW1397,... (last in the list)
  • CPU & Power
  1. NullCPUPowerManagement (disables AppleIntelCPUPowerManagement)   OFF
  2. Patch for AppleIntelCPUPowerManagement  OFF
  3. SleepEnabler (works with NullCPUPowerxxx.kext)  OFF
  4. Emulated SpeedSteps (for old model cpus c2d etc..)  OFF
  5. VoodooTSCSync (Synchronize the TSC in intel cpus) ON  [i'm not sure what this does]
  6. Disable Intel Turbo Boost (on battery) OFF
  • Do build!

You'll get an error (System extension cannot be used …. AppleACPIEC.kext)


3. Reboot.  Microphone and bluetooth should work.  Go to network preferences to enable Wi-Fi (hit ok to the New Interface Detected dialog). Do a software update to upgrade to 10.9.2


4. Fix remaining three issues. 

  • There is no wake-up from sleep.
  1. Download the pre-built version of Kozlek’s FakeSMC from RehabMan / OS-X-FakeSMC-kozlek / Downloads — Bitbucket
  2. The HWMonitor app included works with this version of FakeSMC, and is very helpful to verify correct operation.
  3. Verify AppleACPIPlatform.kext (from 10.9.2) is in /System/Library/Extensions
  4. Delete AppleACPIPlatform.kext and FakeSMC.kext from /Extra/Extensions
  5. Use KextWizard to Install Kozlek's FakeSMC.  (Combine with I8k.kext to save time).

  • The fan stays on constantly

  1. Get the updated version in post #3.
  2. If you read the posts, please note that I do not need to monkey with /Library/LaunchDaemons/i8kfan.plist, or do anything else to make the fan work as expected.  Just install the kext and it works.
  3. Notice you can modify the settings in I8k's Info.plist to adjust the temps the fan runs Low and High.
  4. Use KextWizard to install I8k.kext 

  • SpeedStep doesn't work, and the system runs at it’s slowest speed (about 600MHz)
  1. Delete /Extra/Extensions/VoodooPState.kext
  2. Run Chameleon Wizard


Time Out 1

Generate P-States

Generate C-States

Graphics Mode - 1440 x 900 x 32


SMBios (then Edit)

Premade SMBioses: MacBook Pro (5,1) - Core 2 Duo

(This is the earliest version which speed step works)




Get screen resolution, Apply

Choose any theme you like

  • After these steps (or individually if you do them separately) run myFix (in myHack).  Choose Full.
  • I also install the Hackintosh Chime Boot Sound from https://github.com/nicoSWD/Carillon.

5. Reboot and verify (try HWMonitor, and maybe Geekbench); customize and enjoy.  Someone recommended choosing Start up automatically after a power failure in System Preferences / Energy Saver (to help with wakeup issues, and I do this.

  • Like 2
Link to comment
Share on other sites

  • Create New...