Jump to content

Turning off Bluetooth in Mavericks


flex
 Share

Recommended Posts

Hello all,

 

I have a Qualcomm Atheros 3011 (Vendor ID 3304) bluetooth adaptor on my Asus K43SV. I managed to get the bluetooth working by installing Rehabman's IOath3frmwr.kext using Kext Utility. I am able to see other bluetooth devices, pair with them and send files to them. However, I was not able to send any files to my Hackintosh from my android phone. I am new to hackintosh, so I am not sure there is a combatibility issue, or any driver installation is required. I do not have any other apple devices to try sending a file.

 

Also, I am not able to turn of bluetooth. The Option Button is greyed out. I came across various posts on Apple community itself, mentioning that Bluetooth was not turning off even on native hardware. Is this the same issue? Or is it something wrong with my kexts? A verbose mode boot showed nothing. All features except Realtek USB 2.0 card reader, Touchpad (Keyboard issues with EmlyDinesh's driver & Kernal panic with Voodoops2 even after appleps2nub removal ), Alcor Webcam work perfectly on my Hackintosh.

 

Can anyone guide me on how to turn off my bluetooth, as the battery drain is significant? I will try bluetooth file transfer using a apple device to send file to my Hackintosh  and post back tomorrow.

 

Edit: Tried sending a file from my Samsung Galaxy S3. I get a notification Network is unavailable. On a closer look, after I double click the device and connect it, the status immediately changes to Not Connected. Outbound files transfers are fine.

Link to comment
Share on other sites

  • Administrators

Depending on hardware and OS X version, the BT Finder icon may not actually totally switch off BT, it may only turn it off at OS level. You could find your BT blue led still lit on your machine. If you want Bluetooth completely  or definitely off, you may have to disable it in BIOS.

 

That's valid for all recent OS X versions, not just Mavericks.

Link to comment
Share on other sites

Thanks for your reply.

How do I turn it off at the OS level as the turn off bluetooth button is greyed out. Can I turn it off using command line? I tried using blueutil from http://www.frederikseiffert.de/blueutil/ but still bluetooth is working, and I can see other devices and pair. buelutil status says bluetooth is off.

 

Also my Android phone disconnects immediately after pairing and i am not able to send any files to my laptop. Vice versa works fine. I tried with another android phone, and the issue persists. I dont have any other apple device to give it a try. Is there some other tweaks required?

 

EDIT:
 

Tried a nokia phone and a friend's iPad. The issue persists. I can send files from my pc but I cannot receive any files. So after all my Bluetooth isnt working properly.

post-8795-0-30455700-1392617095_thumb.png

Link to comment
Share on other sites

 Share

×
×
  • Create New...