Jump to content
PayPal donations: [email protected] ×
girardpallet

[SOLVED] E6530 update from 10.9.1 to 10.9.2, LOSE sound

Recommended Posts

Good news!

Created my very first patched AppleHDA with hints from pokenguyen. Tested on E6430, should work on all Exx30 models with 92HD93xx.

Tested to work:

  • Internal speaker
  • Headphone / autoswitch
  • Internal Mic
  • HDMI audio

You can get it here.

Hi,

 

I'm a noob thus I'm gonna ask a noobish question: How do I install your patch/update?

 

Thanks,

 

Adrian

Share this post


Link to post
Share on other sites

Hi,

 

I'm a noob thus I'm gonna ask a noobish question: How do I install your patch/update?

 

Thanks,

 

Adrian

Put new file in Extra/Extension. Launch myHack.app from Applications, enter password, select myfix (quick). To add the string to org.chameleon.boot.plist, you'll need Chameleon Wizard or copy file to Desktop, edit it with textpad and copy back.

Share this post


Link to post
Share on other sites

So, I have copied the kext folder to /Extra/Extension, ran myHack but the sound still is not working.

 

The second part of your advice I didn't do because I'm not sure I understand what needs to be done. Could you please elaborate?

 

Thanks,

 

Adrian

Share this post


Link to post
Share on other sites

If you have Chameleon Wizard installed on your computer (if not, install it and place it in your applications folder - Google it and download the application), open Chameleon Wizard (update it if necessary). On the page that opens, there is a button on the bottom right to install the latest version. Your current version is indicated on the bottom, the latest version is indicated on the top. If you click the button, it will update the version of Chameleon to the newest version.

Share this post


Link to post
Share on other sites

If you have Chameleon Wizard installed on your computer (if not, install it and place it in your applications folder - Google it and download the application), open Chameleon Wizard (update it if necessary). On the page that opens, there is a button on the bottom right to install the latest version. Your current version is indicated on the bottom, the latest version is indicated on the top. If you click the button, it will update the version of Chameleon to the newest version.

Done! What next?

Share this post


Link to post
Share on other sites

Done! What next?

Now go to Extra, open org.chameleon.boot.plist with Chameleon Wizard. Under Audio, check HDAEnabler and Enable HDMI Audio. Reboot

  • Like 1

Share this post


Link to post
Share on other sites

Now go to Extra, open org.chameleon.boot.plist with Chameleon Wizard. Under Audio, check HDAEnabler and Enable HDMI Audio. Reboot

It worked like a charm. Thanks a lot for your help!

Share this post


Link to post
Share on other sites

BTW Having strange issues with Sound.. esp. using Flash.. after 10 15 mins.. The sound goes on Mute.. Eg. Playing a You tube video in Chrome..or any flash for the matter...sound still seems to be working (testing by increasing/decreasing volume)..Anyone else seeing this?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...