Jump to content

Dell D820 Post Install No Network connectivity and not able to install EDP


Recommended Posts



Zero network connectivity with ethernet.

No wireless network connectivity 

No Sound.  

Not sure of what else yet 

Was able to copy the version of EDP and put on USB. 

Tried to install but it stopped when said needs internet connection. 

Did I miss loading something?   Is there a way to do this manually by loading on USB  from good machine and porting over?  






- Dell D820  

- Bios A09 

-Intel Core 2 CPU  T7200 @ Gghz  1.99 Ghz @2.00GB Ram 

-Display Adapeter Nvidia Quadro NVS 110M 

Network -  Not sure  I think it is a broadcom (Integrated) I have both an ethernet RJ-11 receptacle and Wireless on this device.  

Audio -  Not sure and not sure how to determine that.  

 - My hack latest version

-  USB Created this AM using the My hack

- Trying to install Snow Leopard 10.6.3  (brought brand new retail version of this release) 


What I did


Everything finally installed right on 3rd attempt 

Loaded bootpack for Dell D820 through Extras (Selected use my own) 


Booted up.. got the welcome to Mac screen with the visuals and prompts to register etc.  

However noticed in install log that it did not load (Wireless)  It said that this device did not have it  (It does)  

It did not load sound, sound is disabled 

No network connectivity.  Connected ethernet cable due to no wireless working, would not give me an ip address.  

Ran My Hack from USB again using the My fix (seeing if that would correct?)   It didn't 


Looking for suggestions please 


Link to comment
Share on other sites

Side Note:  I have done all the basic network troubleshooting.  I am using a known good connection.  

No issues with router or cabling etc.  

I am just not getting an IP address.  I get straight amber and amber blinking light. 

I am betting this is a driver ( I am not familiar with the terms for mac) issue.  



Link to comment
Share on other sites

  • Administrators

Check your Ethernet kext (driver) in /Extra/Extensions:




Native and/or non-native wireless functionality depends entirely on the card model. Look at R&D->Wireless sub-section for details; there's a thread that lists (non-exhaustively of course) supported and unsupported cards.

Link to comment
Share on other sites

I will be honest with you.  I am little lost on this.  I have looked at the thread and the indications.  

This is what I do not understand -  


For the boot pack I can't tell if it includes the drivers or not.  I am assuming that it should.   Does it not and you need to get them elsewhere?  


There are some references to doing surgery to the texts which I assume are the drivers.  However I am not sure what it is referring to.  


Sorry I am a bit new to all this... I need baby steps if possible      Thank you for your patience in advance.  

Link to comment
Share on other sites

I too have a D820 with slightly different hardware. My GPU and CPU are different, but the wired and wireless are the same I think. I managed to get 10.6.3 on this one only after disabling on of the cores. I have been unsuccessful trying to get either network connection to work. Profile shows no Ethernet or wireless cards installed. 3 weeks of effort to get this far. I have tried many things to make them work as well. I used iFail S3 v2. I'm scared to upgrade.

Link to comment
Share on other sites

Don't use a distro; use our recommended installation method: myHack + retail OS X + bootpack. For SL, you'll need to use myHack v3.1.2.

I have a retail SL. but have been unsuccessful at putting myHack or chameleon on a bootable flash drive. I can put them on cd, but when I put my OSX disk in and hit f5 it reads no boot sector.

Link to comment
Share on other sites

  • Administrators

If you mount your SL DVD, myHack should normally be able to use it to create the USB installer. Failing that, you'd need to create an image of the DVD that you'd then mount and use with myHack. You need to have an existing hack or a Mac to do that of course.


Naturally, the alternative is to use ModCD that fully supports the direct use of a retail DVD.

Link to comment
Share on other sites

I finally managed to get my hackintosh running. I have upgraded to 10.6.8 . I have no networking due to incompatible drivers. For $4.00 I bought a small usb nic and it works fine. However, I am still unable to figure the 2 problems that have plagued me for 2 weeks. My profile shows the GMA950 but no kext loaded. I have tried 4 different versions and the OS rejects them or they don't load. I'm currently stuck at 1024x768. Not able to play videos offline because of the quartz accelerator not being present. The app store doesn't work, saying this is not an authorized mac.

I tested and found that the wallpapers transition smoothly so that is a plus. I can watch video online. The second problem is that I keep having to type cpus=1 at boot up even though it is in the com.apple.boot.plist and the chameleon bootloader. 

I fixed my sound,mouse,trackpad, and keyboard with the voodooHDA and voodooPS2 kexts. I use the voodooBattery kext as well.

Link to comment
Share on other sites

  • Create New...