Jump to content

Samsung NP900X4D Mavericks Install


Recommended Posts

First post, long time wannabe hackintosher. Recently I've picked up a Samsung NP900X4D-A03CA laptop, which looks promisingly similar to the NP900X4C/X3C models. i5-3317U and similar (if not same?) BIOS's.


First, I'd like to take time in advance to thank anyone willing to lend a hand :D

Second, I've done a hackintosh install before using Hazard's Intel/AMD SSE2/3 distrobution, and although it wasn't pretty, I managed to hack away at it until it was fully functioning on an AMD Athlon II X2 240 processor. Fun times.

Third, I'm definitely willing to provide logs, DSDT's, SSDT's, etc, etc. with a little guidance. No, there's not a working anything installation as I'm trying to make this soley an OSX machine, but I can definitely hop into a bootable Linux distribution of anyone's choosing should it assist us in pulling DSDT's or other ACPI data from the mobo.


So, without further ado, here's the specs:


Screen Size 15 Inches
Native Screen Resolution 1600 x 900
Processor Type Intel Core i5-3317U
Processor Cores 2
Processor Speed 1.7 GHz
Processor Cache 3 MB L3
Hard Drive Capacity 128 GB
RAM Size 4 GB upgraded to 8GB myself
RAM Speed 1600 MHz
Built-in Memory Card Reader Yes
Memory Card Reader - Compatible Memory Type SD; SDHC; SDXC
Graphics Chipset Intel HD Graphics 4000
Video Memory Configuration Integrated
Dedicated Video Memory Size Not Applicable think it's 64MB, NO OPTION IN BIOS
Wireless Display (WiDi) Capable Yes
Type of Pointing Device Touchpad I believe it's ELAN, verbose boot showed these kexts loading fine
USB 2.0 Ports 1 / USB 3.0 Ports 2
VGA Output No via expensive dongle, don't really care about
HDMI Output No via micro-HDMI, adapter has been ordered
Ethernet Port Yes Ethernet worked out of the box, providing it was plugged in/active on boot
Integrated Wi-Fi 802.11b/g/n not working, I am aware of having to buy replacement card
Integrated Bluetooth Yes - 4.0 worked fine out of box, according to verbose kext log
Laptop Thickness (closed) 1.5 cm
Laptop Weight (including battery) 1.65 kg



Problem I've having is getting it to boot without the black screen Intel HD4000 problem. Here's what I've tried so far:

  1. Originally I started with Niresh's 10.9.2 customized ISO meant for both Intel and AMD systems, and it worked OK for the installation part. No boot flags required immediately from the get go, just pop the DVD into my external USB DVD Drive, USB 2 or 3 port works fine, boot up, install with default options. The problem is upon reboot, it hangs unless I use the GraphicsEnabler=No flag, and then it doesn't hang, but gets stuck at a black screen, probably trying to display over the micro-HDMI port. (I have ordered a micro-HDMI to HDMI adapter to help troubleshoot this.)
  2. I went back at least 8 times, selecting different SMBIOS.plist files, none of which helped in any way, and eventually booted into single user mode -s and was able to run their grafix backup all script to clean all the Intel kext files out. After that, I managed to get it to boot and login, although I had to do so as root because it skipped the initial setup screen...?
  3. Anywho, since then I attempted to use EDP, which failed because of other kexts already loaded from Niresh's, so I figured as I have a half-baked install, why not use it to download legit Mavericks and run myHack? Plug in USB for formatting, kernel panic! :D
  4. Needless to say, I ended up creating a myHack USB Installer at work on their Mac's, and used the NP900X4C compatibility pack from OSXLatitude, including your handy guide. Problem there is the installer would also boot to a black screen unless I used -x safe mode flag. (Yes, I did try the GraphicsEnabler=No/Yes and the IGPEnabler=No/Yes flags just for the giggles, neither of which helped.)
  5. I went ahead and installed it from -x safe mode flag boot, and selected the "/Extra" Kexts folder bootpack for the NP900X4C but upon reboot, it would start up, seem normal in verbose mode (no abnormal errors) until Mr. DSMOS arrives which is when it finishes booting and bingo bango! Black Screen. I have also tried the IGPlatformId=xxxxxxxx and IGPEnabler=Yes flags, they're not seeming to do anything different.

I seem to be in the same pickle as this guy's thread and would love any assistance or insight's into my sillyness. According to the information @Stanislav was able to provide, the Samsung 900X3C/900X3D/900X4C/900X4D models all share the same motherboard, so technically speaking they should all be able to use the same bookpack or DSDT files, yes? (assuming the processors are all i5-3317U's as well)


Anywho, I'll await patiently and see if we get anywhere, and do have Mac's at work I can use to keep making hackintosh installation USB's.


Many thanks,


Link to comment
Share on other sites

  • Administrators

update chameleon and try 

IntelCapriFB=value For Intel HD 4xxx, range 0-11

value is a number from 0 through 11 also your cpu has VT-d it is known to cause issues on some machines for now turn it off in bios or use dart=0 flag

  • Like 1
Link to comment
Share on other sites

 update chameleon and try 

IntelCapriFB=value For Intel HD 4xxx, range 0-11

value is a number from 0 through 11 also your cpu has VT-d it is known to cause issues on some machines for now turn it off in bios or use dart=0 flag


Many thanks; I will give it a shot once we're home from the long-weekend holiday here.


Threw Ubuntu 14.04 LTS on it for giggles, and amazingly, EVERYTHING works OOB. Sound, Ethernet/LAN, as expected, and unexpectedly WiFi, Backlight controls, and even Backlit keys! Taking it with me whilst away to use on 3G/Cellular for fun.


Rest assured, I shall be wiping it when I get home and attempting a clean install using the myHack USB I created, but this time with your provided boot flags, and attempt to turn off VT-d in BIOS.


EDIT: I've tried all combinations of @Bronxteck's suggested boot flags IntelCapriFB=X (X=0-11) and attempted to turn off VT-d in the laptop's BIOS, but that setting doesn't seem to exist, so I also tried the flags each with dart=0 as well.


The installer was created on a 2013 27" iMac running OS X 10.9.2 Mavericks with a freshly downloaded Mavericks installer from the AppStore. I used myHack 3.3 to create the installer, and applied/copied over the EDP compatibility pack for the NP900X4C laptop, which should have the same motherboard as all the NP900Xyz models as according the the ACPI tables I was able to pull from Ubuntu.


Darwin/x86 Boot v5.0.132 | Chameleon svn2266 | myHack 3.3

Build date: 2013-10-27 12:29:10 (USB INSTALLER CREATED April 2014)


Strangely enough now, I cannot get the Installer to boot using safe mode -x and GraphicsEnabler=Yes/No anymore... is it possible that the initial install could have broke it?

Link to comment
Share on other sites

  • Create New...