Jump to content

D620 / 945GM ML Install (No Ethernet)


Recommended Posts

Ok, Here's what I have and what I did...


I have a Dell D620, 945GM Graphics, Intel BCM5751 Ethernet (at least, that's what worked on Lion)


I have followed the steps for Phase 1 from Herve's instructions... but here is what I did.


  1. Using my VM ML Install, formatted a 8gb Thumbdrive for Mac OS Extended (Journaled)
  2. Ran MyHack and selected "Create OS-X Installer" (after entering my sudo password of course).
  3. Selected my freshly formatted thumb drive labeled "installer"
  4. Located the install app "Install OS X Mountain Lion" (this is rev 10.8)
  5. Then I let MyHack do its thing...
  6. After complete, I restarted MyHack and selected "Install Extra"
  7. Navigated to the unzipped folder for the "Extra_D620i_lores_ML" and again let MyHack do its thing...
  8. Ejected the thumb drive and booted my D620 from it.
  9. I had Lion installed, but I went ahead and erased the HD to do a clean install (I didn't have anything I needed to keep on there anyway as I'm pretty new to this).
  10. Let the installer do the install...
  11. Selected a custom Extra folder at the end and pointed to the "Extra" located at the root of the thumb drive...
  12. Let Installer complete (with failure but that's okay!)
  13. Reboot system onto ML/HD Install.

At this point, I was able to complete the 1st boot setup, but I had no network connection. I checked the Network Utility and it doesn't show a Network Card installed.


I rebooted using -v and saw the following error during the boot:

    kxldcom.apple.iokit.AppleBCM5751EthernetJ:  The Mach-O file is malformed: Invalid magic number (0xfeedface)

    Can't load com.apple.iokit.AppleBCM5751Ethernet - link failed

    Failed to load executable for kext com.apple.iokit.AppleBCM5751Ethernet.

    Kext com.apple.iokit.AppleBCM5751Ethernet failed to load (0xdc008016).


I tried swapping the kext from my Lion install (since it worked) and got the same message.

I saw in a different thread where someone had some KP issues that were apparently resolved by updating the Chameleon Loader to V2248 so I thought that may help. I downloaded the Chameleon Wizard to my D620 (via thumb drive) and ran it, but was disappointed when I saw it failed to run because it needs internet connection.


So, can anyone see something wrong I'm doing??

Or, if I'm on the right track with the Chameleon update (thought the whole 64/32 bit loading issue may be the issue) any suggestions how I can update the Chameleon without Internet? Is there a more direct way to update without the Wizard?


Any thoughts are appreciated... in the mean time, I'm still plugging away trying to figure this out.

Happy Hacking!!   :-P



Link to comment
Share on other sites

Hmm... never mind... I found the obvious answer to my question when I saw the options to change the location where Chameleon gets the update package from.... Dohhhh!!! I selected internal and was able to update to r2286 but I still get the same error after a reboot.


I also tried reverting back to the original kext for the Ethernet but still the same error.


Still looking into it...



Link to comment
Share on other sites

Thanks for the reply Hervé. I tried the kext you posted using myfix but no change. I also tried re-installing ML and replacing the kext on my installer with the one you provided (rebuilding the Extra folder with MyHack first of course).


I still get the same error message as above.


BTW, I didn't post before, but my BIOS is A10 and I have the BIOS settings done according to the D620 BIOS settings page.


Any other suggestions? Is there some log file or more information I can share that may shed light?

I'm continuing to look into it on my end.




Link to comment
Share on other sites

Thanks Hervé. I'll try that as soon as I can.


Since my last post, I was able to scavenge a DW1490 wireless card from one of our old work laptops (no longer in use) and swap out my Intel wireless card so I am on wifi now and applying ML 10.8.5 updates. Next step MLPF


I still want to get the Ethernet working, but at least it's not as pressing now.


I'll keep you posted.


Thanks for your help.



Link to comment
Share on other sites

Well, after applying the MLPF and following the Phase 2 instructions (with a couple of hiccups) my D620 seems to be working at or near 100%.

The Ethernet started working right after applying the PostFactor patch... not sure what actually got fixed.


One thing I was worried about... after applying the ML update to 10.8.5, I restarted the machine (even though Hervé states in the instructions not to reboot). I was worried, but everything worked fine anyway so I'm not sure why you're not supposed to reboot.


So, thanks for your help and thanks to all for the great work you have done with OSXLATITUDE.

I will be contributing $$.



Link to comment
Share on other sites

  • Create New...