Jump to content

M4300 Mavericks problems with EDP


Recommended Posts

Just reinstalled Mavericks on my M4300 T7500 nVidia Quadro FX 360M, for the 3rd time. Installation went fine, like the other 2 times. I just updated to 10.9.4 via Software Update and all went well. 


The first 2 times I downloaded EDP from the website via Ethernet and it installed okay. I chose the standard EDP for this model.


Both times I had problems with a kernel panic when the EDP install finished.


And both times at reboot I had a weird problem: I booted from my USB drive and then chose my internal HD with Mavericks. The boot started but then after a few seconds it went back to the original screen with the icons for the USB drive and the hard drive. When I selected my internal HD again, I got a message that there was a problem with the "magic number". Never seen that before.


Any suggestions at this point?


The Mavericks 10.9.4 install works well, except:


1) no wifi: I have a Dell 1390 installed and it usually works fine. I also tried the custom kext via EDP for the 1395, etc. but as I said, I got a kernel panic at the end of EDP install


2) my processor shows up as Core 2 Duo 1.2 Ghz, instead of the real 2.2 Ghz.


3) no Trackpad control panel, so don't have scrolling.


Sound works great, the system seems pretty fast, battery charge shows up and the battery lasts as it should (almost 3 hours, like under Windows 7).


I was pretty happy with the 10.9.4 update, which I did unattended. When I came back it was booted and ready to go with 10.9.4.  

Link to comment
Share on other sites



Just to recap:  M4300 T7500 Core 2 Duo processor 2.2 Ghz, niVidia FX 360M, display 1920 x 1200, DW1395 wifi, 4GB RAM, 500GB HD.

Bios A15.


Working well. I used Mountain Lion for a couple months and it worked fine. Dual boot with Windows 7. No problems.


Recently upgraded to Mavericks. Did a clean install. Used different bootpacks: the one on the bootpacks page, one that Herve linked a few months ago, and one that another user linked a few months ago.


Installation went good with all 3 bootpacks and the most recent MyHack.


My problems are post-installation.


Ethernet worked out of the box and after installation I connected to the site to download EDP. I chose the standard build for the M4300. But I got a kernel panic just as the EDP installation was finishing. I got this kernel panic 3 times at the same point in the EDP installation.


I tried a custom build and I got a kernel panic again.


Using Herve's bootpack it works okay, but I don't have wifi - even with the modified Broadcom kext - or trackpad.


Also, processor speed is always listed as 1.2Ghz and the M4300 does seem slower.


After one successful installation with Herve's bootpack I updated to 10.9.4 from App Store and it went perfectly.


Any ideas re. the best Build to use? Best kext options?


3 key points to resolve:


a) Processor speed shows 1.2Ghz instead of 2.2Ghz

B) No wifi, even with modded kext for DW1395

c) No trackpad

Link to comment
Share on other sites

  • Administrators

On a T7500, make sure IDA is disabled in BIOS (or system will run 10% slower than expected speeds). Follow the recommended settings for performance tuning (files and SMC keys are provided).


Reported speed at 1.2GHz is just a cosmetic matter. Run myFix (quick) or rebuild your permissions with Disk Utility and you would find that you'd be back with a reported speed of 2.2GHz at next reboot; but it may change back to 1.2GHz. I can't remember how I fixed this on my D630s before.


Wireless with DW1395 will only work on clear networks. For encrypted networks, you'll have to swap for a fully compatible card like some Atheros. Refer to the inventory posted in R&D section for details.

Link to comment
Share on other sites

Thanks for fast reply.


I'll go back and fine tune performance with a different FakeSMC. 


Re. the DW1395, is the problem with encrypted connected with Mavericks? I was using a DW1390 in the M4300 when I had Mountain Lion and it worked fine. But now, with Mavericks, neither the DW1390 nor the DW1395 work.


I think I have a DW1490 lying around somewhere. Don't know if it's different from the other two but I can try.


Any recommendations re. Trackpad kext?

Link to comment
Share on other sites

  • Administrators

Full size DW1390, DW1490 and DW1395/7 (on clear networks) work in Mavericks. I use them all. The inventory does make mention of reported problems with ½-size cards, but I've never had one to play with.

Link to comment
Share on other sites

  • Create New...