Jump to content

Lenovo x201 Bios error


hamid37
 Share

Recommended Posts

Hi

I now get this error before bios boot : 0189 invalid RFID configuration information area

Then I have to press ESC to start booting into mac or Win , but it's anoyying. Is there any fix for that? I also noticed asset tag field is empty, where and how I can restore asset number.

Lenovo x201- Bios 1.4 whitelst

Thanks for any help

Link to comment
Share on other sites

Hi Hamid

 

I found you question, looking for a solution to the same problem.  Now I'm back to tell what I found:

 

A German language forum had a discussion some years back on th problem, see:

 

  http://thinkpad-forum.de/threads/22528-T20-mit-Fehler-0189-Invalid-RFID-Configuration-Information-Area

 

Several other links in a Google lookup (rfid error lenovo) refer to User Manuals, for example for T540, in particular to page 134:

 

Error: 189 Invalid RFID configuration information area

Solution: The EEPROM checksum is not correct (block # 4 and 5).  The system board
should be replaced, and the UUID needs to be reinstalled.  Have the computer serviced.

 

In the German language forum one member told that a solution was obtained when  "the serial number was written to the EEPROM by use of a Hardware Maintenance Diskette" where UUID might be identical to the Serial Number (of the machine?).

 

Let me know, if you can use this and perhaps help me along.  I have no idea of where to obtain a maintenance diskette or how to use it.  For the time being I make do with the Esc-button.

Link to comment
Share on other sites

Hi oldfux

Thank you for your time and effort. The method you mentioned may have worked for some people but not in my case. I obtained a copy of the MD and installed on a flash disk. Booted with that , re-wrote, erased serial no etc.. And tried to re-assign UUID , but non worked. I'm not sure but maybe I'm still doing something wrong. I got the latest Maintenance disket and managed to make a bootable usb and run the program but when I command assign UUID I get error :UUID already assigned. I dont have the instalation exe file any more but still have the USB pendrive and it's still working. If you like I can send it to you to try on your system, perhaps you could find a way.

Link to comment
Share on other sites

Hi Sergeant

 

Thank you for your offer.  I trust your experience, even though my sources were official Lenovo manuals.  Perhaps the second part of their 'solution': get the machine serviced' is the way to follow, if we get annoyed by use of the Esc-button.  I am not competent to work at that level anyway.

Link to comment
Share on other sites

 Share

×
×
  • Create New...