Jump to content

[ Installation Any models ] No AHCI models, Installer doesn't see your boot drive [ SATA 3 card]


Recommended Posts

:!: I changed title of this topic. Aug 22.


This is my first thread, Take it easy :mrgreen:


Some DELLs has no AHCI in the BIOS, IT’s famous first wall to install OSX, All you already know very well.

OK, I would like to say few G33 DELL PCs are not available to Mods IOATAFamily.kext. I tried out Vostro 400 and Inspiron 545. *and maybe Vostro 410.

I’m not sure if possible to install as other way.

Some DELL PCs are not available to IOATAFamily.Kext ( Patched AppleIntelPIIXATA.kext ) , Or Installer didn't see boot storage at the installer screen if you set a SATA mode to RAID. I confirmed VOSTRO 400 and INSPIRON 545 are like that.

Optiplex 745 / 755 are seem to be same result, But they are not my experience.


But don’t worry about that, Our only  hope is SATA 3.0 card used Asmedia chip. My chip is ASM1061. You can buy at the Amazon USA. I have one bought from Japanese amazon, Japanese version has changed pats a little bit. I believe USA version card should works same, These are seem to be same circuit board and chip. *Japanese has output e-Sata to switching.


I used 2 slots Graphics card, So I mod extension PCI-e, see my pic.



*I always hope some experienced guy make a new AHCI bios to those PCs.


Installer could see AHCI storage through this SATA card, Works OOB. No need to extension kext and other tools. You should add a IOAHCIBlockStorageinjector.kext since post install to see built-in storage not removable one.


For Example:


*Vostro 400 is almost same method, But you can use Vostro 200 DSDT is completely same.


Model: Inspiron 545s

CPU: X5470 3.33GHz with LGA771 to 775 adapter

*I will make a new topic of LGA771 mods for Hackintosh Compatible list.

Graphics: Geforce GT610

HDD: SiliconPower S55 240GB

SATA: SATA3 Asdedia PCI-e card.


Pre install:

OS Helper: MyHack *Chameleon boot loader

Boot options: -v  npci=0x2000 GraphicsEnabler=No (*PCIrootUID=0)


Post install:

Restart/shutdown: EvOreboot.kext

Removable Strage to onboard strage: IOAHCIBlockStorageinjector.kext

SSD Trim support: Trim Enabler

Network: RTGMAC_V2.0.6

Audio: VoodooHDA-V2.8.6.pkg


Check the Boot option of Chameleon.boot.plist, listed bellow:


Time out = As you like

kernel : mach_kernel

use kernel cash



Ethernet built in

Restart fix

Generate P-state

Generate C-state


*GT610 to set: GraphicsEnabler=No PCIRoot=0


Works perfect, No issue.



SATA card didn't give full performance of latency. PCI-e's transfer capacity is very lower, but work well. I think you don't feel it slow.

Link to comment
Share on other sites

  • Administrators

Interesting solution for SATA 6 capability (and AHCI SATA mode) for those older PCs that can be limited to SATA 1.5 or SATA 3 specs. You just used a PCIe x1 riser cable, right?


Note that some of those Dell BIOS can actually be modified to unlock AHCI SATA mode for the motherboard controller. On unmodified BIOS, I understand AHCI is implicitly available by selecting RAID mode (without actually configuring any RAID array).
I've been using such a modified BIOS on my own Vostro 200 for the last 3 years or so and been running with the onboard controller SATA mode set to AHCI since. Details are available here and here.

Link to comment
Share on other sites

Thanks for your experienced comment as prompt action.
OK, I already tested Vostro 200 and Inspiron 530. I know that's works very well with modded BIOS from BIOS-MODS forum.
You can check a lists, I made it. But is for LGA 771 to 775 relation to OSX. I will post another thread.
I tested G33 mother board without AHCI mods, A RAID mode to set also, I didn't succeeded with IOATAFamily mods on these DELLs. I'm not sure before ~ OSX10.7.  *And additional to say, See my list, I succeed to set a RAID few DELLs works no issue...
Let me know if you found my misunderstanding without my very bad English...lol

Link to comment
Share on other sites

Oh boy!!! I tried many times, I don't know why I didn't. I'm gonna try it soon. This thread is kind of useless...Sorry for that  8-)  


About 10 min latter...


I tried out, Installer doesn't see HDD even if set to RAID. I used MyHack latest one 10.9.1 on the USB stick. That's also shorter way to use SATA3 Asmedeia card.


Vostro 200 is the G33M-02 motherboard, I had it was long time ago. I forgot How to Install to use with it. Vostro 200 was succeeded with RAID That can be possibly so. I think flashed a AHCI BIOS soon after bought that...


Vostro 400 is G33M-03 Motherboard for QuadCore, Little deferent I think.


Thank you for tell me. I'm very happy to confirm the installer. I appreciate to care my thread :-P 

Link to comment
Share on other sites

  • Administrators

Thread is not useless, it's a potential solution for those machines with BIOS where SATA mode may not be configurable and OS X installer does not see the HDD. I think that was reported for other Dell desktops like some Optiplex 745 or 755. Something like that anyway.

Link to comment
Share on other sites

OK, I wanna tell you Vostro 400 and Inspiron 545 are same circuit board, I succeeded they are same method to install OSX without network.


>I think that was reported for other Dell desktops like some Optiplex 745 or 755.

I didn't know that, That's sound very interesting for me. They need also SATA3 card.


My DELL's start point is little deferent from other guys. I'm Mac Pro user and had thinking up grade it everyday. LGA771 XEON cpu can install on many DELL desktops.  And they can also run OSX. Gigabyte and Asus...Them mother boards are similar with OSX, But they does not to work OSX if put a XEON.


PS: Do you still have a vostro 200? You can use X5270 ( 3.5GHz 6M-cache ), If you have a any time to try it.

Link to comment
Share on other sites

  • Create New...