Jump to content

D630 w/ Intel x3100 Low-Res, (1280x800) - Dramas with EDPv6 and Lion 10.7(.5)


Recommended Posts



Simply a stunning attack vector - when getting your Dell Latitude D630 Lappy, 'up-up-and-away' on OS X!


Brilliant work, (and hat's off to all), for putting together such an amazing resource - across a well laid out, and beautifully presented 'Site.



OK, having a red-hot-go at getting a Dell D630 Intel x3100 'Low Res', (read 1280x800), airborne on Lion v10.7(.5)


(The '.5' is in brackets - due to my probable misinterpretation of the specific steps required to get from a fresh install of v10.7.2, up to v10.7.5)



Here's what's happening right now;


Upon booting via 'Boot Verbose' within Chameleon, tonnes of progression - until hitting the skids at 'Still waiting for root device'...



How I got here;  (and due to the obvious 'Uber-N00b-ality' of me, myself and I - I have listed every single exact step that has led to this current knotted-ball-of-string...)


- Began by downloading 'myHack v3.3.1' onto my iMac, running Snow Leopard v10.6.8

- Within an Admin Account, placed a verified Lion v10.7.2 'InstallESD.dmg' onto the Desktop

- Formatted a 16GB USB Stick as directed, ran myHack v3.3.1 and wrapped up the creation of the USB Installer, using the correct and already unzipped Bootpack for my Low-Res D630

- Configured my D630's BIOS Settings, (version A19), as directed

- Booted from the newly minted OS X v10.7.2 USB Installer, and managed to progress to the 'Choose Langauge' prompt found within the OS X Installer

- Selected Disk Utility from the Menu Bar and formatted the internal 80GB SATA HDD of the D630, as a 'Mac OS Extended (Journaled)' HDD, committing to the Erase with a write of zeros across the 'Drive, just to be safe-and-sure

- Upon format completion, just to double-down with extra safety, selected Partition / 1 Partition / and within the 'Options' ensured that 'GUID Partition Table' was selected

- Suitably convinced I now had a 'clean-tight-and-tidy' HDD, I then let the USB Installer off-of-the-chain and the installation of 10.7.2 went off without a hitch

- As directed at the 'Generic Kexts' prompt, I successfully chose 'Use My Own' and located the appropriate 'Extra Folder' created by the initially downloaded and unzipped Bootpack file from Step 3, above

- I hit 'yes' to every prompt regarding any extensions of concern, and once resolved - commenced to reboot from the internal 80GB HDD



This is when the first issue arose...


I couldn't get to the Create Account / Registration Process, unless I chose 'Boot Ignore Caches' from within Chameleon.


Nevertheless, once this boot option was selected, I was able to complete the Create Account step, and proceed straight into a fresh, clean and new, Lion Desktop.


By this point, I was feeling very, VERY impressed - at just how far the Hackintosh Community - as a collective - had made this entire process to this point, so easy for me.


I really did feel as though I was standing on the shoulders of unquestioned greatness!



Next move, obviously straight into EDP.


- I configured my new Lion environment's Ethernet for all-systems-go, and immediately downloaded the 'Install_EDP_v6.zip' file - onto my new Lion Desktop

- As directed, double-clicked on the unzipped 'Install EDP' icon and entered my sudo password at the prompt waiting within the Terminal Window

- Without any hesitation, the installation concluded and with a selection of immediate launch, a fresh window opened - revealing the minty-lushness of the beautiful work put together by all of you Gurus, otherwise known as EDPv6.


Simply breath-taking, gorgeous work.  Stunning visuals, amazing layout - incredible vision!



However, this is where the real problems began...


- Instructions made it clear to 'refresh' the model database within EDP, so before anything else I updated via the 'Config Button' and chose 'Download EDP Updates'

 - Once complete, I then headed back to the 'EDP Button' and hit the 'Build from model database', but the list refused to reveal ANY systems at all, within the drop-down list

 - I re-attempted a 'Download EDP Updates', but still no joy within the drop-down for selecting ANY system at all...


Attacking the Forums, I discovered a few others were having the same issues - EDP v5/6 refusing to populate the drop-down.


Within this Topic - https://osxlatitude.com/index.php?/topic/7126-cannot-download-bootpack-d630-x3100-low-res-missing/?hl=d630i_lores_10.7.5_tuned_pack&do=findComment&comment=42126 - somebody was having the same problem as me, and somebody else, gave the option of downloading the files for my D630, that EDP needed as a 'Ready-to-Go-Pack'


So, needless to say - I grabbed the same Pack as well.


Upon downloading it, I noted that it said that it was for v10.7.5 - not v10.7.2 - and this is where everything starting to go all-fuzzy-and-wild...


Indecision, turmoil, uncertainty - what to do?


You guessed it - because I was in a new Lion v10.7.2 Desktop - (and not v10.7.5) - I stupidly moved the 'MacOSXUpdCombo10.7.5.dmg' over - and applied it.



Now that the UpdateCombo for v10.7.5 has had it way with this installation, at the Chameleon boot-loader - immaterial of whether I choose 'Boot Ignore Caches' or not - there's simply no more OS X Login Prompt for me...


Selecting 'Boot verbose' instead - as stated at the beginning / at the top - progresses until 'Still waiting for root device'...


So, there it is - I haven't managed to locate a solution within the Forums - so Help(?), and go easy on an Uber-N00b!


Thanks in advance.

Link to comment
Share on other sites

  • Administrators

Clearly, the EDP issues have not been sorted yet.
Meantime, you can safely use the pack offered here for your initial Lion 10.7.2 installation as well as for your expected 10.7.5 update. No EDP required.
Use it when you create your USB installer and when you install Lion 10.7.2. After that, there should be no issues at all updating to 10.7.5 (combo update or update via Apple menu) without further action.


NB: You should answer Yes to all questions about kext removal at the end of the installation, but do not install MBR patch (there's a little bug in myHack v3.3.1 and it's not needed on a GUID partitioned disk).

Link to comment
Share on other sites



Thanks for the prompt reply.



OK, still a couple of issues - but...


- Grabbed your Bootpack as directed.  (Downloaded as 'D630i_LoRes_10.7.5_Tuned_Pack.zip')

- Unzipped it and placed it on the Desktop of the same Admin Account on my iMac, running Snow Leopard v10.6.8

- Launched Disk Utility and reformatted the 16GB USB Stick, (now completely empty, with a single GUID Partition)

- Relit myHack v3.3.1, entered my sudo password for this Mac Account when prompted - and again chose 'Create OS X Installer'

- Once again I chose 'Create OS X 10.7 Installer'

- Selected the 16GB USB Stick to create a fresh OS X Installer

- Selected the same 'InstallESD.dmg' from round one, as the source for creating a v10.7.2 Installation

- Let myHack v3.3.1 run riot, ensuring I denied the request to allow for MBR Partitioning

- myHack v3.3.1 DOES NOT THEN PROMPT YOU FOR YOUR EXTRAS, it simply wraps up the creation of your USB Installer

- Once myHack v3.3.1 had finished, I relaunched it and now chose from the initial drop-down, 'Install Extra'

- When prompted for the location of the USB Installer to be 'modded', I chose the freshly-minted USB OS X v10.7.2 Installer created only moments earlier

- Next, I was asked to either go 'Generic' or 'Use My Own', obviously 'Use My Own' was selected

- Finally I was prompted to browse for the location of my 'Extra' Folder, and so I did - navigating to the Extra Folder contained within the unzipped file from earlier, (originally labelled as 'D630i_LoRes_10.7.5_Tuned_Pack.zip')

- myHack v3.3.1 took the bait and amended the USB Installer, and upon resolving all necessary tasks then informed me that all-was-well


With a deep breath, I then double-checked all of the BIOS Settings within my Dell D630 Low-Res, inserted the 'new' USB Installer and Powered Up.


The first thing I noticed was that your Bootpack had correctly set the aspect ratio within the OS X Installer, (no more 'stretched' Mac Installer environment!), so I then launched Disk Utility and reformatted the internal 80GB HDD once again.


- Away the Installation went, and as before, at about three-ish minutes left to completion, up came the request to go either 'Generic' or 'Use your Own'

- I then inserted an additional USB Stick that also contained your 'Extra' Folder from your originally zipped file, and directed the Installer to use this Folder

- The Installer gobbled this Folder up and continued on, unabated

- Once again, the usual array of requests for removing/ignoring problematic Kexts all came and went and were all answered 'Yes' to remove each one

- Installation wrapped up, and upon reboot, I removed both USB Sticks - and crossed both fingers


The reboot featured your 'different' chromed Apple Logo, but it appeared to stall.

After approximately five minutes of zero Hard Drive activity, (No HDD LED action - but still spinning boot 'paddle' icon), I killed the Power and restarted the D630.


At the Chameleon bootscreen, tapped a key to provide boot options and instead this time, selected 'Boot Verbose'.


Watched intently, until the boot process again stalled and snapped a Screen-Shot with my iPhone;


(Sorry about the large image size - I just wanted to ensure that the necessary detail was present-and-accounted-for...)



(Tell me what you make of this...)




Nevertheless, I cycled Power again and this time chose Chameleon's 'Boot Ignore Caches' option, and Voila! - straight into the Lion 'Create Account / Register' prompts.


Happy Days - and found myself again standing upon a fresh Lion v10.7.2 Desktop - this time, with PERFECT screen aspect ratio and resolution!


Immediately set the time correctly, but as soon as Spotlight commenced its Indexing of the HDD - several prompts popped up on the screen as follows;








Now, each time I execute a reboot - I can only get to the Login Prompt, if I chose the 'Boot Ignore Caches' option within Chameleon.


Needless to say, I'm holding back from the upgrade to v10.7.5 until advised to do so by you.


Again thanks for your help so far - but what-say-you, can I stretch the friendship for just a little more help?




Many Regards and thanks in advance...

Link to comment
Share on other sites

  • Administrators

It seems that once you've booted into Lion, you need to re-run myFix (quick) to repair permissions and rebuild cache (so that you don't have to boot ignoring it). This being said, sometimes myHack.kext proves to be damaged, so you can then delete it from /System/Library/Extensions and re-run myHack app and proceed with Install myHack Utilities to reinstall the whole (myHack) thing.

Link to comment
Share on other sites

Snap-Crackle-Pop and Shazzan!  ( <- Ignore the Hanna-Barbera reference, if you're too young! )


I can now attest to the shear brilliance of Hervé-The-Almighty!


If you can't be bothered encumbering your installation of Lion with any form of EDP - onto a Dell D630 x3100 Low-Res (1280x800) - then read this Topic from the top and simply follow my every step from Post #3 - and along with Hervé-The-Almighty's additional input - you too, will have a D630 like mine...


- Perfect Screen Aspect Ratio and a number of useful resolution selections available within 'System Preferences / Displays'

- Analogue Audio In and Audio Out working flawlessly, as well as the embedded Speaker and Mic, (even the D630 Volume Up/Down recognised by OS X!)

- Ethernet ready-to-rock!  (Well, mine appeared as 'Bluetooth PAN', but I simply relabelled this to 'Ethernet' within 'System Preferences / Networking')

- Seamless 'Sleep' on Lid-close and Resume on Screen-open or Power Button - just perfect.

- Bluetooth 'OOB', (Out-of-Box), good-to-go - and the Wireless Switch on the side, once configured in BIOS, disables it as well!

- Trackpad deliciousness includes two-finger, (well, one 'fat finger'), zoom/scroll and one-touch tap

- Complete integration with Li-Ion Battery Charging and state-of-charge reporting in the Menu Bar

- Firewire instant provisioning, (Just awesome for Target Disk Mode within OS X!)

- Recognition of the standard RS232 Serial Port, (but yet to confirm OS X can 'see' it)

- All USB Ports fully functioning at USB 2.0 Speeds

- Immediate ability to engage the DVD-ROM for DVD Playback within DVD Player

- All keys recognised on the Keyboard, (although still yet to eliminate the 'pesky' Bluetooth Setup Assistant that presents at each boot, due to 'no keyboard detected' when the D630 Keyboard is definitely present and working...)


That said, that done - just need to sought out the WiFi.

(See my post over on the 'Supported/unsupported Wireless cards inventory' Topic, for how I'm hoping to resolve this issue...)





Thank you once again for your unwavering support - for my first 'dabble' into this Mad-As-World of Hackintoshing.


Can you confirm-or-deny that the Bootpack you were kind enough to supply me, (D630i_LoRes_10.7.5_Tuned_Pack.zip), has also been optimised for the maximum possible 'giddy-up' for the x3100 Video Hardware I have on my D630, when it comes to Quartz Extreme and Core Image performance?


I read what both yourself and 'Bronxteck', (Mario), have been up to over on the 'Performance tuning with FakeSMC & SMBIOS plist' Article - (an excellent write-up by the way!) - and was wondering if I also now need to walk down the same road, or if what you gave me within your supplied Bootpack - has all of this - already 'peaked'?


(And any idea of 'disposing' of the persistant Bluetooth Setup Assistant, as mentioned above?)



Cheers again - and again, thanks in advance.

Link to comment
Share on other sites

  • Administrators

Yes, it's all tweaked & tuned-up, nothing further to do, except any potential wireless card setup if non-OOB model in place. You can easily check up the tweak through:

1) System Profiler->Hardware: look at the model identifier & SMC version reported

2) SMBIOS plist: look at the Mac profile used

3) Run HWMonitor and look at CPU throttling 


-> All should be as per the article you read.


Re: bluetooth Assistant annoyance, go to the Bluetooth PrefPane and uncheck those 2 cases you will immediately notice. You'll easily understand...

Link to comment
Share on other sites

I am the original Muppet!


Having come all the way from Mac OS System 6 - all the way through to OS X Lion, (yes - I have come ALL the way, from Mac OS System 6, System 7 - (System 7.6.2 was my favourite!) - Mac OS 8, Mac OS 9, and then across into OS X - (including 'Kodiak'!) - through 'Cheetah', 'Puma', 'Jaguar', 'Panther', 'Tiger', 'Leopard', 'Snow Leopard' - and now finally Lion…)


With this history - I should well and truly have remembered the parameters within the Bluetooth PrefPane, so - my apologies...


A couple of clicks later, and the Bluetooth Setup Assistant issue - resolved.



I couldn't be happier.


After 'de-tuning' the Lion-esk-ness-ness of Lion, somewhat back to Snow Leopard - (read, switch off 'Restore windows when quitting and re-opening apps' for starters!) - I have been throughly impressed with just how responsive and incredibly stable this D630 is - flat-crack sprinting - not running - Lion!


Immaterial of whether this D630 can or cannot progress any further beyond Lion - I couldn't care less, (as I'm just not really that keen to move any further forward anyway) - as too much starts to become stripped away from what I consider OS X's true roots, fundamentally to be.


If I wanted a Laptop to 'feel' like iOS, then I'd buy an iPad!


It's taken me this long to finally move up and away from Snow Leopard, (which I already miss to a degree, as - no more Rosetta, no more 'Save/Save As', no more Front Row, etc-etc…)


But - Safari 5 was starting to show its limits when roaming around within today's Internet environment, and at least within Lion, you instantly get Safari 6 - and once updated to the latest v6.1.x - is then fully loaded with the same WebKit2 engine, security, and additional grunt as provided for Safari within 'Mavericks' and 'Yosemite'.




Hence from the get-go, I still get to somewhat retain a 'Classic OS X feel', but now with current cutting-edge Safari capabilities.


Aside from 'all the good stuff now gone', I'm pretty impressed with all of the new goodies - and additional claws - Lion brings to the table.

For example, native Full-Screen on everything from Safari, Terminal AND ALSO Full-Screen Screen Sharing! - through to Mail as well - (so, OK, this iOS-ish-ness I don't mind…)


But I'll be damned if I'll be moving any further forward, as I feel 'Mountain Lion' officially marked the end of what I believe OS X should be all about.


Just too much focus on trying to make what was once an incredible Desktop / Server operating system - into the retarded cousin of iOS.

(I also hate the unabated and ongoing high level pressure, to 'integrate' with iCloud as well…)


Plus too boot, some of the Mac's about the place here - just can't natively migrate past Lion anyway.


(Currently running a selection of Late'06 iMacs, Late'06 MacbookPro's, plus a couple of '08 dual-QuadCoreXeon Xserves Xgrid'd together - for any and all heavy lifting!)


Well, it's good to finally be here - finally up on Lion - swinging hard with the King-Of-The-Jungle...

Link to comment
Share on other sites

  • Create New...