Jump to content

OSX Mavericks install hanging at Bluetooth HCI


Recommended Posts

So I'm getting going on the Thinkpad X201 OSX Mavericks installation.


I'm using the installation guide from kreye:




I've built the USB and made it through the installation process. I did have trouble with step 6, moving the SLE folder. For some reason I couldn't do it through the osx terminal (bash 3.2). It didn't recognize the commands. So I un-journalled the drive, then booted to a Linux flash drive, moved the SLE, then back to the hack usb stick to re-journal the drive, then boot.


Now I'm in the OSX Installation process...


It hangs deep in the process at ****[iOBluetoothHCIController]...






A few notes.


1. I am still on BIOS 1.23 (I have the new one, to fix the whitelist, but my battery is completely dead so I don't want to risk flashing the BIOS until my new battery gets here).


2. I removed the wifi card completely and turned off the wifi switch.


3. I've tried it with the BIOS Display set to Analog VGA and to the Thinkpad LCD


4. Machine type Model is: 3626W58 Core i5, 2.53 gHz


I've read many/most of the posts here, insanely mac, and thinkpad forum. There is quite a bit on video, but I'm assuming that it was all rolled up into kreye's fixes in our forum.


Any help would be greatly appreciated.

Link to comment
Share on other sites

Ok, I got past this. Note to others. Un-journaling and re-journaling an HPF drive doesn't work. So I went back and did a new installation USB with a different Extra pack that did not require so much editing of files after the fact, and it worked.


I've updated all the way to 10.9.5 and most things are working pretty well, except... I don't think I have full QE/CI. My system file for graphics still says "no kext loaded" under the Intel HD graphics. Not sure if my menu bar is translucent or not? It looks aqua or teal (like in the photos), but how would you really know unless there was something behind the bar to see through? I don't have the DVD player to check that menu as in the post http://www.insanelymac.com/forum/topic/286092-guide-1st-generation-intel-hd-graphics-qeci/.


Any thoughts on how else to: verify QE/CI and if it's not working how to get it to work?

Link to comment
Share on other sites

Ok so just to close up this thread. I got the whole thing working just as it was supposed to (several times now). Turns out my USB installer was just not quite right. I made a new one using the Extra-Lenovo_201x_mav.zip https://osxlatitude.com/index.php?/topic/5744-maverick-on-lenovo-x201/page-3.


I did have to use the non-whitelist BIOS in order to allow my new Dell 1510 wifi card to work, but the installer found it perfectly and had me set up during installation.


Overall the Thinkpad X201 is about as straight forward as they come once you fix the BIOS for the wifi.


I do note that the battery life seems shorter on Mavericks than either of my other partitions (WIN7 or Linux). And the trackpad is very very fast (not sure if there is a fix for that?)

Link to comment
Share on other sites

  • Create New...