Jump to content

Optiplex 755 mini Tower and Yosemite


clickmikes
 Share

Recommended Posts

Hi again.

 

Need your help for some problem where I am stuck:

 

Trying to revive my "oldish" Optiplex 755 mini Tower and bring it up to Yosemite. It has a IHC9-R board and Nvidia Geforce 210 made by Zotac. It is currently running Lion 10.7.4 and Windows Vista dual boot. Bios is A22. Graphics seems to work OOB, for yosemite, but needs more thorough testing after the OS is installed.

 

This is what works:

Got a Clover USB boot stick with Yosemite on it and your bootpack drivers in EFI-Clover-Kexts-10.10

The AppleIntelPIIXATA2 kext is there, too, but it does not load.

 

I get to the installer screen and when I check with Harddisk-tool, all I can see is the USB stick that I booted from.

When I check system information, I can see no ATA, but in PCI I can see that it recognizes the AHCI as

ICHR9-R with PCI 0x8086, 2922

and further down I can see Ven ID 0x8086 and Device ID 0x3a22

However no driver is loaded, so it cannot see my harddisks.

 

I have tried by modifying the info.plist for the XATA2 kext and added those IDs that I saw in system information, but no luck so far.

 

Do you have any ideas?

Thanks for your help.

 

best regards

 

Michael

 

Link to comment
Share on other sites

I looked at the machine once again.

When booting in Lion, it shows an ICH10 AHCI and using Version 1.2, so my info in the first post was not quite right.

ICH10 also matches the PCI ID 0x3a228086 that I see in system information.

 

I have seen in the AppleAHCIPort kext that comes with Yosemite that ICH10 is in the info.plist with exactly this PCI ID.

Why is it not loading a driver then?

 

BTW I also tried booting with PCIRootUID=4, did not help either...

 

Ideas?

Link to comment
Share on other sites

 Share

×
×
  • Create New...