Jump to content

Complete set of files (Clover/Enoch) for El Capitan/Sierra


Recommended Posts

Glad to hear that :D


Now, you should had some success by placing DummyUSBEHCIPCI.kext in /Library/Extensions or /S/L/E :P.


DummyUSBEHCIPCI.kext can't work from EFI/CLOVER/kexts/10.11 because of dependencies ;).


USB_Injector.kext has not this problem and that's why I thought it was a better solution.

Link to comment
Share on other sites

I really love the USB_Injector.kext method in combination with Clover on my D830. This way I can keep the /S/L/E as clean a possible for OSX updates.
The solution works fantastic for USB thumb drivers and the mouse, but when I plug in my iPhone 4S it doesn't seem to work. 

It's dutch, translated:


Power for USB-device

Connect iPhone to a USB-port of this Mac.

Link to comment
Share on other sites

Yeah I noticed that too with one of my USB thumb. AFAIK, this is happening with just one particular device and I wasn't able to reproduced it with other devices (tested various USB thumbs, external hard disks and Webcam).


I'm looking for a fix without any success yet but my guess is that something is wrong in the port Injection. I'm confident it can be fix by some DSDT patch/edit or by using a different UsbConnector value in USB_Injector.kext's info.plist.


But I've already tried different values and it still the same. Some values even prevent ports for working with other devices.


Any help would be appreciated on that matter ;).

Link to comment
Share on other sites

First, you should read that. Installation is the same for D630 & D830.

Now, answers :D :

How am I supposed to format the stick to make it bootable on the D830? Currently, I'm using 1-partition, MBR/HFS+ although I also tried GPT/HFS+.

Clover : GUID
Enoch : MBR

After partitioning/formatting, should I use the CreateInstallMedia method from terminal, or should I use one of the user-friendly all-in-one tools?

I didn't tried createinstallMedia Method and used the old one. Should work the same though…

Should I use Clover or Chameleon for the best chance for succes?

As you wish. But keep in mind that only Clover is able to activate iMessage…

Is it sufficient to use the standard Clover or Chameleon install with only the files from post #9 when I create an El Capitan install stick, or should I add more kexts?

No it isn't. Well actually, it is if you use the whole Extra folder and Enoch. But it's not if you use Clover. In addition to replace the standard config.plist by the one supplied, you have to copy all kexts from the Extra/Extensions folder to /EFI/CLOVER/kexts/10.11.


Also, don't forget to place DSDT.aml file in /EFI/CLOVER/ACPI/patched !

Are any bootflags necessary for the install stick to boot?

Nope. Both org.chameleon.Boot.plist + kernel.plist and config.plist are ready to use as it.

Can I create the stick from a VM (everything looks to be OK when I try) or should I use a "real" Mac/Hac? When necessary, I can use a crappy but working version of Yosemite Zone on an XPS L502x.

Sure. No need to use anything else than the Mac App Store and Disk Utility. Whether it's a Mac or a Hack.

Most important for me at the moment is to be able to create a stick that at least boots into the OSX installer. (…) My ultimate goal would be to have El Capitan running on my D830, hence my reaction in this thread.


Use Enoch (and NOT Chameleon) or Clover r3259 (minimum) and you'll have no problem to install and use El Capitan on a D830.

Btw. my D830 has nVidia 140M graphics, 1920x1200 screen, 4GB of RAM, T7500 processor and currently bios A17, although I can downgrade it to any other version when necessary. I already set the bios settings according to the sticky.

Fine because that's all you need ;).

  • Like 1
Link to comment
Share on other sites

Wow, that's almost a step by step guide! Thanks a lot, I'm going to try it again!


It looks like Enoch is the key why I couldn't get Chameleon to work, but I still don't understand why Clover doesn't boot at all, since I used the newest version I could find. Anyway, I will try the Enoch method since for some reason Clover's hybrid boot block isn't recognized by my D830.

Link to comment
Share on other sites

Well on mine, I use this settings :





I don't use BiosBlockIO. You could try to install Boot0af in MBR instead of Boot0ss in MBR option. My D830 can only boot using the later but who knows… ;).


And yes, Enoch is the key point here. Chameleon is not ready for El Capitan yet but it will be soon so stay tuned :D !

  • Like 1
Link to comment
Share on other sites

Again, thanks a lot for your help! I finally managed to get the installer booting and running on my D830. One of the key tricks proved to be the use of Enoch instead of Chameleon, although I also had problems booting Chameleon with Mavericks and Yosemite (I always use the latest version). Another key trick was the use of a different USB port. I don't know why OSX is so picky ,when I can boot general recovery sticks from any USB port, but it turned out that every stick has it's own preferenced port for booting.


Maybe I will try to create another stick based on Clover, with the settings you suggested above. iMessage would be nice ;)

And I have to dig my house for the Atheros card that still must be lying around somewhere.


One funny thing I noticed is that although the touchpad of the D830 is not a real trackpad and doesn't support multi-touch, it is still possible to use a kind of two-finger scrolling with only one finger in a certain area of the touchpad. Since OSX doesn't have the clickable scrollbars "Windows style", this is very useful, sometimes it's your only way of scrolling the screen. The trackpoint doesn't work but I never used it anyway, but since the upper two mouse buttons belong to the trackpoint, these aren't working either. Not a big issue.

Link to comment
Share on other sites

Hello, first of all, thank you for this amazing tutorial.

However, even if my USB ports are working now after upgrading Yosemite to El Capitan, there's no input response. I mean, the mouse and keyboard are detected but cannot pass the login screen because pointer doesnt move and can't enter any text either.


Do you know how to fix this? Am I missing something? I'm like a newbie with this hackintosh thing tho :P

Link to comment
Share on other sites

For USB to work it's mandatory to :


• Use MacBookPro5,1 SMBios


• Use Clover's config.plist supplied with DSDT patch or if you're using Enoch/Chameleon edits in DSDT to change EHC1/EHC2 device to EH01/EH02 (I've attached a new Extra.zip with already edited DSDT for Enoch users in post #9)


• Use USB_injector.kext in bootloaders appropriate folders or in Library/Extensions or /System/Library/Extensions


• Set CsrActiveConfig value to 0x3 or 3 for Clover/Enoch


That's all.


Note : The USB_Injector.kext is not perfect. Some devices complains a lack of power when plugged in. Any help would be appreciated to fix that problem ;).


Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...