Jump to content

9020 Yosemite - USB3 HDD not working in SS-USB but does in USB2


Snookiwooki
 Share

Recommended Posts

Hi All,

 

Firstly I must thank Jake Lo for his work on getting OSX on the 9020.

 

I am a serious novice OSX user, though I am a tech with 20+ years Windows service (ouch!) so please bear with me.

 

PC is a 9020usff with i7-4770s, 16gb, HD4600.

 

Overall experience is very sweet, though having an issue if I plug my external Lacie USB3 HDD into the SuperSpeed ports it is not recognised.

 

If I plug the same drive into a USB2 port it is recognised as is a USB2 HDD in the SuperSpeed port.

 

I replaced the USB3 kext in Extras with the RehabMan-Generic-USB3-2014-1016 as suggested in another post for the 9010 - as these are vaguely similar machines though same issue arises.

 

Any help, tips, pointers would be very much appreciated.

 

SnookiWooki

 

 

P.S. Out of curiousity what is the 'Correct' way to copy the kernel over to a freshl OSX install - I took the SSD out and connected it my Mac Mini and copied the files and installed Chameleon on it...

Link to comment
Share on other sites

  • Administrators

Re: copy of kernel file, what you did was appropriate. Just verify permissions/ownership afterwards (should be owned by root:wheel (i.e. 0:0) and permissions set to 755 (i.e. rwxr-xr-x)) and adjust if necessary from Terminal:

sudo chmod -f 755 /System/Library/Kernels/kernel
sudo chown -f 0:0 /System/Library/Kernels/kernel
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...