Jump to content

yosemite upgrade, or not


john67
 Share

Recommended Posts

  • Administrators

Well, you'd actually be very ill-advised to attempt upgrading to Yosemite!

 

OS X  does not support Intel GMA950 graphics beyond Lion 10.7.5 and such support is limited to 32bit kernel mode. From ML, no drivers for obsolete Intel GMA graphics controllers and kernels+kexts are all 64bit only.

 

So the most recent OS X version that will run with full hardware support on your D520 is:

  • Lion 10.7.5 (in 32bit kernel mode) if you have a 64bit Core2Duo CPU
  • Snow Leopard 10.6.8 (in 32bit kernel mode) otherwise
Link to comment
Share on other sites

 Share

×
×
  • Create New...