Jump to content
PayPal donations: [email protected] ×
balchy

D420 cannot get sleep to work - what to check?

Recommended Posts

Hi

 

I have a D420 working well now on SL 10.6 but cannot get sleep to work.

 

Spec - D420 dualcore with 2gb memory, broadcom wireless (replaced) Snow Leopard 10.6

 

Steps taken so far:

 

Followed WIKI guidance on fixing sleep

Using: EDP 1.9.1, and then EDP 1.9.2 from a previous post from Leon (fixed sound for me)

both with and without "nullcpupowermanagement" (though I think I shouldn't expect sleep to work when this is installed) without sleepenabler.kext

 

Not tried:

sleepenabler.kext (I am not sure how to identify the right one to use)

updating to a more recent SL version (reading about networking issues, so want to avoid)

 

Laptop never successfully goes to sleep.

 

With nullcpupowermanagement, press power button, select sleep: screen goes off, but fan etc does not power down, power light does not pulse and I am unable to wake - have to force a reboot with long press of power button.

 

Without nullcpupowermanagement, press power button, select sleep: screen goes off, powers down, power light pulses. If I press the power button again, I get a full reboot. Keyboard, trackpad buttons do not wake.

 

Not sure what else to check or reconfigure next...

 

 

Thanks in advance for any advice

Share this post


Link to post
Share on other sites

Hi,

 

I'm a noobie and have the exactly problem as the op. Same hardware etc. I have enabled the bios password and the problem still persist. It is like the display goes to sleep and hard disk sleeps, but the system does not. And you cant wake up from it.

 

I also do not have the option in my bios to default the settings.

 

Any ideas?

Share this post


Link to post
Share on other sites

On my D430 1.33 C2D with 10.6.0 and E.D.P. 1.9.2, if I install nullcpupowermanagement with Sleepenabler.kext resume from sleep does not work with symptoms as described in the original post (screen blanks, power light remains on, will not wake with power button).

 

If instead I use Apple native power management, sleep works.

 

For clarity, bios A09, bios password set, bios reset to defaults,

 

CPU temperature seems to be holding steady at ~62-65o.

 

Is this typical of others experience?

Share this post


Link to post
Share on other sites

now you need to apply the hibernation fix in edp... option2 then 2. yes they run warm on lion mostly when there is a lot of hdd activity like dropbox sync or spotlight index or video well flash video html5 runs a bit cooler. to keep temps down it needs nullcpu and the sleep enabler. or cookbook patched for lion (quirky) great in snow leopard though.

Share this post


Link to post
Share on other sites

I applied the hibernation fix, but this made no difference.

 

Thinking that maybe I had messed something up during the install I started from scratch:

 

1) installed snow leopard 10.6 from USB image with no issues

2) Downloaded EDP 1.9.2 & installed

3) Ran EDP and:

a) Pressed 1) for kext configuration

i) Selected 1 for D420/D430 dual core, 1 for mouse, y for nullCPU, y for sleepenabler, 1 for battery, y for emulated speedstep

ii) Retuned to main option screen

b ) Pressed 2) for Fixes

i) Selected 1 for Touch/System/Library/Extensions

ii) Selected 2 for hibernation fix

iii) Retuned to main option screen

c) Pressed 3) for installer

i) Selected 7 to install Chameleon SVN2.1 1684

ii) Returned to main option screen

d) Q to exit

e) Reboot

f) Entered BIOS A09, checked defaults set and system password set, saved and exit BIOS

g) Once back into 10.6, press power button and choose sleep option from window. Screen blanks, fan continues to run and green light in power button stays on. Can not resume from sleep - only way to resolve is to press and hold power button until switch off and then restart.

 

I then re-ran EDP and at step 3) a) i) chose the same options but for nullCPU instead of y I chose n and reboot, sleep then works as it should, but the laptop runs ~10 degrees hotter.

 

I would really appreciate any help with getting nullCPU to work with sleep.

 

Thanks

Share this post


Link to post
Share on other sites

×
×
  • Create New...