Jump to content

E6220 with Clover Help


pafkata
 Share

Recommended Posts

Hello, I have E6220 with Core i7-2620M and it's running Yosemite 10.10.5 thanks to Herve's guide !!

 

I have tried to prepare El Capitan USB following Jake Lo's guide.

I followed the steps, I noticed the Sandy bridge instructions about Clover install.

I used the generic EFI folder and put the kexts in the folders I found in OEM, but I always get kernel panic with the same power error.

NullCPUPowerManagement does not work either.

 

I have SSDT generated by a script running fine with Yosemite. I have tried using it for the USB and without the SSDT - same  kernel panic.

I have used the provided DSDT and also the old working DSDT which I used for Yosemite - same kernel panic.

 

Please help me find what I am doing wrong. I suspect that I am not preparing correctly the EFI folder with the provided files for E6220

 

Thanks in advance!

Link to comment
Share on other sites

Many thanks for the quick reply.  I have placed them there. I browsed all folders previously and didn't find Kexts folder anywhere but OEM (is this to be expected?), so I just created /EFI/Clover/Kexts/Other 
 
Now something else happens after I add -v flag to look at errors.
 
30 seconds nothing and then one line appears with only these symbols "++++++++++++++++++++++++++++++++++++++++" and system reboots.
 
I have no idea why I am having this kind of trouble and I can't even see the welcome screen of El Capitan with so compatible hardware.
When I didn't know what I am doing and I was trying to install Yosemite - I could at least read some error message and look for a solution, but now I am in a dead end.
 
Your expert advice will be much appreciated.

Link to comment
Share on other sites

Thanks for creating a separate topic for my troubles.

 

I do not see any power related kernel panic after you told me where to put the files from the E6220 zip from your guide.

 

Clover starts and I add the -v flag to see errors, then blank screen for 30 seconds and I am getting a line like this +++++++++++++++++++++++++++++++++++ at the top of the screen, only plus symbols and system restarts by itself.

 

I have tried with Clover 3320 and 3333, I have tried with the EFI folder as it comes after Clover install and just putting the E6220 files to the correct location.

I have tried by replacing it with the generic EFI folder from the guide + adding the E6220 where they belong.

 

Then, I realized that the zip with E6220 files comes with SSDT which may be for the i5 processor, and I have i7, so I used the working SSDT , which I use for Yosemite - same ++++++++ and reboot.  I decided to run without any SSDT - same line with ++++ and reboot.

I have put NullCPUPowerManagement, although I do not see power related panic - just to try , and I get same 20 times plus + symbols in a line at the top and then system restarts.

 

The only different thing happens when I use Clover 3333 and leave the EFI as it is created by Clover and put the kexts,config-plist and DSDT in the correct place without SSDT... Then I see this weird line with "++++++++++++++++++++" again and system reboots, but I can spot for a millisecond than another line shows up in the place of the "++++++++++++++++++++++++" , but it shows for a millisecond before reboot and I can't read it. It's so fast that I can't read even 3-4 symbols, but I notice that it replaces the plus signs for a millisecond before reboot.

 

I guess I have to somehow make Clover log this error line which appears for a millisecond before reboot and then we will have a clue what is wrong ?

 

I have just read how to make Clover write a log file and I will be back if it works and show the error.

Link to comment
Share on other sites

I have tried to add bootflags for logs after reading this:

http://clover-wiki.zetam.org/Configuration/Boot#boot_arguments

 

But nothing happens and when I use -x for safe mode , the only difference is that the line with plus signs appears after the line saying that it's trying to boot in safe mode.

 

If I was getting anything which makes sense - I'd read and find the solution , but my error message just looks like this:

 

++++++++++++++++++++++++++++++++++++++++++++++++++++

 

and then system restarts by itself.

 

I hope this kind of error message has appeared to someone else and I can get some ideas what could be wrong.

I'd appreciate any help or suggestion.

Thanks in advance!

Link to comment
Share on other sites

I mount the EFI partition using EFI mounter app, which was included in the tools. It's definitely a separate partition, not the root folder of the USB which mounts automatically.

 

Things changed after your advice about which folder should be created for the kexts from the bootpack.

 

No more kernel panic related to power, but I don't get an error that tells me what is wrong... It's just one line "+++++++++++++++++++++++++" and reboot.

 

I will probably destroy the contents of the USB and start to create it again as per the guide, but I don't expect different results, because I have followed similar guide for Yosemite and everything was clear, easy and familiar to me until the step about combining the generic EFI folder with the bootpack, because I had no idea what is the correct directory structure, but now I know it and I am sure that I did it correct, but the error message is just +++++++++++++ and it does not mean anything to me.

Link to comment
Share on other sites

  • Moderators

Did you install clover loader according to this config? 

 

  • Install Clover in the ESP
  • Bootloader/Install boot0af in MBR
  • CloverEFI/CloverEFI 64-bits SATA

or 

  • Install for UEFI booting only
  • Install Clover in the ESP
  • Drivers64UEFI\OsxAptioFixDrv-64

You should use the 1st, the second is for UEFI BIOS only and this model has some issue and not working right.

Make sure to set your BIOS correctly too. Set to 'Load default', apply then set SATA Operations to AHCI. Leave the rest as is.

Link to comment
Share on other sites

I am sure that I install everything correctly as listed in the guide and I am getting the same error message with a line with plus symbols.

 

8GB USB is not enough and I get error about not enough space. I used 128GB , is it possible to fail due to being too large ?

 

I can only guess that it's not working because I have i7 processor unlike most E6220 with i5.

 

Anyway, it seems that I am stuck at using Yosemite 10.10.5 . It's still much better than Windows, but I wish I had a way to troubleshoot, because error message like this one "++++++++++++++++++++++++++++++++++++++++" does not mean anything...and can't point me to what's wrong.

Link to comment
Share on other sites

 Share

×
×
  • Create New...