Jump to content

Install usb won't boot for Dell 3340


rcboosted
 Share

Recommended Posts

I followed this https://osxlatitude.com/index.php?/topic/8506-dell-latitude-inspiron-el-capitan-clover-guide/ to create a install USB.  Everything seemed really clear on the creation of the usb until the last part where:

 

28. After installation of Clover, the hidden EFI Partition will appear on the Desktop

29. Download the EFI folderfor your model in post #2, rename it as EFI to the root of the “EFI†partition, replacing the existing folder ( not merge)

 

So I dragged the "3340" folder that was created from 3340.zip I downloaded (after renaming to EFI) to the mount point "EFI" that was automatically mounted after Clover install.  OSX asked if I want to overwrite or merge, withe EFI folder, I overwrote.  After that, I can't unmount EFI, it keeps saying it's busy.  I shutdown the system and removed it.

 

On boot, I tapped F12, got the boot menu, but under UEFI, it did not have the OSX install listed.  Just the internal drive or Window boot manager.  If I choose legacy and book from usb, it says invalid partition table.  The BIOS was set up per the guide:

 

  • Sata Operaton -> AHCI
  • Secure Boot -> Disabled
  • Boot List Option -> UEFI. 
  • Enable Legacy Option Rom

 What am I doing wrong?  I tried 2 different USB drives just to be sure.

 

 

 

*edit*  I figured it out.  I missed the part about downloading the clover_efi.zip, so I was missing the all important "boot" directory.

Link to comment
Share on other sites

  • Replies 37
  • Created
  • Last Reply

Top Posters In This Topic

As big as it is, I missed it initially.  I was able to get it working after following that.  

 

So I got 10.11.2 installed without issues after I got the install USB created. Would the screen brightness work using the Fn key shortcuts?  Any help would be appreciated!

 

I think I read somewhere that Intel wireless cards aren't supported.  I opened up the laptop, and sure enough, I've got an intel wireless-ac 7260 card.  Dang it.  Any recommendation from the list here https://osxlatitude.com/index.php?/topic/2120-inventory-of-unsupported-and-supported-wireless-cards/ internal card for easy OOB support with BT 4.x? My card is M.2 NGFF, so I may only have 1 choice.

Dell     DW1560        NGFF M.2         14e4-43b1    BCM4352       A/B/G/N/AC  ?  ?  Y   Y    Y   Y   N     DSDT or Brcm4360 patch

 

This is the simplest install I've done on a Hackintosh.  Thank you Jake for putting in all the work to make it happen.

Link to comment
Share on other sites

Thanks for the quick response.  I will look for a DW1560, they seem to be hard to find at a good price.
 
As for brightness changes, I got Karabiner, it worked great on F6.  But my keyboard is using F11/F12 for brightness changes.  I looked at the xml file and edited to use F11/F12, it seems to work. But it's the opposite of volume changes.  Volume changes need Fn to be held down, while F11/F12 does not.  I see F6 is called PC_SCROLLLOCK, I guess I need to know what F11 and F12 are called to map it to that instead of F11/F12 directly.

Link to comment
Share on other sites

  • Moderators

Really easy to get them working. Just need the following kexts found in my E7450 bootpack.

Just install them to /S/L/E or /L/E

FakePCIID

FakePCIID_BCM94352Z_as_BCM94360CS2

BrcmPatchRAM2

 

You might also look at the hand-off and 5GB fix found in my config file under kextToPatch

Link to comment
Share on other sites

 Share


×
×
  • Create New...