Jump to content
PayPal donations: [email protected] ×
Pupilliam

M6600 Setup

Recommended Posts

Make sure you define the correct path in BIOS if you choose UEFI mode.

 

Caution with the OP's config file though because it carries some incorrect settings and that can lead to confusion. For instance:

  • on the graphics side, he used the discrete nVidia GPU and correctly activated nVidia injection but kept some incorrect Haswell HD4600 Azul framebuffer layout-id at the same time, something obviously not applicable on a SandyBridge HD3000 platform.
  • on the audio side, he used AppleHDA patches for ALC292 codec when the laptop appears fitted with IDT 92HD90 codec so it's quite normal he could not get audio through AppleHDA.
  • on the SMBIOS side, he used MBP10,1 which is an IvyBridge platform with nVidia GPU. One could have expected SandyBridge models such as MBP8,1 (HD3000) or MBP8,2/8,3 (HD3000 + AMD). But maybe that was necessary to get the nVidia dGPU to work.

Share this post


Link to post
Share on other sites

Hey, sorry I was having some issues with my job. I'll be able to update the guide very soon.

 

As for the UEFI boot, you need to make sure you have UEFI boot selected in BIOS.

Additionally, if your EFI folder doesn't have /EFI/Boot/BOOTX64.efi , it won't load the Clover without custom-defining the path.

 

Herve, thank you for pointing out the errors in my config file, I will fix them ASAP.

I had based my config off of the M6800 one, so that would explain the first two issues.

 

The SMBIOS configuration is because I would get a black screen whether or not I was using discrete vs. onboard. Changing to the odd profile fixed it.

When I get my machine up and running again, I will see to these issues.

Share this post


Link to post
Share on other sites

I am interested and waiting for the full details.

 

BTW, I used your EFI folder with macOS 10.12.2 and edited the plist file to use MCP10.1 instead of MCP6.2 and it works fine for me but I am using clover installed in the EFI partition with boot sector set to bootaf

 

I have three pending issues, the USB3 is not working (I tried the Generic USB3 and injectall by rehabmab but it's not working) as well as the Audio drivers and I can't set the nVidia web driver as default to enhance the graphic performance, I must pick it from the options in every boot.

 

I used VoodooHDA but it can't detect the audio card.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...