Jump to content
offficial_florin

macOS on Latitude 7370

Recommended Posts

Quick question, is there another way to get the BIOS for this machine without reinstalling windows? I cannot get the BIOS through any method I've tried, such as:

* WinPE with Universal BIOS Backup Toolkit

* Unzipping the .exe from dell

Share this post


Link to post
Share on other sites

Alright! I got the graphics working. I checked everything required in the guide, but my commands ended up being the EXACT same. I have full acceleration working on the HD515 with '0x191e0000' as my platform ID. So, now I just need WiFi working, which is proving to be a bear, sadly. 

Share this post


Link to post
Share on other sites

I have the FakePCIID Intel HD/FakePCIID kexts in /S/L/E because I can remove those in single user mode easier than in the Clover folder. I get KPs on loading the AirPort4360 family kext when I have the FakePCIID_Broadcom kext, so I think I need a DSDT patch.

 

EDIT: having trouble uploading

Clover.zip

Share this post


Link to post
Share on other sites

Actually, I believe its an ALC3266, codec ALC298 according to the manual here: https://cdn.cnetcontent.com/e9/cd/e9cd9867-d3d2-4d12-999f-193996bbb1a6.pdf. I think there are different configs of the 7370. I did try the ALC256 kexts, but I haven't seen any outputs in Audio

Share this post


Link to post
Share on other sites

How'd you achieve full QE/CI? Was it through setting DVMT to 96MB (0x03) with EFI Shell?

What's value was it? 0x432 as my E7470?

 

I'll add the correct patched AppleHDA (by Joe82) and DSDT/SSDT soon. Just need a little time to work on it. Hopefully the DSDT will get your wireless working with the kexts from Rehabman.

You could check what codec is on your system in the BIOS.

Share this post


Link to post
Share on other sites

Here, try this.

Replace the Patched folder with the attached. Replace Config.plist, I replaced the ALC293 patches with ALC256. Install the Apple_ALC256 to /L/E and repair permission and rebuild cache.

Make sure to remove Apple_ALC293.kext if you had it installed. 

From your Clover folder attached, remove 10.11 folder, only use Other. 

Move the 2 kexts BrcmPatchRAM2 & BrcmFirmwareRepo to /L/E

For USBInjectAll to work, you'll need to move it into Other, it won't load from where it was now.

Download and add IntelBacklight to Other as well for Brightness control.

For wireless BCM4352z to work, add FakePCIID & FakePCIID_Broadcom_WiFi to /L/E

 

Make sure to repair permission and rebuild cache

      sudo chmod -Rf 755 /L*/E*

      sudo chown -Rf 0:0 /L*/E*
      sudo touch -f /L*/E*
      sudo chmod -Rf 755 /S*/L*/E*
      sudo chown -Rf 0:0 /S*/L*/E*
      sudo touch -f /S*/L*/E*
      sudo kextcache -Boot -U /

Latitude 7370.zip

Share this post


Link to post
Share on other sites

your smbios is wrong. seems to be mixed with mba5,1 and mbp11,2. try correcting that with Clover Configurator

 

If that still fails, we'll have to repatch your DSDT/SSDT file since you have changed the DVMT value.

Launch Clover and hit F4. Send me the new Origin folder.

 

Note: You should be able to boot by going into Clover Option. Disable DropOEM SSDT, and uncheck all the SSDT below that option.

Also change DSDT.aml to BIOS.aml, that should get you back into the Desktop.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...