Jump to content

D630 Intel Sleep Problems


torrent99
 Share

Recommended Posts

Hi,

 

I've just installed Snow Leopard from the USB Stick image on the wiki.

Unfortunately sleep just doesn't work at all.

 

Basically all that happens is that the monitor goes black and the disc light flickers for a sec.

Then it sticks in a mode with the power light and bluetooth light on, fans whirring but no other activity.

If I press the power button nothing happens.

(if I hold it for a few secs it powers down forcefully as you'd expect)

 

I've tried following the sleep guide on the wiki. No change. (even tried swapping the touch and rm statements as that made more sense to me!)

 

 

Vital statistics:

Latitude D630 Intel

Bios A17

 

Built it by setting bios to default values. Then installed from USB.

Wouldn't boot on first go so I set SATA mode to EHCI which let it boot.

 

Then installed EDP 1.9.2

 

 

Anybody any ideas?

 

Cheers

 

Steve

Link to comment
Share on other sites

Just tried that.

 

Doesn't work I'm afraid. Did a reboot immediatly after. Then when it had started up again pressed the power button & clicked sleep. Same symptoms, Power light + bluetooth light, blank screen (no fans). Unresponsive to power button (apart from 4sec hold down), keyboard & lid.

 

 

Also checked that USB Wakeup in the BIOS is disabled (as mentioned in another thread).

 

 

Any ideas?

Link to comment
Share on other sites

and you guys are using a password? that's the most important part....

 

Using a "system password" on the bios as described on the wiki. Not setting the "ask for password after sleep" in OSX security settings.

 

Pressing the power button after sleep does nothing though. No fans. No disk. No signs of life. Just the power light (steady not pulsing) and bluetooth light. No changes in either of them with power button.

 

Anything I can provide for debugging?

 

 

(For a hardware check, it was working under Ubuntu. So the hardware's ok)

 

Cheers for your help

Steve

Link to comment
Share on other sites

SUCCESS!!!

 

Without removing the bluetooth hardware, though I've only just seen that and it's a great suggestion. Should have thought of it myself having done similar sorts of things debugging sleep issues on Linux (remove any optional hardware you can).

 

The way I got it working was to rerun edptool.command and configure as follows:

 

1) Machine type 6 = D630 Intel

2) Apples PS2 Controller for mouse (seems to work OK on mine)

3) n = Use Apples power management

4) 0 = none no battery management (this comes up as VoodooBattery.kext on the summary)

5) Speedstep = no

 

This works for me, now I'm going to keep re-running edp changing one option at a time until it breaks! I suspect it's the power management....

 

(EDIT: Yes it was Screen 3 Power Management, reverting to Apples power mgmt)

 

Cheers for your help!

 

Steve

Link to comment
Share on other sites

 Share

×
×
  • Create New...