Jump to content

ASUS A555LA: fine tuning


black.dragon74
 Share

Recommended Posts

Hello people,

 

I have almost managed to turn my ASUS A555LA laptop into a perfect MacBook. (Yeah, guide will be available on this forum in a couple of days)

 

The stuffs not working as of now are:-

 

1. VGA Port (Haswell IGPU doesn't support it. So, ignored)

2. Atheros AR9565 Bluetooth (In fact, it is a combo WIFI+BT card)

 

So, here is a brief synopsis. The Bluetooth was working when I freshly installed OS X and also installed BTFirmwareUploader to SLE.

 

It was working fine until I don't know what happened. Maybe I applied some PNLF patches to DSDT?

 

I removed those patches and yet it was not working. 

 

Things I have tried:-

1. Simulating version of Windows by _OSI edits in ACPI tables. (Tried 2001, 2009, 2012, 2013, 2015 and Linux)

2. Reinstalling BTFirmwareUploader.

3. Updating kext caches.

 

ACPI hotpatches I'm using:- (Please tell is one of them interferes with Bluetooth)

1. Change EHC1 to EH01

2. Change EHC2 to EH02

3. Change _OSI to XOSI

4. Change HECI to IMEI

5. Change SAT0 to SATA

 

I am attaching my IOREG and ACPI tables down below. Please assist me.

IOREG.zip

ACPI.zip

Link to comment
Share on other sites

I just found something that interested me, look at the "Bluetooth" section output from system info:-

Apple Bluetooth Software Version:	5.0.4f18
  Hardware, Features, and Settings:
  Name:	MacBook Air
  Address:	80-a5-89-3d-86-8a
  Bluetooth Low Energy Supported:	Yes
  Handoff Supported:	No
  Instant Hot Spot Supported:	No
  Manufacturer:	Qualcomm Atheros
  Transport:	USB
  Firmware Version:	7.12545 (7.1)
  Bluetooth Power:	On
  Discoverable:	Off
  Connectable:	No
  Auto Seek Pointing:	On
  Remote wake:	On
  Vendor ID:	0x13D3
  Product ID:	0x3423
  HCI Version:	4.1 (0x7)
  HCI Revision:	0x3101
  LMP Version:	4.1 (0x7)
  LMP Subversion:	0x01
  Device Type (Major):	Computer
  Device Type (Complete):	Mac Portable
  Composite Class Of Device:	0x38010C
  Device Class (Major):	0x01
  Device Class (Minor):	0x03
  Service Class:	0x1C0
  Auto Seek Keyboard:	On
  Services:
  Bluetooth File Transfer:
  Folder other devices can browse:	~/Public
  When receiving items:	Accept all without warning
  State:	Disabled
  Bluetooth File Exchange:
  Folder for accepted items:	~/Downloads
  When other items are accepted:	Save to location
  When receiving items:	Accept all without warning
  State:	Disabled
  Bluetooth Internet Sharing:
  State:	Disabled
  Incoming Serial Ports:
  Bluetooth-Incoming-Port:
  RFCOMM Channel:	3
  Requires Authentication:	No

Any ideas? How to enable those disabled services?

Link to comment
Share on other sites

 Share

×
×
  • Create New...