Jump to content

Dell Latitude E6220 Ports Problem


Recommended Posts

Hi everyone, first of all I wanna thank Hervé for his fantastic guide on how to hackintosh our Latitude E6220.

I want to start saying that I'm running Sierra, but I haven't followed the guide entirely, because, after the installation completed and I booted into the main HDD, I installed Clover instead of Enoch.

I did this because I basically hate those legacy bootloaders, as they gave me lots of problems when I hackintoshed my other laptop, an Acer Aspire 5750G, so I don't want to use them if it's not mandatory.

Also, I don't want to tamper with S/L/E if I can.

Right now almost everything is working, but I have a little strange problem.

When I first boot up the laptop, the eSata port does not work, and the SD card reader, even though is recognized, doesn't show any card in it.

However, if I put the computer to sleep, then I wake it up, both start working without a hitch, I can hotplug the eSata port and the reader mounts without any problem.


Is there a way to fix this under Clover?


My lappy:

Dell Latitude E6220

i5-2520M, HD3000

8GB 1333MHz RAM

macOS 10.12.5 Sierra

Clover r4077, using Hervé's DSDT and generated SSDT

Boot args:


I attach my config.plist, I think it could be useful.


Thanks in advance


Link to comment
Share on other sites

Well, it didn't work.
At first it seemed to function correctly, but after a reboot it was like before.
I also tried to copy your whole package, and I also reinstalled Clover (I used the BitBlocksIO SATA driver before, I thought switching to the basic SATA would've helped), but nothing worked.
As a plus, now the laptop wakes up on its own the first time I put it to sleep, but the subsequent sleeps work fine and the it stays asleep.
Could the fact that I edited my FakeSMC to enable my WWAN card contribute to the problem? (I don't think so, since it doesn't work even with the FakeSMC from your package)

Link to comment
Share on other sites


  • Create New...