Jump to content

[SOLVED] E5420 Sierra USB not working


Recommended Posts

Hello again,


I have been using Sierra without issues until today when I tried (for first time after upgraded it) a USB drive and it wasn't detected by the system.


That was weird, so I started to try with different USB-things and I realized that, for example, my android phone was charging but not detected, the iPad was not even charging and all the usb drives weren't detected 


I used to have Mavericks before and I didn't have this issues... my current setup goes with A14 Bios, i3 and HD3000, 4 GB Ram, 250 SDD and 500 HDD.


Could you help me?



Link to comment
Share on other sites

I have been doing some research and seems like the sabios doesn't reference in some way to my usb ports... I haven't ha any issues before because I had been using Yosemite but now in Sierra all the USB ports are not working


Any help?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...