Jump to content

[SOLVED] E7470 - Kernel panic on boot when docked, no external video, no brightness adjustment on internal screen


Recommended Posts

So this is a new wrinkle. Whee! :)


I brought it to the office today and docked it. When I resumed from sleep the external display powered up, detected no signal, went back to sleep. External display is Display port from the dock. Wired ethernet / WiFi / bluetooth / USB all work fine.


So I rebooted and got this kernel panic:



I booted into Clover, went into Options / ACPI, renamed to BIOS.aml, cleared the "All OEM" checkbox, selected all the DSDT entries below that, then booted up and it worked fine. Now my Origin folder looks like a dumpster, lol lol lol:



Origin zipped and uploaded here. origin.zip'


I've also uploaded my Patched folder. patched.zip


Final wrinkle: my WiFi performance is *awful*. It takes forever to pick up an IP address through DHCP on boot, and my Speedtest.net maxes out at 55-60 Mbps download, where under Ubuntu is 180 Mbps or more, and my iPhone is closer to 230 Mbps.


I feel like I'm really close to getting this working. That said, I don't understand what I'm doing, just trying the things that Jake and Hervé tell me to; can anybody point me toward documentation that explains what DSDT and .aml and Origin vs. Patched, and what all the options in Clover Configurator mean? I'd like to be smarter (and less helpless!) than I am.


And again, thanks to all of you who give your time and energy to this. I'm deeply grateful. When I get this machine tweaked just right it'll be the most perfect Mac I've ever owned.

Link to comment
Share on other sites

Update: tested WiFi performance here at the office and it's perfectly respectable 144 Mbps down / 210 Mbps up, so I guess it's a configuration issue at home. *grumble grumble*


I'll deal with it.


Still fighting through the missing display brightness and external display when docked issues, though I seem to have gotten rid of the kernel panic by clearing out my origin folder and using F4 in Clover to re-dump. My patched folder is empty now, though... could that be the problem?

Link to comment
Share on other sites

Update again: (yes it's a slow day at work)



  1. Downloaded E7x70_BIOSv1.17.5.zip from post #3 of this install guide
  2. From that extracted zip file I replaced the following:
    1. EFI/EFI/CLOVER/ACPI folder
    2. EFI/EFI/CLOVER/Kexts folder
    3. EFI/EFI/CLOVER/config.plist file
  3. Copied the EFI/EFI/CLOVER/Kexts/LE kexts over to Mac OS/Library/Extensions (replace all as needed, ignored the error messages)
  4. Launched a Terminal window, ran su -s to get into a sudo shell, and ran the permission.sh script from the post-install tools
  5. Rebooted... hard crash. No kernel panic, just Apple logo, progress bar, then power cycle and BIOS POST.

So I booted into Clover, went into Options / ACPI, renamed to BIOS.aml, cleared the "All OEM" checkbox, selected all the DSDT entries below that, then booted up and... oh hey look, Displayport is working!



But it's only running my 4k external display at 1080P:



Drat. And still no display brightness adjustment. But WiFi is still working, and bluetooth / Airdrop, and USB and wired ethernet and etc. So progress!


So I'm still hoping for help. Please and thank you, a thousand times over.

Link to comment
Share on other sites

Sweet, I'll give that a shot tomorrow. Thank you!


Of course, when I got home it wouldn't wake up from sleep, and then when I rebooted WiFi was broken. :|


So I emptied E/E/C/A/patched and rebooted; crash. So I rebooted with All OEM DSST unchecked. WiFi is back. I'm mystified. I'm gonna need to create a spreadsheet with a list of test conditions and variables, lol.

Link to comment
Share on other sites

So after completely bricking my system, I'm not sure how, I did a bare metal install from scratch, using Clover 4173 and the attached patched files, and success! Wifi works, brightness works, audio works, dock works, DisplayPort works. I think I'm gonna quit while I'm ahead. Thank you thank you thank you, I'll be donating to the site shortly.

Link to comment
Share on other sites


  • Create New...