Jump to content

ntrung03

Members
  • Content Count

    17
  • Joined

  • Last visited

Community Reputation

0 Neutral

About ntrung03

  • Rank
    Private First Class

Profile Information

  • Gender
    Not Telling

Recent Profile Visitors

344 profile views
  1. Recently got backlight hotkey working. Here is the EFI folder (A11 BIOS) The sleep issue still persists. P/s: for anyone struggling with this issue, you can try Block Sleep (S3 state) from BIOS. It works. Can't fail if you don't sleep at all (Mind your power usage if you are running on battery) Before using this patch, please make sure that the ACPI patch _OSI to XOSI is done correctly because the number '14' is DSDT-dependent(BIOS version ig). The issue is that "\SB.OSID" would be compiled to "SB_OSID" which makes the replacement done incorrectly P/s: you might want to checkout iasl -l (the lowercase L) P/s2: The sleep/wake failure issue still persists even on A20 BIOS, updating BIOS might cause Wifi and Bluetooth to stop working. However, if you still want to do so, you can fix the issue by using SSDTTime to generate FixHPET patches for the dumped DSDT(use linux), remember to add the new ACPI patches and remove the old ones from config.plist. Block Sleep (S3 state) should stay ticked. It glitches the graphics on shutdown. OC.zip
  2. Hi, I am using Catalina(10.15.6/19G2021) on Dell Latitude E6230, BIOS version A11 (no battery for updating) The wifi chip is DW1510, BT is DW380 The patched DSDT cause the machine to boot and the screen will go dark when it reach the login screen. As a result, I worked on a dynamic (hot patch) DSDT Backlight, audio, trackpad, USB3, ...etc are working nicely. Also the boot time is way better than Clover. BTW, The backlight hotkeys(fn+arrow up/down) (IOWMIFamily) haven't work yet for now, but I will be working on that and will update soon. Except when the machine go into sleep mode, It restarts with this log Sleep Wake failure in EFI Failure code:: 0xffffffff 0x0000001f Please IGNORE the below stackshot ================================================================ Date/Time: 2020-08-19 19:19:41 +0700 OS Version: ??? ??? (Build ???) Architecture: x86_64 Report Version: 29 Data Source: Stackshots Shared Cache: 0xf32000 8CEC7810-03FA-3C33-AD6A-609CD0C6299E Event: Sleep Wake Failure Duration: 0.00s Steps: 1 Time Awake Since Boot: 33s Process: swd [351] Architecture: x86_64 Footprint: 416 KB Start time: 2020-08-19 19:19:41 +0700 End time: 2020-08-19 19:19:41 +0700 Num samples: 1 (1) Thread 0x887 1 sample (1) priority 3 (base 4) <thread QoS background (requested background), thread darwinbg, process darwinbg, IO tier 2> 1 start + 1 (libdyld.dylib + 109769) [0x7fff68216cc9] 1 1 ??? [0x100ce4454] 1 1 ??? [0x100ce41dd] 1 1 __stack_snapshot_with_config + 10 (libsystem_kernel.dylib + 135862) [0x7fff683782b6] 1 *1 ??? [0xffffff80002c1206] 1 *1 ??? [0xffffff8000984c37] 1 *1 ??? [0xffffff800089d7c1] 1 *1 ??? [0xffffff80002e49e7] (running) 1 Binary Images: 0x7fff681fc000 - 0x7fff68232fff libdyld.dylib (750.6) <789A18C2-8AC7-3C88-813D-CD674376585D> /usr/lib/system/libdyld.dylib 0x7fff68357000 - 0x7fff68383fff libsystem_kernel.dylib (6153.141.1) <2B6311E6-6240-3EF7-8C87-475B66F7452C> /usr/lib/system/libsystem_kernel.dylib # pmset -g System-wide power settings: Currently in use: standbydelaylow 4200 standby 0 womp 1 halfdim 1 hibernatefile /var/vm/sleepimage networkoversleep 0 disksleep 10 standbydelayhigh 4200 sleep 10 (sleep prevented by coreaudiod) autopoweroffdelay 259200 hibernatemode 0 autopoweroff 0 ttyskeepawake 1 displaysleep 10 highstandbythreshold 50 lidwake 1 I appreciate all your help. Thanks a lot. A few side questions: - The machine always restarts on shutdown, even when I shutdown with an Arch Linux live usb, Resetting BIOS default/EC Reset doesn't work for me. Does anybody have the same issue? I think it has something to do with my battery, which cannot even hold any charge. OC.zip
  3. http://www.insanelymac.com/forum/topic/330190-dell-keyboard-hotkeys-remapping/ Use IOWMIFamily.kext for Fn Up/Down for brightness
  4. I have just enabled hibernatemode 25 and try hibernate my hackintosh 10.13.1. But it reboot early after select to any macOS boot option from Prebooter to Recovery. There weren't any "Cancel hibernate wake" so i decided to use the old clover rev on the usb and select that option but it not working! deleting nvram.plist from EFI Shell doesn't help, too!THANKS for HELPING! P/s: it reboot early with 2 lines: 1: osxaptiofixdrv-64 starting override... 2:using relic blocks:yes hibernate wake:no
  5. 1. i use natural scrolling. But when i pinch to zoom, it got inverted to natural. How to invert it back? 2. I couldn't invoke the notification center with the trackpad. Any solution? Thanks all. ALPS: Found a V3 Rushmore TouchPad with ID: E7=0x73 0x03 0x0a, EC=0x88 0x08 0x1d
  6. My E6230 running High Sierra always recognized External drive on USB2.0 as internal disk. But the drive on the usb3.0 port was recognized correctly as external. How to fix this? External icon patch on AppleAHCIPort applied.
  7. Sorry, I meant airdrop and handoff
  8. I just got my new DW1510 arrived for replacement of Intel Centrino Advanced 6205. Wifi works great. Rebranded with Vendor: 0x106B / Product: 0x0093, following http://www.osxlatitude.com/rebranding-broadcom-802-11abgn-cards-as-airport-extreme/ But the problem is airdrop is kind of not working, It couldn't detect a another 6+ in the same wifi. Bluetooth DW380. Could someone help me in enabling airport? Thanks
  9. My hackintosh CPU core temperature usually go over 55C and it makes the palmrest too hot and uncomfortable. Could someone fix the dsdt to keep the temperature for cpu core for about 40-50C ?Thanks Here is my DSDT! Jake Lo sent me this few months ago. System info: -FakeSMC: newest from Rehabman -SMBIOS: MBP9,2 DSDT.aml.zip
  10. It works well except I can't move the mouse with my finger tips. I think I was too lazy to test that keyboard
  11. It just copy&paste. The R6B6 Jake Lo provided in his bootpack was good, except the trackpad failed on HS. So I grabbed the trackpad plugin from here and paste to Plugin folder of the R6B6 and I got over the keyboard caplocks and the trackpad prefpane missing from R4 and R5. Long in short, this is the kext I am using VoodooPS2Controller-HS.kext.zip P/s: this trackpad plugin required a little bit more finger touching surface in order to move the mouse
  12. Got it working with default prefpane. I will upload the modified kext if anyone requested.
  13. Well, I decided to patch the trackpad plugin of the R6B6 with the release 5 ones. It went well except the prefpane, It fail with the old error with class sgrp invalid index.
  14. The version I grabbed from Hervé Enoch bootpack seem a laggy a little bit.
×
×
  • Create New...