Jump to content

bulletbob

Members
  • Content Count

    10
  • Joined

  • Last visited

Community Reputation

0 Neutral

About bulletbob

  • Rank
    Private First Class
  1. Chess didn't play right. I'm trying your post install pack now.
  2. I installed your applehdgraphics kext on my t410 (nvs) running el cap with kext helper then put the HDD in my x201. So far it works like a charm. I didn't use any efi or dsdt files from your kit just the kext & HDD of el cap from my t410
  3. bulletbob

    X201 sleep issues & Wifi wont turn on DW1510

    bcm94322hm8l is a rev2 card flashed to AirPort Extreme (0x14E4, 0x93) still wont turn on Pasted system info Software Versions: CoreWLAN: 4.3.3 (433.48) CoreWLANKit: 3.3.2 (332.36) Menu Extra: 9.3.2 (932.35) System Information: 9.0 (900.8) IO80211 Family: 6.4 (640.36) Diagnostics: 3.0 (300.40) AirPort Utility: 6.3.2 (632.3) Interfaces: en1: Card Type: AirPort Extreme (0x14E4, 0x93) Firmware Version: Broadcom BCM43xx 1.0 (6.30.223.154.65) MAC Address: c4:17:fe:00:6f:5b Locale: FCC Country Code: US Supported PHY Modes: 802.11 a/b/g/n Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 132, 136, 140, 149, 153, 157, 161, 165 Wake On Wireless: Supported AirDrop: Supported Status: Off
  4. So i bought a x201 on the cheap and followed the install guide to get 10.9 running after flashing the bios whitelist fix in windows, any who, i bought a dell1510 bcm94322hm8l card and installed it. the os detects it as 3rd party but with airdrop support and all that, but it will not turn on. I have tried a couple of things to get it going, 1 was deleting the pref plist, because my card is showing as en1 not en0, en0 is my ethernet. that didnt work. i tried the command "sudo networksetup -setairportpower en1 on" that did nothing. i tried removing wifi from network list and "make service inactive" rebooting and enabling it again. im using the dsdt from page 3 of the guide to install mav on the x201 from this forum, maybe its for a ar card sometimes when i reboot my keyboard and mouse pad stops working and i have to reinstall the extra from my hack reboot and it works again. odd. the sleep issue is if i close my laptop , the screen comes back just where i was but nothing works and its frozen in place and i have to force the power off. im not too concerned with sleep as i shut my laptop down when its not in use but still a small aggravation. also prtsc button doesnt take screen shots. enough of my word salad ill see you folks later.
  5. bulletbob

    Success! 10.8.5 on the D430

    sudo pmset -a hibernatemode 0 to disable hibernate and sleep works! Thanks herve!
  6. bulletbob

    Success! 10.8.5 on the D430

    Small update i got the pre linked kernel command to work with out errors, so everything works here except sleep and wake. Not sure whats going on there. I couldn't get the security update 2015-006 to install either from the app store or from the combo update pkg, i used pacifist to install it, which lead to an immediate kernel panic, I used MLPF and it worked but i am back down to kernel 12.0 and the app store still says i need to install update 2015-006, so i hid the update. I havent tried mac post factor, it does have an option for 10.8, but i am uncertain how it handles 32 bit. Has anyone tried mac post factor on the d430? Question for Herve, have you gotten sleep and wake working? And if so how?
  7. bulletbob

    El Capitan or Sierra on Thinkpad X201?

    have you tried using an external monitor or with your boot set to 1440x900x32 or 1280x800x32 what ever your monitors native res is. as far as acceleration in theory the kext / patches for Yosemite should work on el cap with some tweaking. I love were your going with this, keep up the good work you'll get there!
  8. bulletbob

    Success! 10.8.5 on the D430

    well I got some good news and some bad, 1 i borked it and had to start over with the ml partition, did the updates in 64 bit mode, then rebooted into the mlpf partition"DSDT=/Extra/dsdt.aml arch=i386 -f, did mlpf for 10.8.4, booted up with arch=i386 -f . Then i noticed itunes had the incompatible icon over it, under system info it shows as 10.8.4, well i thought that was cosmetic only and would not effect apps , i was wrong. I found justins website for tutorial for changing the osx version, basically you type "sudo nano -w /System/Library/CoreServices/SystemVersion.plist" in terminal type your password and manually change it to 10.8.5 as if it was a text doc, ctrl-x to exit, hit y for yes, then enter to overwrite the old. iTunes works now. 2 the voodoo audio kext isnt causing me an issue during prelinking, see below, its doing this now: kriss-MacBook:~ kris$ sudo kextcache -system-prelinked-kernel -a i386 Password: kxld[com.apple.driver.AppleACPIEC]: The following symbols are unresolved for this kext: kxld[com.apple.driver.AppleACPIEC]: _AcpiHwRead kxld[com.apple.driver.AppleACPIEC]: _AcpiHwWrite Link failed (error code 5). Prelink failed for com.apple.driver.AppleACPIEC; aborting prelink. Failed to generate prelinked kernel. -I am going to try in single user mode 3 Mr herve thanks for replying to my post, i did as you said and changed the video title. Not here to mislead. i will suggest everyone with a d420 do the mobo swap. it takes 30 minutes and the only 5 screws that are different are the 3 that belong to the keyboard & 2 for wifi the other 15-20 are a piece of cake. 10-13$for the board, 5$for copper shims, already had thermal paste,worth it! 4 Waterfox works great for browsing and youtube upto 720p, in 1080p video it becomes a still image with music just like in my yt video. Seamonkey plays 1080p video but becomes out of sync, again its fine in 720p mode. Kodi 16 plays like a champ for me in any resolution, if you skip around the first second or so is off then it catches up.
  9. bulletbob

    Success! 10.8.5 on the D430

    kriss-MacBook:~ kris$ sudo kextcache -system-prelinked-kernel -a i386 Password: IOKitWaitQuiet() timed out. Internal error; overrun mapping executable file /System/Library/Extensions/myHack.kext/Contents/PlugIns/VoodooHDA.kext/Contents/MacOS/VoodooHDA. Internal error; overrun mapping executable file /System/Library/Extensions/myHack.kext/Contents/PlugIns/VoodooHDA.kext/Contents/MacOS/VoodooHDA. Can't link VoodooHDA.kext - architecture i386 not found Prelink failed for org.voodoo.driver.VoodooHDA; omitting from prelinked kernel. kriss-MacBook:~ kris$ thats what happens when i run script not 10 minutes more like 4 or 5 and i downloaded the newest edp and it did find the d430. still a few graphical hiccups here and there but sweet.
  10. bulletbob

    Success! 10.8.5 on the D430

    I had a sweet d420 running ubunto with a mac theme, and i wondered what would it take to hackintosh this? Well the d420 had a 1.2 coreduo and would not run anything other than snow leopard. So i looked online and came across these forums and herve's post and found out the d420's limits. i looked on ebay and found a 1.33gz core2duo mobo for 10$ and some copper shims for 5$ and i did a little swap. Anyway, I finally got Mountain Lion running in 32 bit mode. i followed herve's guide almost to the letter. edf v5 dont find squat anymore. luckily herve had a nice boot pack that had everything. one thing with the boot pack in the boot plist i had to remove arch=i386 to get it to boot the installer for 10.8.5. easy enough. then the hardest part, tracking down mlpf v0.03 for 10.8.4. i managed to find a mediafire link, then i installed it to my best usb stick and mlpf wouldnt boot...so i made a partition out of left over lion space 9 gb and had to do mlpf on the internal hd & installed with the boot flags herve provided arch=i386 -f. afterwards i had to boot into lion to run myhack and do the my fix on ml, wouldnt let me do it from ml. I did the full fix rebooted and did the script for rebuilding 32 bit cache and it failed after 10 minutes, but its working and running. Im typing this up on the frankintosh. kodi plays fine, youtube works on seamonkey. Big thanks go out to herve! I made a video
×